Anyone know how to us the Expression Engine Action Suite?

The idea of integrating Freeway Pro 5 with EE is an exciting prospect especially since there is an Action to do the ‘heavy lifting’. Until it doesn’t work out.

If anyone is familiar with the EE Action Suite from Termite Terrace Studios, this is what I have done to test the FW/EE process:

Put together a few web pages with different elements–a color background, white text, links and a placed image. Set the FW folder structure to mimic EE folders and templates, apply the EE Resources Action to the specified folder…Following all the developers EE Action documentation closely. Right so far!

Set up a server with the EE Core version in a folder with database connectivity (Yes, I ran the EE Wizard). Upload site. In the EE control panel, create the folders and templates, Save As Templates checked and set the Server Path To Upload Directory (In this case the Upload Directory is outside the EE System folder per developer recommendations) OK! So far the setup is followed to the T.

Now, here is the issue.

My test site pages are visible in EE. Text and links show, but without styling. The test image does not show up. For some reason the styling set in Freeway does not translate to EE. It’s like there is no connection to the css stylesheet in the css folder. If I check the code in EE, it appears that the template is calling the folder with the stylesheet.

I have repeated this process from top to bottom a few times to check that I am following the procedures correctly. Obviously, I am missing some trick along the way.

Anyone have any ideas to a solution?


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi John,

I’m sorry you’re having a problem. It does look like you’re doing everything correctly from what you’ve posted. Can you provide a link to your test site so I can see it and perhaps poke around a bit? You do not need to give me access to your EE install, just the test site pages as you test them.

If you do not wish to post the link publicly, you can email it directly to me. You should have my email address, or you can find it on my profile on FWTalk.

Joe


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Joe,

If there is something to be learned here, the community can benefit as well!

Here is the link to the test site:

http://maskell2.com/eedev2/index.php


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

It may be that your Upload URL set in your document setup has the “public_html” folder added.

So instead of:

http://maskell2.com/public_html/eedev2/css/sheet1.css

it should read:

http://maskell2.com/eedev2/css/sheet1.css

I just loaded up the second URL option and your css sheet loaded up.


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Dan,

I see that. I went to the EE control panel to check the template code. The code in each template is pointed at:

If I delete the ‘public_html’ for both the style sheet and resources tags, the site shows up publicly. Good!

The confusing issue is the ‘public_html’.

In the EE Admin panel, the Server Path To Upload directory is specified as:

/home/maskel2/public_html/eedev2/images/uploads/

In the templates feature this path is set at:

/home/maskel2/public_html/eedev2/template_files

Are these paths still technically correct for Expression Engine? Or does the problem lie in the FTP Upload path from Freeway?

Just trying to get this in my head before making all the resets!

Thanks for the response.


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Yes, they are. The difference you are seeing here has to do with what
a “path” is.

On the server, there is a path to the files, which can be a path
beginning from the server’s filesystem root (/) and building up from
there, like ‘/homes/username/shared/www/htdocs/’ or something like
that – starting with the forward-slash, meaning “all the way from the
top of the tree”.

Various services, like FTP and HTTP, present different virtual ‘root’
locations depending on various parameters. For an FTP or SFTP server,
where your ‘root’ is depends on who you log in as. username:email@hidden
might get you in to /homes/username/ and nowhere higher – this is
known as a chroot jail. admin:email@hidden might get
you in to /. And http usually uses either the IP address or the IP
address and the requested hostname to figure out to dump you into /
homes/username/shared/www/htdocs/ and serve you files on a read-only
basis.

So that’s a long way to say that both of these paths are correct. The
one with public_html in it is an internal (filesystem) path, and the
one without that is an external (protocol-dependent) path.

Walter

On Jan 23, 2009, at 12:32 PM, John Maskell wrote:

Are these paths still technically correct for Expression Engine? Or
does the problem lie in the FTP Upload path from Freeway?


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

It may lie in both. You said you had adjusted the “public_html” address and I can see now that the site loads up just fine. Do you need to set it to the public_html folder or can you just leave it as a folder named “eedev2” for your template folder?

It may just be a trial and error and how I usually have my sites setup is that I just use a subfolder (off the root portion) with the name of the project and then use that as my template folder or else it gets complicated with trains of folders.

Also the server path to the upload directory refers to uploading files onto your server from within EE and not through Freeway. If and when you publish a post to a weblog you’ll notice a button to upload a file and you can upload like a PDF and it will put it in that specific uploads folder.

I hope to be wrapping up a screen-cast series on using EE with Freeway that will hopefully help people get past the server side of the setup.

Hopefully that helps.


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks!

I now have an idea what the issue is, so its down to trying out a few directions.

That screencast would be very welcome… Thanks for making those screencasts. There’s nothing like seeing something visually to get that “light bulb moment”.


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

It looks like you’re on the right path. Please keep us posted on how you get it resolved, or if you have more questions.


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I really wasn’t being punny intentionally.

On 24 Jan 2009, 1:51 am, Joe Muscara wrote:

It looks like you’re on the right path.


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

In an attempt to help, my latest experience.
I’ve been helping setting up a site for someone else. In that process we decided to change the position on the server of the directory where The System (of EE) lives. (please do not ask why, previous position was like confusing))
Naturally I changed the new location in all of the path’s that EE uses.
But my Templates did not get an update by EE. FW did update the Template files, but EE did not pick them up. Because it uses a file stored in the database.
Now, I made a new Group Template Files (with exact same name etc) and made this Group the site’s Home Page.

This trick worked. Site was visible again. Database updated with this new Group.


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

OK! Lesson learned I believe.

This is the answer.

It seems the Document/Upload settings in Freeway are critical to Expression Engine use. Inserting the appropriate Document/Upload settings seems to set the tags and links that EE will use to connect to Folders and Templates.

Also, by doing this, it sets and links the External css Style Sheets and Resources folders correctly for EE, which was the problem I was having (at least on my server setup), as Dan pointed out.

To do this, I looked at the Freeway Preview page mode and changed the Document/Upload settings to get the style sheet tags to change from:

http://maskell2.com/public_html/eedev2/css/sheet1.css

to this:

http://maskell2.com/eedev2/css/sheet1.css

which, was the location on the server.

That /public_html/ being the culprit in the wrong place. I still needed /public_html/ as part of my FTP Upload from Freeway. See below:

Directory: public_html/eedev2/

Web Address: http://maskell2.com/eedev2/

That’s just the way it is. Now, when I upload other (non EE) files to the same server or my company’s server, I use:

Directory: subfoldername/project

Web Address: http://domainname.com/

(just as Dan J says)

I guess it comes down to user error and confusion.

All the paths in Expression Engine and the EE Action Suite are correct, as Walter stated.

At this point my little Expression Engine setup works and updates with every update I make in Freeway. “Houston, we have ignition”

Excuse the long response, but perhaps it will help someone else.

I will leave the test site up to keep it as a reference to this post!

http://www.maskell2.com/eedev2/


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I’m glad you got it working. I look forward to seeing how things turn out.


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options