Background box and bars show through CSS menu

Please forgive my lack of understanding if the answer to my question is something obvious. I’m trying to teach myself Freeway after previously using iWeb.

I’ve followed various tutorials and videos to create the site, but I have this strange gray box that I can’t get rid of that keeps appearing behind my CSS menu. The background of each page is a very pale gray, and I have a photo on top of it at the top. The menu is on top of that (and I did bring it to front). However, when I preview the site in Chrome, I have a gray box under the menu and two thick gray lines that go all the way across the page horizontally at the top and bottom of the menu. You can see the menu and click on it just fine. I have created the menu on my master page, and I have unchecked Background in the Actions pane. I tried checking it and having no background selected, but that didn’t fix it.

A picture is attached. Can anyone help me get rid of this crazy box? Thanks-

https://db.tt/OAiPf7ro


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

A picture is attached. Can anyone help me get rid of this crazy box? Thanks-

A link to a live web page would be far more useful for diagnosis.

Are all your items layers? They should be and that is where I would start looking.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

BTW - are you trying to use Graphic Text in your CSS menu - if so that is a No No.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I’m adding a new website (pearlharborspeaker.com) to our outreach efforts of the past (pearlharborchild.com), because “speaking” is what my wife (who IS the Pearl Harbor Child) wants to focus on. OK, so its very important that visitors to either site can easily click on a link that will take them immediately to the other site. Some of the content will be similar, but mostly different, and we need to make moving from one to the other as easy as possible. Suggestions, please on the best way to do this. Also, I can’t get the “Comments” process to work. I built the three pages, but when I browse it,
the data page comes up, but none of the fields are there. Need some help, and thanks in advance.
Larry


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Larry - please start a new thread for your topic.

Your question is not relevant to this one.

And post a link to your problem page(s)

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I’m adding a new website (pearlharborspeaker.com) to our outreach efforts of the past (pearlharborchild.com), because “speaking” is what my wife (who IS the Pearl Harbor Child) wants to focus on. OK, so its very important that visitors to either site can easily click on a link that will take them immediately to the other site. Some of the content will be similar, but mostly different, and we need to make moving from one to the other as easy as possible. Suggestions, please on the best way to do this. Also, I can’t get the “Comments” process to work. I built the three pages, but when I browse it, the data page comes up, but none of the fields are there. Need some help, and thanks in advance. Larry


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Larry,

I started this thread on a problem with my background showing through my CSS menu. Your question is on a different topic, so no one will see it here. If you go back to “Freeway Talk” and scroll all the way down to the bottom, you’ll see where you can start a new thread and give it a title that will help people see it who know the answer.

As for my thread -
Larry,

Thanks for your quick reply -

Unfortunately, I haven’t solved the problem yet. Here’s some more info that might help

  • I’m just starting the design process, so I don’t have a live site yet
  • I’m using Freeway Express, and from what I’ve read in the user guide, layers seem only to apply to Freeway Pro
  • I chose the background color by going to my master page, going to Appearance in the Inspector, and then choosing the color
  • I tried following the directions in the user guide step-by-step and recreating the menu (without even changing the font or type size, etc.), but I got the same results:
    https://db.tt/uJPrPGh1

Any other suggestions or ideas? I’ve done so little to the site that it seems odd to have such a problem.

Thanks again for your help!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Any other suggestions or ideas? I’ve done so little to the site that it seems odd to have such a problem.

This is really difficult to diagnose without being able to see a live web page.

The first thing I would stress is that your text should be Html text and NOT graphic text - by the looks of it your menu text is not a web ready font so is likely to be Graphic text.

If you want to email me your .freeway file I could have a look at for you. You will get my email address by clicking on my name at the start of any of my posts if you are looking at the FWT website. http://freewaytalk.net/thread/view/148457#m_148568

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

without even changing the font or type size, etc.

But you still have the original menu on that page that does have a non-standard font.

Try removing that menu so just to leave the one that uses Times

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Dave,

Thanks again. Deleted the non-html menu, but still had same problem. Will email you the file.

Two quick questions:

  1. How did you get the image above to show in your post? I’ve only been able to post a link.

  2. Are you saying the only choices for fonts for a menu have to be from the few HTML fonts listed in Freeway? How do so many other websites have designer fonts for their menus that match the rest of their website text?

thanks,


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

  1. Are you saying the only choices for fonts for a menu have to be from the few HTML fonts listed in Freeway? How do so many other websites have designer fonts for their menus that match the rest of their website text?

Yep - absolutely recommended, as long as you do not know how to treat custom FONTs.

Custom FONTs can be treated several ways:

  1. You owned a set of “web-safe” FONT formats so you could either use WebFont Action or Caxton action.

  2. Free services like Google WebFonts (excellent and recommended)

  3. Paid services such as Typekit.

Never define content (a menu is text, so content) as graphic - there will be a time (crystal ball oracle) google will ignore you. Be prepared on it - cause “content” is king.

Cheers

Thomas


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

You owned a set of “web-safe” FONT formats so you could either use WebFont Action or Caxton action.

As Grant is an Express user he doesn’t have an Action option so would have to use Google Web fonts or a hand coded version.

As to his original question. His issue about the CSS Menu breaking apart the graphic behind is because, in Express, the app creates a Table Based structure to hold everything together. Essentially slicing his background image and inserting it in the cell structure.

Because different Browsers render text at slightly different sizes then gaps can open up. See http://www.softpress.com/kb/questions/138/Photo+or+graphic+image+background+breaks+apart+and+displays+with+lines+or+blocks+through+it for a more complete explanation.

The fix is to apply a background, not as an item behind the other items on the page but, as a Page Background.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

the only choices for fonts for a menu have to be from the few HTML fonts listed in Freeway?

Just to clarify - Express (and Pro) users can use any font that they like on their system. However this will be converted to Gif text so that it will display the same in all browsers cross platform.

Because it is Gif text (essentially an image) then it cannot be read by screenreaders, Google etc. and will not be indexed with your site.

This leads to accessibility and SEO issues.

In order to display html text in different fonts so that everyone can see them as you intended then you need to do some code magic and provide the font information to all viewers whether they have that particular font on their system or not.

There are actions for FW Pro users to help you with this. Actions extensibility is one of the features that differentiates between Express and Pro.

Personally I believe that if you are intending to earn money from building web sites then you should invest in your tools and buy Pro. You owe that much to your clients.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Ok, so I’ve imported the image as a background image, which solved my strange box/bar problem, but I’d really like to have the image appear as a wide band across the top of my page.

I can’t find any way to size the image, though. It appears over the entire page, and I don’t see any controls that will allow me to alter the size…


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Aha! I see now from following DeltaDave’s link that it looks like I’ll need to size the image in Photoshop to fit the dimensions I want and then import it as a background. Onward… wish me luck –


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options