Blinking Text in 5 Beta

Hi All

I have been playing with 5 as I guess most of you have but I have a couple of problems that may or may not be 5 issues.

1 - Blinking Text in Firefox 3

Some of my text links (in the CSS menu and in Current Date) are blinking on a page where I am using show/hide layers with fade and sequence timer to create a fading slideshow and I don’t know why.

2 - On the same page the graphic box containers that I am using for the fading slideshow have rounded corners but in the browser I am getting white bits showing at the corners even though I have a black background behind.

The page in question:

http://www.coffeesupport.net/newtest.html

Any ideas anybody?

David


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

C’mon you lot - hasn’t anybody had a chance to look at this yet.

http://www.coffeesupport.net/newtest.html

Help please

David


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I must add that the blinking text in question actually is evident in Firefox 2.0.0.11 not 3 as previously mentioned.

http://www.coffeesupport.net/newtest.html

And there is still the problem of white bits at the corners of rounded boxes when on a black background.

David


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

A couple of non-technical suggestions or you, David, (I’ve had a look,
now I know it’s FireFox 2).

  1. White corners - If not already, try setting your show/hide images
    to Type: PNG with Colours: millions, in the Inspector graphic tab
    (third along).

  2. Blinking type - not sure on this one, but the timing does seem
    related to the sequence timer setting for the show/hide images. Try
    toggling on or off layers for the menu bar and/or the image stack.
    Also check by turning off the sequence timer.

Let us all know the result if it works - but don’t tell anyone I
suggested it, if it doesn’t!!

Colin

On 3 Feb 2008, at 12:55, DeltaDave wrote:

I must add that the blinking text in question actually is evident in
Firefox 2.0.0.11 not 3 as previously mentioned.

http://www.coffeesupport.net/newtest.html

And there is still the problem of white bits at the corners of
rounded boxes when on a black background.

David


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks for looking Colin

I must admit I didn’t realise that you would not get proper rounded corners unless you output your graphics as PNGs.

I try to stay away from them knowing that IE doesn’t handle them as well as other browsers.

Anyway I changed to PNG output and still got some white bits at the corners until I changed the anti alias from Auto to the background colour of black.

But my blinking text problem is still there.

It would appear that it relates to the ‘Fade’ duration set in the
Slave Show/Hide Layer action.

I have put up another page with different settings on the images.

http://www.coffeesupport.net/newtest.html has a fade duration setting of 3.5 while

http://www.coffeesupport.net/newtest2.html has a fade duration setting of 1.5

You will see that the navigation text in newtest never gets to full brightness while the same text in newtest2 blinks quite dramatically.

Of course you need to use Firefox 2 to see it - or does it happen in other browsers?

So how do I sort it?

Answers on a postcard please to…

David


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Yup, I can see it just fine in Firefox. That’s mighty odd looking.
It’s almost as if the text is getting a Bold setting periodically. I
looked at it in Firebug, and could not see anything about that text
changing over time as the animation happened. I was able to watch the
opacity of the various photos change in real time, but the text in
that layer was not affected in any way over time.

This is a real puzzler.

One thing you might try is to set a style on your navigation that
includes an opacity of 0.99. It might be enough to make this effect
go away.

Walter

On Feb 3, 2008, at 7:27 PM, DeltaDave wrote:

Thanks for looking Colin

I must admit I didn’t realise that you would not get proper rounded
corners unless you output your graphics as PNGs.

I try to stay away from them knowing that IE doesn’t handle them as
well as other browsers.

Anyway I changed to PNG output and still got some white bits at the
corners until I changed the anti alias from Auto to the background
colour of black.

But my blinking text problem is still there.

It would appear that it relates to the ‘Fade’ duration set in the
Slave Show/Hide Layer action.

I have put up another page with different settings on the images.

http://www.coffeesupport.net/newtest.html has a fade duration
setting of 3.5 while

http://www.coffeesupport.net/newtest2.html has a fade duration
setting of 1.5

You will see that the navigation text in newtest never gets to full
brightness while the same text in newtest2 blinks quite dramatically.

Of course you need to use Firefox 2 to see it - or does it happen
in other browsers?

So how do I sort it?

Answers on a postcard please to…

David


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sometime around 3/2/08 (at 19:27 -0500) DeltaDave said:

I must admit I didn’t realise that you would not get proper rounded
corners unless you output your graphics as PNGs.

Well… you can only get true smooth transparency with PNGs set to
‘millions of colours’ so that they include alpha channel masks. You
can get 1-bit ‘cutout’ transparency with GIFs, and if the antialias
colour is selected carefully this can be just as effective. And you
can fake transparency in JPEGs by making sure the ‘transparent’ area
is filed with the same colour (or graphic) as the underlying space,
creating the illusion of transparency.

You might find it worth nudging your fading graphics into the black
area a little so that you don’t have to worry about them blending
with the black on the upper-left and the grey on the upper-right.

As for the text blinking, I can’t think of a solution right now. And
I didn’t see it in Safari.

k


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Ideally I would like the graphics to only have a rounded corner on the top right to meet with the curve of the corner of the ‘page’ so that there is no gap between graphic and top and graphic and RHS.

Any suggestions for that one?

And I will try Walters suggestion

includes an opacity of 0.99

David


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sometime around 3/2/08 (at 19:44 -0500) Walter Lee Davis said:

Yup, I can see it just fine in Firefox. That’s mighty odd looking.
It’s almost as if the text is getting a Bold setting periodically.

It sounds to me as if Firefox is causing an emboldening effect by
compositing the text on top of itself during part of the transparency
rendering process (like duplicating an antialiased text layer in
Photoshop), then fixing this by drawing the correct, non-multiplied
type in again.

Which would mean this is a specific Firefox page rendering bug, which
would explain why it hasn’t shown up in other browsers.

Walter, does this make sense to you as a possible explanation?

k


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sometime around 3/2/08 (at 19:51 -0500) DeltaDave said:

Ideally I would like the graphics to only have a rounded corner on
the top right to meet with the curve of the corner of the ‘page’ so
that there is no gap between graphic and top and graphic and RHS.

Once you have given a graphic box rounded corners you should see
small ‘radius handles’ appear just inside each corner. Grab one of
those and drag it to set the radius of that rounded corner manually.
If you drag it out to hte original corner you’ll have a sharp,
unrounded corner there.

Nifty, huh?

k


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

But of course.

The way that 5 beta does it - and I hadn’t noticed it before - there is a small point, at 45 degrees to the corner, within the box - that can be dragged in and out.

Whereas in 4 it is as you suggest Keith - the typical Illustrator-like radius handles.

David


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Typing too slow again…


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

That’s exactly what it’s looking like, except that layer (the menu
bar) isn’t even close to the layer that’s being changed over time by
the effect. It’s not the same Z-index or anything.

Another thing you might try is to alter the effect call in the Show
Hide Layer action. (For initial experimentation, just change the
generated code.)

function FWShowHideLayer(lay, vis, ch)
{
if (ch && lay != “”)
{
vis = (vis) ? “visible” : “hidden”;
var obj = FWFindLayer(lay);
if (obj && obj.visibility != vis)
{
if(vis == “visible”)
{
obj.visibility = vis;
new Effect.Appear(lay, {duration:1.5,
delay:null,
end:0.9
});
}
else
{
new Effect.Fade(lay, {duration:1.5,
delay:null,
afterFinish:function(){
obj.visibility = vis}
});
}
}
}
}

Walter

On Feb 3, 2008, at 7:52 PM, Keith Martin wrote:

It sounds to me as if Firefox is causing an emboldening effect by
compositing the text on top of itself during part of the transparency
rendering process (like duplicating an antialiased text layer in
Photoshop), then fixing this by drawing the correct, non-multiplied
type in again.

Which would mean this is a specific Firefox page rendering bug, which
would explain why it hasn’t shown up in other browsers.

Walter, does this make sense to you as a possible explanation?


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Walter

I tried that (source code snooper) but I suspect the formatting of the text got screwed on the web and I got no fade at all.

David


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

It worked in my testing here. The only change is to add

, end:0.9

inside the innermost curly brackets of the call to Effect.Appear. What this does is keep the images that are fading in and out from ever reaching full opacity, but it also keeps the HTML from getting over-bold.

Walter


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Right Walter - I have done that at
http://www.coffeesupport.net/newtest2.html

but it didn’t do the trick.

Unless I have put it in the wrong place…which is probably quite likely.

David


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Here’s something odd. I am seeing a completely different site in
Safar (navigation menu is News, Contact Us, Links, and Search) as
opposed to Firefox (navigation menu is Home, Sourcing, Specifiers,
Members, News, Contact Us , Links, and Search).

I suspect that the blinking is actually a symptom of something deeper
here. What should the menu look like?

And you did put the code in the right place, yet it’s not working as
it did here when I tested it.

Walter

On Feb 4, 2008, at 3:28 PM, DeltaDave wrote:

Right Walter - I have done that at
http://www.coffeesupport.net/newtest2.html

but it didn’t do the trick.

Unless I have put it in the wrong place…which is probably
quite likely.

David


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Aha - that is because the first 4 items in the navigation I changed to graphic text with an opacity of 99% - as per one of your previous posts.

Obviously that has thrown another spanner in the works when it comes to Safari.

I will change that part back.

David


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Well I have changed those first 4 links back to html text and they still don’t show in Safari for me - cache issue maybe?


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I’ve just been looking into this (the blinking text issue) and it
looks like a bug in Firefox 2.0.0.11. I will continue to look for a
workaround.

On 4 Feb 2008, at 21:02, DeltaDave wrote:

Well I have changed those first 4 links back to html text and they
still don’t show in Safari for me - cache issue maybe?


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options