Carousel help.....again

Hey Walter
How are you??? I was just checking one of my scrolls and a border on a few images that were not there before have popped up. I can not find the cause. Some have half borders, some have one line above the image.
Please advise

Thanks

http://www.carlagrande.com/davidscroll.html#JWTGlennis1


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Try this. (Sorry, it involves starting over.)

Make one HTML box exactly the size that you want all of your panes to
be. This must be the largest possible size that your images will ever
appear. Set this box to have a white background and no border.

With this first box selected, draw a new graphics box directly over
the first box, making sure that the start and end of the drag to draw
never leave the first box. While you are dragging diagonally, your
mouse cursor will change from a + to a + in a box, like this [+].
Also, there will be a blue glow selection rectangle around the parent
box, to indicate that you are drawing a child within it.

Now, import your first image into this nested graphics box. Crop and
scale and add a border as you like. Make sure that any border you add
is a graphic border, not an HTML (CSS) border. You will know that you
are using the right one when you see the option to have the border
either be on the inside or the outside of the box. CSS borders do not
offer you that option.

Next, select the outer HTML box, and duplicate it in place. When you
do this, you will be creating your next pane. The panes will all be
built in this manner, with a borderless HTML box containing a
bordered graphics box. Make sure there is a small amount of padding
between the HTML box and the graphics box – by padding here I do not
mean to add padding through the Inspector, I simply mean make sure
that you never draw the graphics box touching the edges of the parent
HTML box.

When you have finished your entire stack, group it and apply the
Carousel action to the group as usual.

In short, your carousel panes should contain your art, not be made
from your art (since all of your pictures are of varying dimensions
and aspect ratios. If you were to make every image a square, or every
image a horizontal rectangle, then you could simply stack a bunch of
images, group them, and make that your Carousel. But without making
all your images in a photo editing application and importing them as
pass-through, this won’t work in your design.

Walter

On Apr 7, 2008, at 10:04 AM, Carla wrote:

Hey Walter
How are you??? I was just checking one of my scrolls and a border
on a few images that were not there before have popped up. I can
not find the cause. Some have half borders, some have one line
above the image.
Please advise

Thanks

http://www.carlagrande.com/davidscroll.html#JWTGlennis1


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hello again

I have noticed this problem on 3 of my scrolls, interesting.

I have no borders set on any images, and as you may see there is one line on some and 2 on others.

any wisdom you may have

Thx

Carla


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

ugh hyroglyphics! Ha!

I have to say that this problem was not there before I upgraded to Freeway 5. Why is this? Theses scrolls were done months ago and no border issue. This is difficult to understand.

so strange don’t you think? Walter

I will try to understand your process


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Walter

I just can not seem to get it right. Sorry
It takes me a while I just don’t understand the HTML and graphic box coordinates

I will keep trying but thanks anyway

Carla


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hello Guys

I am at a loss here. I have tried to do this new carousel and it is not working. Of course I know I am doing something wrong. I guess I do not understand your instructions.

Don’t roll your eyes… I have come a long way from stupid! Ha! At least I have made workable websites but this has stumped me.

Thx

Carla


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

What version of Freeway are you using?

Walter

On Apr 7, 2008, at 6:50 PM, Carla wrote:

Hello Guys

I am at a loss here. I have tried to do this new carousel and it is
not working. Of course I know I am doing something wrong. I guess I
do not understand your instructions.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Walter

I am on Freeway Pro 5
but I have to say again this scroll was made months ago and the problem did not occur until I upgraded to 5
to answer your question
Thanks

Carla


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

You may have not installed the Action properly in your upgraded copy
of Freeway 5. The cached version in the document will not have access
to the libraries of JavaScript code and this will cause the entire
process to fail.

Try downloading the latest version of the Action. Unzip it, and drag
the icon of the Action over the top of your Freeway icon (in the dock
or Finder) while Freeway is running. This will trigger the install
mechanism. Also, make certain that Finder has not renamed the file to
Protaculous-1.fwactionb in the process of unzipping it.

Walter

On Apr 7, 2008, at 9:34 PM, Carla wrote:

Hi Walter

I am on Freeway Pro 5
but I have to say again this scroll was made months ago and the
problem did not occur until I upgraded to 5
to answer your question
Thanks

Carla


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi again Walter

Yes I downloaded the newest action last week when I had other trouble.

Ok but I just worked on it again with a fresh mind and imported the image and scale & trim instead of scale and pad,
and… it worked … lines gone…
don’t get excited. I will work on the other problem images and give you a report.

Thx

Carla


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi everyone

well the scale and trim only worked with the image that was in question and the others blew up so that did not work.
I resized all my images to be close in size 400 px wide or 400 ht
and I looked at my images and there are no lines.

so…???

so frustrating


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Here’s what this means. The issue was not with Carousel, but rather
the Freeway scale and pad behavior. It’s possible that your image
boxes had a background color, and that this color was showing through
if the graphics box was a pixel too large in one dimension (that is,
if the image’s own background color did not cover the box’s
background color).

It might be helpful in the future for you to make a page with all of
your carousel panes showing – not stacked – and publish that and
see if the problem is there. Then you will be able to see what’s
going wrong in one layer, rather than seeing it later as a surprise.
After you have all of the Freeway graphics boxes working the way you
want them to, you could move them into a stack, group them, and apply
the Carousel action to the group.

I have been thinking (at Paul Dunning’s urging) for some time now
about a different work model for the Carousel, which would remove the
requirement to stack all the panes on top of each other. I have not
done anything about this besides think about it, but it’s definitely
coming at some point.

Walter

On Apr 8, 2008, at 10:14 AM, Carla wrote:

so…???


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Walter

what I did was in Inspector I shaved a few pixels off each side and that did the trick… All my images have a transparent background so I do not understand this problem. I blew them up in photoshop and there are no lines and no layers.

so well so far so good as this lis going ok

Thanks again

I will post again when finished and hopefully uploaded

Carla


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

What color is the background of your page? You may be seeing an anti-
aliasing bug here. It’s also possible that your images are getting
scaled to a non-integer dimension. I have seen Freeway make things an
odd dimension like 35.445 pixels tall before! If you still have a
broken image to test with, try turning Anti-Aliasing off in the
Inspector for that image and see if the problem goes away.

Walter

On Apr 8, 2008, at 10:31 AM, Carla wrote:

Hi Walter

what I did was in Inspector I shaved a few pixels off each side and
that did the trick… All my images have a transparent background so
I do not understand this problem. I blew them up in photoshop and
there are no lines and no layers.

so well so far so good as this lis going ok


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

turning anti alias off did nothing

some work and some do not… I am having a time of it but I will persevere


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

ok update!

Making the graphic box smaller is definitely working.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hello Walter and every one

Here is the link. I have only David’s scroll fixed. On to the next.
http://www.carlagrande.com/davidscroll2.html#Pic11

Still don’t understand why this all of a sudden happened as it was working perfectly for weeks before I upgraded
but oh well

best
carla


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options