Continue shopping - NOT FOUND

Hi Gang,

When I click on my continue shopping button within my shopping cart I get the following error message:

The requested URL /zyzagarus/index.html/buybook.html was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.7a mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at www.mydomain.com Port 80

Where am I going wrong?

I have bin through the cart setup in Mals 5 times and still none the wiser??!!! lol

This is the page I want it to return to:
http://www.mydomain.com/zyzagarus/buybook.html

Any help please

Worm


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The requested URL /zyzagarus/index.html/buybook.html

You can only have put the wrong URL into your cart setup because the one you have provided above is not valid ie you cannot have folder/webpage/webpage - it must be folder/folder/webpage

What have you actually entered in the cart setup - select it all and copy it out into a text box or editor to check incase you have something in there unexpected.

Worth copying and pasting from a known source after deleting all existing content.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thank you Dave for your response.

I have looked on here, on the mal’s forum & the FW documentation and there is nothing that explains this simply & concisely that I can see?

I tried what you suggested Dave and even left it blank just to see what it would do and it still displays a 404 error.

Does anyone with experience setting up a Mal’s cart with FW know how to set the continue shopping/return link correctly to return to the cart page within your FW site?

It would be most appreciated as I’m going round in circles & embarrassingly I’m sure its a simple answer.

Many thanks

Worm


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi, Worm:

Not sure whether I can help or not – rank amateur that I am – and I haven’t seen the rest of this thread (I’m on freewaytalk now on my email client, not on the web) but I just had this experience about an hour ago. I’m in the process of setting up my first store with Mal’s and using the Mal’s E-commerce suite. When I clicked on the continue shopping link I got a 404 error, too.

What I discovered – and I have no idea of what exactly caused this or how – was that the page, which I had named store.html in Freeway changed in Freeway to something I had typed in the cart setup in Mal’s. I know that sound’s odd, but it’s what happened. So then I changed the altered page name in the Inspector, re-uploaded and everything is working fine now.

So you might want to check that page name.

Hope this helps.

Martin
Signal Mountain, TN

On Jan 25, 2011, at 4:52 AM, Mr worm wrote:

Thank you Dave for your response.

I have looked on here, on the mal’s forum & the FW documentation and there is nothing that explains this simply & concisely that I can see?

I tried what you suggested Dave and even left it blank just to see what it would do and it still displays a 404 error.

Does anyone with experience setting up a Mal’s cart with FW know how to set the continue shopping/return link correctly to return to the cart page within your FW site?

It would be most appreciated as I’m going round in circles & embarrassingly I’m sure its a simple answer.

Many thanks

Worm


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

So what URL is it telling you can’t be found now?

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thank you for you response Martin, Im still not quite sure why this happens in FW? I looked in your suggestion but thats not what was happening to me?!!

I posted on the Mal’s forum & they advised me that the link that is in the continue shopping button is controlled by the return value in your product code. So this needs to be edited in Freeway.

I’ve had to open up the shop page in question in a text editor like text wrangler and manually edit ALL the return links within the code and re-upload to the sever. It seems to work!

However I’m still unconvinced that this is normal practice for a shop?!!

Hopefully Dan J, Walt , Joe or someone familiar with setting up Mal’s shops in FW can shed some light on this subject.

Fingers crossed!

Here is my TEST link to my URL Dave:

http://www.cmlmarketing.com/zyzagarus/buybook.html

Or is it because of my site structure EG. domain/folder/page

Where as you stated that folder/webpage/webpage is not accepted - it must be folder/folder/webpage

Ultimately it will be www.mydomain.com/store.html

Worm


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi,

No it’s not normal to have to edit Freeway output like that!

Just had a quick peek at your page and it looks like the return link isn’t getting set properly.

In Freeway go to >File > Document Setup and click on the Upload tab, check the address you have in the Web Address part.

If you are uploading to a folder (in this case zyzagarus) on your server from your Freeway document it should be:

<http://www.cmlmarketing.com/zyzagarus/>

This will link up with the actions on the pages to allow the cart to return customers back to the page they came from.

It’s been a while since I’ve used the actions but from what I remember this is how the return link is set.

When all the testing etc is finished and you are ready to upload the site to it’s final server, the link in the Upload tab of Document Setup should be:

http://www.mydomain.com/

Replacing mydomain.com for the real url, and don’t forget the http:// bit!

Hope that helps.

Steve.

On 26 Jan 2011, 12:19 pm, Mr worm wrote:

However I’m still unconvinced that this is normal practice for a shop?!!

Hopefully Dan J, Walt , Joe or someone familiar with setting up Mal’s shops in FW can shed some light on this subject.

Fingers crossed!

Here is my TEST link to my URL Dave:

HugeDomains.com

Or is it because of my site structure EG. domain/folder/page

Where as you stated that folder/webpage/webpage is not accepted - it must be folder/folder/webpage

Ultimately it will be www.mydomain.com/store.html

Worm


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Each of the Mals actions has a return address field where you can specify the continue shopping URL. It sounds like you have this set incorrectly as it has an extra section at the end of the URL.
Correct this in each of the actions and you should be set.
Regards,
Tim.

FreewayActions.com - Freeware and commercial actions for Freeway Express & Pro.

Protect your mailto links from being harvested by spambots with Anti Spam.
Only available at FreewayActions.com

http://www.freewayactions.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Steve,

You were correct. Upon setup I completely forgot that:

In Freeway go to >File > Document Setup and click on the Upload tab, check the address you have in the Web Address part.

I did this and the web address was incorrect.

I amended it and re-uploaded it and it works fine now!

And thank you Tim this is indeed correct and I have now corrected accordingly.

Thank you so much guys

Worm


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options