CSS Menu not working in Explorer

Hi all,

I have a problem where the menu does not work in IE6/XP
I can hover over the menu but can’t select anything.
I remember I had the same problem in the past, but can’t find the post.

Does anybody know how to fix it?
Thanks for any help,
Emilio FW5 Pro


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sounds like you have a layer sitting on top of the menu, what page is
it happening on? Your menus worked fine for me on IE6.

Joe

On 3 Jan 2009, at 03:09, kitesurfer3 wrote:

Hi all,

I have a problem where the menu does not work in IE6/XP
I can hover over the menu but can’t select anything.
I remember I had the same problem in the past, but can’t find the
post.

Does anybody know how to fix it?
Thanks for any help,
Emilio FW5 Pro

www.olympiawindows.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Joe

I found my old post and the problem is that I need color background on the menu.

I thought by now they this was fixed, guess not.

Emilio


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Nope, people are still using IE6 for some reason…

Walter

On Jan 3, 2009, at 5:45 AM, kitesurfer3 wrote:

I thought by now they this was fixed, guess not.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Actually Walter it behaves the same way in IE7 and I was referring to FW fixing it.

Emilio


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sometime around 3/1/09 (at 13:00 -0500) kitesurfer3 said:

I was referring to FW fixing it.

Heh - if only Softpress could fix Internet Explorer!
(If only Microsoft could fix Internet Explorer… :slight_smile:

From the sound of it, your solution was to apply a background colour
to the menu items. This is, to my knowledge, a quirk (among many) of
Internet Explorer.

Perhaps menus could default to having a fill, but I would be rather
unhappy if Freeway actually blocked me from producing menus with no
fill. There can be legitimate reasons for doing that, and
compatibility with the Worst Browser Ever is not always a necessity.

k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I can’t think of any reason why you wouldn’t need (or want) to be IE compatible.
I think it would be to FW advantage to make sure it is compatible, without forcing anybody to change, maybe adding some code to fool IE.

Emilio


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I was hoping that IE6 would get buried in a peat bog and recycled as firelighters, seriously. I waste so much time patching around its frank bugs.

Walter


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

More problems with CSS menus. I have had a Freeway constructed site up for 7 years and never did preview in Explorer. So I put Windows 7 in Fusion the other day. Either Explorer sucks or every other browser sucks. But I think some of the problems are fixable.

Please look at these examples. My first thought is that Explorer can’t display certain fonts, but it seems the ones inside CSS are the only ones displaying all over the place.

http://www.thesonsofthelawofone.com/explorerexample.html

working example:
http://www.thesonsofthelawofone.com/trialpage.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I think it more likely that your problem is in the use of a non-standard font like Herculanum.

It may come on a Mac but I dont think you will find it on many windoze boxes.

http://www.ampsoft.net/webdesign-l/WindowsMacFonts.html

If you want to a font to display correctly to all visitors whether they have the font installed or not then you are going to have to use an action like Web Fonts or Caxton.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

If you want to a font to display correctly

If you want a font to display correctly…

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options