[Express] upload problem

Hi All,
having a problem uploading a site to a test folder on a server.

The company running the server require that the website is uploaded to a folder called ‘web’ inside the root folder where the existing website is. I have created a folder called ‘test’ inside this folder to test out the new website but every time I upload it will only go to the root folder and no further. I have to manually access the server and move it into the ‘test’ folder - a real pain !

The company running the server are adamant that the ‘web’ folder is permissions free and are blaming the software I’m using (freeway express 5.5). I’m not convinced as I am sure I have done this before on other servers.

This will be a pain going forward as I will have to manually upload the site every time I make a change.

Is there something I can add to the ‘web address’ or ‘directory’ field in the upload dialogue on free way or change the ftp mode to force the upload into the ‘test’ folder ???

Help welcome, Neil


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

What do you currently have in the Directory field? Try adding /web/test to that field, empty out the Web address field (it’s only used for certain Actions, and might be confusing things here) and make sure that your username, password, and the server address are all correct. What should happen when you log in is this: your username and password will be used by the server to decide which “jail” folder to put you in. When you arrive in that folder, likely at /home/your_first_initial/your_user_name/, your FTP application (Freeway) will be told “you are at the root” or / and therefore all folders that you might want to switch to must live below that level (which means inside your user folder). So when you ask for /web/test, you aren’t really getting /web/test, you are getting /home/your_first_initial/your_user_name/web/test, which is the folder you see in your other FTP application.

Walter

On Aug 27, 2013, at 6:53 AM, NeilMM wrote:

Hi All,
having a problem uploading a site to a test folder on a server.

The company running the server require that the website is uploaded to a folder called ‘web’ inside the root folder where the existing website is. I have created a folder called ‘test’ inside this folder to test out the new website but every time I upload it will only go to the root folder and no further. I have to manually access the server and move it into the ‘test’ folder - a real pain !

The company running the server are adamant that the ‘web’ folder is permissions free and are blaming the software I’m using (freeway express 5.5). I’m not convinced as I am sure I have done this before on other servers.

This will be a pain going forward as I will have to manually upload the site every time I make a change.

Is there something I can add to the ‘web address’ or ‘directory’ field in the upload dialogue on free way or change the ftp mode to force the upload into the ‘test’ folder ???

Help welcome, Neil


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Walter,
thanks for the reply. In the directory field I have /and then the name of the route folder on the server for this website it reads, /www.turnkey-locations.co.uk , inside this is a folder called ‘web’ which has in it the old website I am rebuilding that was made by someone else. The user name and password all work OK and the web address filed has http://web/test/ in it which I thought would take it ot the test folder I have created.
I will try your tip and see what happens…
cheers,
Neil


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

If you are getting to the top folder by entering /www.turnkey-locations.co.uk, then add /web/test to the end of that – don’t enter just /web/test, because they clearly have not jailed you in the normal manner if you need to enter your top-level domain folder in the Directory field.

Walter

On Aug 27, 2013, at 11:09 AM, NeilMM wrote:

Hi Walter,
thanks for the reply. In the directory field I have /and then the name of the route folder on the server for this website it reads, /www.turnkey-locations.co.uk , inside this is a folder called ‘web’ which has in it the old website I am rebuilding that was made by someone else. The user name and password all work OK and the web address filed has http://web/test/ in it which I thought would take it ot the test folder I have created.
I will try your tip and see what happens…
cheers,
Neil


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Brilliant ! Thanks Walter it worked a treat…

Neil


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options