FancyZoom - How?

it will be a good test to try a fresh test page. I will let you know later.

I remember a bit of trouble I had getting FZ to work; it turned out
that it doesn’t play with image maps, and Freeway puts image maps
around rotated graphics. This is pretty logical (ideally, a link on a
rotated graphic should map to its visible shape rather than the
overall rect area) but it does abstract the actual link code from the
object code - which broke FZ.

But this doesn’t seem to be your trouble. You do have link map code
in the page but I don’t think it relates to the image you’re trying
to zoom.

In your test page, make it as absolutely simple as possible.

k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The markup code that shows the paths to the javascript files is as follows

<script src="/js-global/FancyZoom.js" type="text/javascript"></script>
<script src="/js-global/FancyZoomHTML.js" type="text/javascript"></script>

As i said in my previous post I could not get this to work when the js-global folder was at the same level as the page in question.

I had to move the folders up one level to make it happen.

If you don’t have access to the next level up then I suspect you could alter the path to the javascript files but not being a coder I will leave that to someone more knowledgeable.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

When you begin a URL with a /, that means “start at the root folder for this site”. If you leave it off, and start with the first directory name, then that means “start at the base href for this page”, which usually means the current directory.

Walter


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

If you are going to change the URL path in the Scripts:

if you download:

http://louslittle.com//FancyZoomScripts/js-global/FancyZoom.js

you will see the altered line :

var zoomImagesURI = ‘/FancyZoomScripts/images-global/zoom/’; //
Location of the zoom and shadow images

I did this to put all the scripts in their own folder. I hate
cluttering up my top level directory with a lot of stuff that later I
can’t figure out what it is.

LLE

On Dec 15, 2008, at 7:17 AM, waltd wrote:

When you begin a URL with a /, that means “start at the root folder
for this site”. If you leave it off, and start with the first
directory name, then that means “start at the base href for this
page”, which usually means the current directory.

Walter


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

OK my friends

I have created a new very basic page with just one image and went through all the motions and this is what I have got . . .

http://www.howardprimaryschool.com/test.html

loading wheel - just spins!

this is the actual space where the site will live and
upon login I have 3 folders and have been instructed the site should be placed in the htdocs folder. This is where the page resource folder etc , the zoomable image and the two FZ folders are.

There are two other folders in the root: logfiles and private. Anyone got any ideas?

Trev


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

loading wheel - just spins!

If I try to get to the image directly
(http://www.howardprimaryschool.com/eye2.jpeg) I get this:

 Not Found
 The requested URL /eye2.jpeg was not found on this server.

Make sure that the eye2.jpeg graphic is in the right place - in this
case loose at the root of the site.

k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

SUCCESS!

Good Man Keith - The images was not being found because it had the wrong prefix!

When I saved them both from photoshop both were .jpg
when I processed through Freeway it came out in Resource folder as a .jpeg I uploaded the 2.jpg image manually so when I changed the prefix and uploaded it works fine - now I just need to figure out the caption bit and I’m done. Thanks for pointing me in the lost file direction. Thanks to to all who gave help and replies.

Trev


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Just as a matter of interest

How do I place a caption on the large image please?

Trev


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Trev,

You do this by adding a title tag to the href.

To do this depends on how you associated the zoom picture with the
thumbnail in FW.

If you selected the thumbnail and then ctrl-clicked on the thumbnail
and selected Hyperlink, and the external button, then just fill out
the Title line with your caption. The link to your Zoom picture is in
the edit field box above the Title entry. The problem with using this
method is that FW does not “manage” the upload of your Zoom picture.
You have to do that manually.

If when you click on your thumbnail, you then select "Item->Actions-

Graphic Link To File" from the top menu to link to the zoom picture,
then the Action pallet has no entry for the “Title”, just the image
to use as the zoom picture. But using the Action causes FW to manage
uploading the zoom picture and putting it in the Resources folder for
you and getting all the link stuff correct. So to get the title I
discovered that with the Action implemented, you can ctrl-click on the
thumbnail and then select hyperlink. Then select the External button.
Then select the Protocol menu item http:. This will put http:// in the
edit box, ignore this, just fill out the Title line with your caption
and click OK.

That’s how I did it anyway.

LLE

On Dec 15, 2008, at 6:10 PM, t50ufo wrote:

SUCCESS!

now I just need to figure out the caption bit and I’m done.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks so much LLE

So simple - when you know how.

Good to get the final result and looking good - this will enhance my site and I hope others too.

Kind regards to the FreewayTalk forum for sharing knowledge and more importantly taking time to help.

Merry Christmas to all!

Trev


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options