font in InDesign

Any InDesigner’s here?

I use the Futura condensed font in Freehand and it correctly displays and renders upper and lower case letters accordingly.

Call up this font for use in InDesign (CS2), however, and all the letters are capitalised - using the shift key for caps just gets a larger capital at the start of the word.

I can’t make Futura show lower case letters in InDesign!

aaarrrgghhhhh

Hugh


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

on 03/12/2008 15:46, hugh at email@hidden wrote:

Any InDesigner’s here?

I use the Futura condensed font in Freehand and it correctly displays and
renders upper and lower case letters accordingly.

Call up this font for use in InDesign (CS2), however, and all the letters are
capitalised - using the shift key for caps just gets a larger capital at the
start of the word.

I can’t make Futura show lower case letters in InDesign!

Sounds like you’ve got Small Caps turned on?

Best wishes Peter

================================
Peter Tucker, Oxford UK email@hidden


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I wonder if the “small caps” option is checked on in your Character
palette’s flyout menu. Take a look – there’s a little disclosure
triangle at the right top corner of the palette, and this is one of
the options available. If it is, there’s your explanation. I can’t
think of any scenario where it would get stuck that way for just this
text style, but that would be one reason why you are seeing this
behavior.

Walter

On Dec 3, 2008, at 10:46 AM, hugh wrote:

Call up this font for use in InDesign (CS2), however, and all the
letters are capitalised - using the shift key for caps just gets a
larger capital at the start of the word.


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Not sure whether I’m seeing this right…but the character/paragraph style palettes to the right of the working area are blank or greyed out. I do have character/paragraph control via the menu bar type thing across the top of the working area, though…can click a small triangle here and it flies out with a list including Ligatures (checked) and Open Types which shows another drop down with all kinds of [discretionary], [fractions], [ordinal] choices. It has [small caps] here but it isn’t checked. The ones checked in my list are [contextual alternates] and [discretionary ligatures].

Is this what you mean?


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Try typing some text in this font, highlighting it, and then have a
hunt through the palettes and their respective flyout menus. This may
have been set in a paragraph or character style, too – these each
have access to the “faux small caps” option. But another reason why
this might be happening is that the font itself may include these
characters, and your input method (set through the little Flag menu in
the top-right, or International in the System Preferences) may be in a
mode where the keyboard input puts it into the Unicode range where
those characters live.

InDesign can get confused in certain Unicode contexts, ignoring
“classic” Mac input modes like Shift-Option-Right Square Bracket, and
insist that you enter backslash codes like some sort of weird Windows
clone. Changing the Flag menu so that it doesn’t have a little U
hanging off of it can help in that particular case.

Walter

On Dec 3, 2008, at 11:48 AM, hugh wrote:

Not sure whether I’m seeing this right…but the character/
paragraph style palettes to the right of the working area are blank
or greyed out. I do have character/paragraph control via the menu
bar type thing across the top of the working area, though…can
click a small triangle here and it flies out with a list including
Ligatures (checked) and Open Types which shows another drop down
with all kinds of [discretionary], [fractions], [ordinal] choices.
It has [small caps] here but it isn’t checked. The ones checked in
my list are [contextual alternates] and [discretionary ligatures].

Is this what you mean?


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

on 03/12/2008 16:56, Walter Lee Davis at email@hidden wrote:

Try typing some text in this font, highlighting it, and then have a
hunt through the palettes and their respective flyout menus. This may
have been set in a paragraph or character style, too – these each
have access to the “faux small caps” option. But another reason why
this might be happening is that the font itself may include these
characters, and your input method (set through the little Flag menu in
the top-right, or International in the System Preferences) may be in a
mode where the keyboard input puts it into the Unicode range where
those characters live.

You may also find that some more professional fonts actually have a
completely separate font containing small CAPS style where the font name is
suffixed with SC. Have you chosen that?

Best wishes Peter

================================
Peter Tucker, Oxford UK email@hidden


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Walt and Peter.

Found it…fixed :slight_smile:

I had the TypeStyle palette open but not the Type palette itself. Oddly, the control palette across the top doesn’t show any small caps on/off dialogue which the true Type palette does.

So once I’d unchecked that it was hunky dory again. It’s a bit of a beast, Illustrator, isn’t it :wink:

No, Peter, no funky fonts with SC suffixes…phew.

thanks
Hugh


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Is this an Opentype version of Futura Condensed, or an old type 1 Postscript version? If it is the latter you may not be able to use it correctly. There are a lot of type 1 fonts that used to work fine in programs like Freehand (and came with it) that do not any longer in newer applications. I have hundreds of old Freehand files that I used Helvetica Narrow in that are now garbage because the old font no longer works correctly when opened in Illustrator CS and above.


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

In the Library > fonts its name seems to be Futur and it has an icon with ‘LWFN’ on it and beneath that Postscript Type 1.

If I do a system wide search for Futura Condensed, all the results are ‘futura.dfont’…whatever that means.

Seems to work, though.


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

.dfont is a Mac os native font that Apple came up with.


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 3 Dec 2008, at 17:40, hugh wrote:

If I do a system wide search for Futura Condensed, all the results
are ‘futura.dfont’…whatever that means.

It’s the font type that OS X uses now, and should work fine.

best wishes,

Paul Bradforth

http://www.paulbradforth.com


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

It’s the font type that OS X uses now, and should work fine.

Just one of the font types…

k


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Oddly, the control palette across the top doesn’t show any small
caps on/off dialogue which the true Type palette does.

The Control Bar (to use the proper name) is just for quick
context-sensitive access to common controls. For full formatting
powers, you will often need to open the relevant floating panel.

(BTW, note that from CS3 onwards those things are panels, not palettes.)

:slight_smile:

k


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 3 Dec 2008, 6:00 pm, thatkeith wrote:

(BTW, note that from CS3 onwards those things are panels, not palettes.)

:slight_smile:

Bring back Freehand is all I can say!


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 3 Dec 2008, at 18:56, Keith Martin wrote:

It’s the font type that OS X uses now, and should work fine.

Just one of the font types…

Well yes, but what I meant was: it came in with OS X. Yes, I know I
should have said that :slight_smile:

best wishes,

Paul Bradforth

http://www.paulbradforth.com


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sometime around 3/12/08 (at 21:00 +0000) Paul Bradforth said:

Yes, I know I should have said that :slight_smile:

Don’t mind me, I once corrected a colleage on the pronunciation of
the word “pedant”…

:wink:

k


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

ROTFLMAO!

On Dec 3, 2008, at 4:31 PM, Keith Martin wrote:

Don’t mind me, I once corrected a colleage on the pronunciation of
the word “pedant”…


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Don’t mind me, I once corrected a colleage on the pronunciation of the word “pedant”…

I take it his spelling was OK though!


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sometime around 3/12/08 (at 17:24 -0500) DeltaDave said:

I take it his spelling was OK though!

Yeah, superb, although like most people he wasn’t terribly hot on commas.
In fact, that’s what started it. I’d corrected something obscure and
he turned to me in exasperation and said “Keith, you’re such a
pedant”, pronouncing it as in pedANTic.
I said “I think you’ll find that’s pronounced PEDant.” It took him
ages to stop laughing, and he told that story for months.

Yes, it really happened. :slight_smile:

k


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

One may be tempted to call you a PEDantophile… or not. :wink:


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options