Form Text Field Size

I’m trying to use Freeway to mock up a form to use as a prototype for a web application. I’ve added the text fields using Insert>Input/Field but there doesn’t seem to be any way to change the size of the field itself.

When I edit the sizes either in the Measurements box or in the Dimensions box below it, it only changes the size of the item box but not of the input field. I copied some fields from an old file which I can resize horizontally but the corner handles are red and can’t be dragged. There’s no info on this in either the extensive Freeway Reference from June 2014 or the Extended Reference for Freeway 7. It’s been a while but I don’t remember this problem.

I would like to be able to resize the field width and height as well as the type size of the input and placeholder type. I did a screen grab video to show what’s happening: Freeway text field resizing (or not) - YouTube
I’d appreciate any input as I’m completely baffled by this. Thanks in advance.

Hi Richard,

This problem is happening because you are using table layout rather than CSS layout. If you turn on the CSS Layout button before inserting a control (or check the Layer/CSS checkbox in the Inspector palette after inserting it), you will get a CSS input/field that automatically adjusts to its new size.

If you actually need to use table layout for some reason, you can adjust the length of the control by changing the value in the the Size field of the HTML Output panel.

Apologies that it’s taken me a few days to answer this. Your YouTube video was helpful in showing the problem.

Hi Jeremy,

Thanks for your reply. I hadn’t noticed. However when I click on the CSS Layout button (the bubble turns blue) and add an Input/Field item, it still has the anchors in red and I can’t move or resize it except length. Here’s a screenshot where you can see this: Thanks.

Clicking on the Height button in the Dimensions section of the Inspector palette will allow you to resize the height. You should be able to move it by dragging it with the mouse, or by changing the Left and Top position fields in the Dimensions section of the Inspector palette.

OK that seems to have worked. Now is there a way to make the input text larger? The text is minuscule.

  1. Select the input/field or one of its ancestors
  2. Switch to the Styles pane of the Inspector palette
  3. Click on the plus button next to Item:[item ID] or one of its ancestors
  4. Choose New
  5. Create a new style with your preferred text size in the Character section of the Edit Style dialog