Google Maps not appearing

Hi Under the send form on this page there should be a map. It works fine on preview but not once uploaded, I tried on another website that is established and got the same problem It seems to be there in the source code but No map on page.

Any ideas. It’s based on the Floral theme and the original won’t work either when uploaded.

Cheers

Anthony

http://www.the-flowershed.co.uk/contact.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Hi Anthony,

since June 22nd Google changed the terms of use of Maps, so you need to always set the API key. It’s a rather convoluted process through the Google console to create and enable an API Key, we documented the steps for the upcoming Sparkle 2.1, here’s the full explanation:

https://secure.sparkle.cx/support/maps/maps-en.html

Duncan
http://sparkle.cx http://sparkle.cx/


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Thank you Duncan, I believe I have now done that and I have added the API_Key to the map action but still nothing, however I am now getting this error message “Geocode was not successful for the following reason: REQUEST_DENIED”

Do I have to wait for the key to authenticate or something.

Thanks Anthony


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Did you do step 4&5 in Maps API key instructions https://secure.sparkle.cx/support/maps/maps-en.html ?

By the sound of it you did not enable the javascript maps api.

Duncan


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Hi Duncan yes I did, We used to d this years ago. The account I use to access the api screen doesn’t matter I take it. I’m missing something here and I know it’s going to end up obvious!!
Just done it again and no change


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I have just gone through this process again for another site using a different google account and the same problem http://www.maroonedhaircutters.co.uk/map.html

Using an unrestricted API Key but map still won’t display

This is the code generated once uploaded:

//<![CDATA[

The API is definitely enabled, do I need to fill anything else in like OAuth consent screen or domain verification?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Fixed!!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Thanks for the help with this earlier Duncan. I have fixed it but don’t know how and now i can’t even replicate the problem I think it may have been server side although the one thing I did differently was to click in another doc rather than pressing enter.

Thanks again

Anthony


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options