help with hyperlinks

Hi… I have tried and re-tried to get the hyperlinks correct on our site, and it just isn’t working.

To set them, I went into Page Inspector and set them as follows:

Normal: Dark Grey (the color that most of the text is)
Visited: White
Hover: White
Active: White

But when I look at the page, I am only seeing the Dark Grey.

On my example page, the “contact us” in the last paragraph is hyperlinked and should turn white when I hover over it, correct?

I’m having the same problem all over the site.

Does anyone have ideas about what I am doing wrong or how I might be able to fix it–for someone who relatively fluent in Freeway but not overwhelmingly skilled at peeking under the hood?

Thanks.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

To set them, I went into Page Inspector and set them as follows:

There are many different places you can set link styles.

I would suggest that you try the following.

In the Page inspector (with nothing on the page selected) change the link styles to None.

Now select the html container (item1 on your page - make sure the corner handles are visible) and now set the link styles in the item inspector.

This is far more specific than setting them on a page wide basis.

Let us know how this works for you.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

It should be noted that if you are using the CSS menu action then link styles should only be applied through the CSS menu action interface.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks! I will try that and circle back tomorrow.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Dave,

I tried the HTML container instructions and it had no effect.

Then I saw your other message…I am using the CSS menu action–and just looked and saw that I had separate “hover” colors there (but those aren’t working either).

Does changing the link styles there in the action supersede all else? Do I need to remove the other ones from the html container?

Any other ideas?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Does changing the link styles there in the action supersede all else?

Link styles applied in the CSS Menu action only apply to the CSS Menu itms. Make sure that you have no colour applied via normal styles. In your example page the text is styled as white. Colour should only be added via the CSS menu link styles.

I tried the HTML container instructions and it had no effect.

Did you remove all other instances of link styling?

As a base measure select all the text that you wish to style as a link and use Style>Remove Styling - this will remove all text styling. Then try adding the link style by selecting the container and applying the link styles.

BTW your background image eucalyptus_bark_m.png is HUGE! - it is nearly 9Mb - makes for a very, very slow loading page.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Your menu has “style4” applied to it if you edit styles and remove the colour white from it your menu will function as you want.

Simon


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

If I may rush in here:

One of the most important things about “styling” text and hyperlinks is to stay organized. I know this might be a shocking statement but doing styles in inspector first is simply the wrong way - for both css-menus and regular page link styles.

I once started with a video screencast series which I interrupted for the moment but will go on with it as soon as I got some minutes (and inspirations).

One of the main messages of this entire series is the “paragraph” episode to get a regular base for further stylings.

Have a look at this and tell me what you think (just 7 minutes of your lifetime):

http://kimmich-dm.de/wordpress/?p=931

(and maybe the following called body as well).

Once cleaned out your page-styles (and even menu-styles) I’m pretty sure you get closer to the wanted.

For css menus I then create a single small style called e.g. .mainmenu which only contains the font-family and the text-orientation nothing else.

So as I already said:

Stay organized, reduced and clear. Start by firing out the style(followed by number) stuff entirely. Make yourself clear what basic properties you need and do this next.

Then follow Davids instructions on how to apply link styles.

The rest of it will be done within css-menu action.

Believe me:

This should take you just half an hour to do and could save you hours of investigation and try-outs.

Cheers

Thomas


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I think that’s terrific, Thomas. Exactly what Freeway Pro users need to
know about how to tame and control their text styles in a very practical
way. Well done!


Ernie Simpson

http://kimmich-dm.de/wordpress/?p=931


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi everyone…

Update:

First, thanks to Thomas for the brilliant video. And to Delta Dave for helping me understand the different categories I need to consider (and pointing out the huge size of my background on the homepage–I had fixed the other pages’ background but had missed that one as it has a different Master).

Now, on to the remaining issue:

I’ve managed to fix the hover so that now it works by stripping everything out and starting over. But now, the basic state of the text that is hyperlinked is a dark blue that I didn’t set and I am sure is automated somewhere or automatic at least, but I can’t figure out where.

If I remove all of the styling and then click on the HTML box and set the links as “NONE” except the “Hover,” which I set as blue, the hover doesn’t work when it is published (but that pesky dark blue does go away).

Any advice, oh wise ones?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

If you do not assign a colour to your link states then the Browser default colour will be used instead - which is blue.

So if you dont want your links to be different to your other text then set it to your normal text color: #666

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

And BTW eucalyptusforweb.jpg is still pretty big at nearly 900Kb!

It really should be down nearer 150Kb (or less)

This is it at 300Kb http://www.deltadesign.co/FW6Test/testingbg.html

Good enough quality?

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Just another quick rush-in here and a small update:

The screencasts are now (better) available on:

http://www.kimmich-digitalmedia.com

The footer links of this page are following those settings:

I am under the impression, that the page is following my advices and I think it shouldn’t be too hard to reconstruct the how and why.

David already said it:

There is a default behavior in browser when all stuff is set to “none”, which will mean blue:link, purple: visited, red: active.

You already saw the first differences between hand-hacked and Freeway in the videos - and especially for links, FW is a real time-saver.

Cheers

Thomas

PS: I have btw an older (and a bit outdated long and boring) episode but it shows the gist as well:

http://www.kimmich-digitalmedia.com/bib-v5/freeway-box-box-modelpro-v5-5-007-styling-links


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options