Hover text problem on PC

I’m not sure if I “hover text” is the correct description, but my problem is that when viewing my websites on PCs, text appears when the mouse stays still for a few seconds. The text is the name of the graphic that is below the mouse. This doesn’t happen on the Mac.

Is there any way that I can stop this happening?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sometime around 26/1/09 (at 05:52 -0500) David said:

Is there any way that I can stop this happening?

Only by removing all alt text from your images - see the Inspector
palette. This isn’t a particularly bad thing to do with images that
are purely decorative, but anything at all informative should be
tagged to help with accessibility.

But don’t get too hung up on this. It is normal behaviour on PCs, so
PC users are fairly used to it.

k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

David

What you are seeing is a ‘tool tip’ and controlled by the ‘Alt Text’
found in The inspector. Select the graphic and in the Inspector select
the third tab from the left. You will see a check box next to to ‘Alt
Text’, which you can uncheck. Better still, to help both those with
graphics turned off in their browser and influence search engines,
leave the box checked and add a brief description of the graphic - it
will help with screen readers, too.

HTH Colin.

On 26 Jan 2009, at 10:52, David wrote:

I’m not sure if I “hover text” is the correct description, but my
problem is that when viewing my websites on PCs, text appears when
the mouse stays still for a few seconds. The text is the name of the
graphic that is below the mouse. This doesn’t happen on the Mac.

Is there any way that I can stop this happening?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Your reactions are obviously faster than mine, Keith. But then you
have the advantage of relative youth :wink:

Colin.

On 26 Jan 2009, at 11:24, Keith Martin wrote:

Sometime around 26/1/09 (at 05:52 -0500) David said:

Is there any way that I can stop this happening?

Only by removing all alt text from your images - see the Inspector
palette.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

you have the advantage of relative youth :wink:

Meaning my sons are still young? :wink:

(Thinks: does 17 and 21 count as young? heh.)

k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

With six grandchildren already - YES!

Colin

(Sorry to hi-jack your thread, David).

On 26 Jan 2009, at 11:40, Keith Martin wrote:

you have the advantage of relative youth :wink:

Meaning my sons are still young? :wink:

(Thinks: does 17 and 21 count as young? heh.)


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thank you both for the replies. I am producing a site for my brother-in-law and he asked my why a message comes up on his PC that says “MediumGreyBackground” when he hovers the mouse over the page.

This is not a particularly useful bit of alt text I’m sure you’ll agree! Perhaps I could just remove the text from some images and improve it on others? A long-winded job. I was hoping there was a button that changed this for the whole site…

Why can’t everyone have Macs?

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Perhaps I could just remove the text from some images and improve it
on others?

Exactly the right approach.

A long-winded job.

Moderately. You should find that it isn’t quite as bad once you get
going, but it will be a bit long-winded. Perhaps click the Site
panel’s title so you focus on one page at a time, showing every item.
You can see and select your graphic items from there. Move the
Inspector palette over next to this panel and you should be able to
dance through things fairly Astaire-like.

Why can’t everyone have Macs?

That of course is the RIGHT question. :slight_smile:

k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 26 Jan 2009, at 15:50, Keith Martin wrote:

Move the Inspector palette over next to this panel and you should be
able to dance through things fairly Astaire-like.

In page mode like that you can Option-click item titles to edit them.
No need to shimmy the Inspector over.

;o)

Heather


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

No need to shimmy the Inspector over.

Unless you wanted to edit or disable the alt text of course… :wink:

k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi David,
What you are seeing is, IMHO, a bug in IE in that it renders the alt data for
the image if no title attribute is present. Rather than deleting your alt data
(as Keith mentions this is really quite useful to have) simply add an empty
title attribute to the image;
title=“”

Select your image and select Extended from the Item menu. Making sure the IMG
tab is selected press the New button and enter;
name: title
value:(nothing. leave this empty)
Press the OK buttons to exit these two dialogs.

The browser will take this text over the alt data and seeing that it is empty
will simply not render any tooltip for the image.
Regards,
Tim.

Quoting David email@hidden:

I’m not sure if I “hover text” is the correct description, but my problem is
that when viewing my websites on PCs, text appears when the mouse stays still
for a few seconds. The text is the name of the graphic that is below the
mouse. This doesn’t happen on the Mac.

Is there any way that I can stop this happening?

Extend Freeway the way you want with FreewayActions.com
http://www.freewayactions.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

There’s a set of Actions to automate this solution here:

http://actionsforge.com/projects/view/56-fix-ie-alt-tags

Walter

On Jan 26, 2009, at 2:43 PM, email@hidden wrote:

(as Keith mentions this is really quite useful to have) simply add
an empty
title attribute to the image;
title=“”


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thank you Walter, and all others, what a great list. Not only do I have a quick fix, but I also now understand what is going on! Brilliant.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options