I do not understand this behaviour (border and background settings).

I keep stumbling over my lack of knowledge, therefore I do hope someone can explain this to me.

When I add in the Inspector a border to a (left) floating DIV that also has a left margin the following happens:

  1. I must reduce my margin to get the DIV back in place
  2. the border shows separate from the background
  3. and of course unpredictable things happen in browsers.

Some screenshots:

http://www.atelier.box.nl/test/issue_23-6-2009/no_border.png
produces in Safari 3 Mac:
http://www.atelier.box.nl/test/issue_23-6-2009/rendered_no_border.png
While
http://www.atelier.box.nl/test/issue_23-6-2009/border.png
makes (after reducing the Margin)
http://www.atelier.box.nl/test/issue_23-6-2009/rendered_border.png

Thank you for looking at this.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

You need to add a graphic effect border (the second icon in the line
of graphic effects). The HTML background and border is separate from
the graphic effects background, border, shadow, round corners and so on.

I hope this helps.

Joe

On 23 Jun 2009, at 09:50, atelier wrote:

I keep stumbling over my lack of knowledge, therefore I do hope
someone can explain this to me.

When I add in the Inspector a border to a (left) floating DIV that
also has a left margin the following happens:

  1. I must reduce my margin to get the DIV back in place
  2. the border shows separate from the background
  3. and of course unpredictable things happen in browsers.

Some screenshots:

http://www.atelier.box.nl/test/issue_23-6-2009/no_border.png
produces in Safari 3 Mac:
http://www.atelier.box.nl/test/issue_23-6-2009/rendered_no_border.png
While
http://www.atelier.box.nl/test/issue_23-6-2009/border.png
makes (after reducing the Margin)
http://www.atelier.box.nl/test/issue_23-6-2009/rendered_border.png

Thank you for looking at this.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thank you Joe.
Then I have a feature request for the interface. Please separate these effects. For users like me its the same. Border is border, background is background. (You know we do not read the FM…;-(
And also if I apply the graphic background, I must adjust my left Margin in order to ger my DIV the place I want. So the visual relation between my FW page and the browser is gone. I must set my Left Margin to 100px in order to get a appr 200 px margin in the browser. Is this normal?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Update: Solved the mystery.
I discovered a above this element a left-floating DIV 100% width that should have been set to no float. naturally. :wink:

Sorry.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options