IE Background Shading

Hello everyone

I have a serious problem with IE rendering my webpage. Any help from you will be very appreciated.

The Problem:

  1. I have a Background image set horizontally and vertically to tile.

  2. On top I have HTML item with colour and image to none, and I used graphic effect to background, colour white and opacity to 30%. This created a nice transparent layer over my background.

  3. On top of the above I have another HTML item, colour and image to none, and I used graphic effect to background with white colour, opacity 100% and corner 9px.

Number 3. is my main layer where I will be adding html text, images and tables.

On top of number 3. I have added a table with cells in white colour, and border is in black.

The Problem with IE.

I have tested the site in Safari, IE8 on Windows 7 and Firefox and it looks without any graphic problems. However, some people reported that viewing the site in IE8 it loads ok for about 2 seconds then flips to the above background. I am sorry I can not show a picture now but it looks something like this.

Number 2 item is filled with the background 1 and it looks transparent, only the border of N2, stay in white. The table cells are also filled with the background colour.

Any ideas on what the problem might be? As I said I can not see it, but any helpful resources on this problem would solve me a lot of time trying to fix this.

Thanks


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sorry just an update

Number 3 item is filled with the background 1 and it looks transparent, only the border of N3, stay in white. The table cells are also filled with the background colour.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Here are some images to see

The item 3 filled with the background and only the border stays in white.

Here is the table cells filled again with the background.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

This is getting really weird, the site was tested on 2 pcs with Windows 7 and IE8, and both displayed the site differently.

The first pc displayed the site normally as it looks in the freeway preview. But the second pc displayed the site with the red background shading in between the text and table.

This confuses me a lot


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The transparent PNG shadows are the problem. Here’s a solution, but it
involves what’s called “progressive enhancement”. Instead of using the
native Freeway controls to round corners and add shadows, use the CSS3
Corners and CSS3 Shadows Actions to add them through CSS3. IE < 9
won’t see these effects at all. But then they also won’t see the bad
stuff you’ve discovered here either. Any modern browser will see the
rounded corners and transparent shadows. The resulting page will be
lighter (fewer images) and faster to load.

Walter

On Aug 25, 2011, at 7:38 AM, Michael Coldereo wrote:

This is getting really weird, the site was tested on 2 pcs with
Windows 7 and IE8, and both displayed the site differently.

The first pc displayed the site normally as it looks in the freeway
preview. But the second pc displayed the site with the red
background shading in between the text and table.

This confuses me a lot


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thank you very much waltd! You’r the master!

I have added white colour to the html item and removed the graphic effects background. I just added the CSS3 corners and it works fine with Safari and Firefox, regrettably not IE.

Because the difference was not visible on my side, a friend of mine sent an image of my webpage in IE and the corners are not visible :frowning:

Is there a way I can make them visible in IE,

Thanks


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

No. That’s the point of this. First, there’s no rule that says that IE
has to drag the whole Web experience down for everyone else. Second,
there’s no rule that says that a Web page has to look exactly the same
in all browsers. Effects like these are the frosting, not the cake (or
the steak). When IE grows up and starts supporting the open standards
they agreed to*, then it gets the goodies.

Walter

*Microsoft is on all the relevant committees in the W3, so it has a
say and a vote on what gets made a standard. When the IE community
upgrades to IE9, things will get a lot more beautiful.

On Aug 25, 2011, at 9:58 AM, Michael Coldereo wrote:

Thank you very much waltd! You’r the master!

I have added white colour to the html item and removed the graphic
effects background. I just added the CSS3 corners and it works fine
with Safari and Firefox, regrettably not IE.

Because the difference was not visible on my side, a friend of mine
sent an image of my webpage in IE and the corners are not visible :frowning:

Is there a way I can make them visible in IE,

Thanks


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options