image and menu disappear

For some reason my CCS menu is showing on a page but disappears when I publish and preview. It works and displays fine on all my other pages. Also a link shows that it should work but then no link when I publish. This is only happening on the same page. Thanks
John


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I meant CSS, but does anyone have a thought as to why 1 page would behave like this?
Thanks John


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Can you post a link? It’s hard to say without an example to interact with.

Walter

On Jun 9, 2014, at 4:18 PM, John Robinson wrote:

I meant CSS, but does anyone have a thought as to why 1 page would behave like this?
Thanks John


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Walt
Here is a link to the home page and the page I am having problems with. The header was created as a master.
http://www.jrobinsondesign.com/ecotest/index.html

http://www.jrobinsondesign.com/ecotest/ecoviewenergysav.html

Thanks John


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Figure out where this line of code comes from (look through the Markup Items you have added to the page, as well as the Page / HTML Markup dialog’s many code slots):

<!-- must put the title above the calculator 

You opened a comment, then didn’t close it later with the → other end of the arrow. So the browser continued on until the end of the page, hiding everything after that point. On this page, the navigation just happens to be late in the page code order (which is fine) but it was the thing that got hidden.

Walter

On Jun 10, 2014, at 11:02 AM, John Robinson wrote:

Walt
Here is a link to the home page and the page I am having problems with. The header was created as a master.
http://www.jrobinsondesign.com/ecotest/index.html

http://www.jrobinsondesign.com/ecotest/ecoviewenergysav.html

Thanks John


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Walt
So I should just add —> to end of this line

<!-- must put the title above the calculator and it will solve the problem? Thanks for your help. John _______________________________________________ freewaytalk mailing list email@hidden Update your subscriptions at: http://freewaytalk.net/person/options

Yes, or remove the initial part of the comment. If you do elect to close the comment, take care that you add two hyphens followed by the greater-than, not a long-dash as created by the Web view of this mailing list. Typographical niceties have no place in the code-bits of HTML!

Walter

On Jun 10, 2014, at 11:25 AM, John Robinson wrote:

Walt
So I should just add —> to end of this line

<!-- must put the title above the calculator and it will solve the problem? Thanks for your help. John _______________________________________________ freewaytalk mailing list email@hidden Update your subscriptions at: http://freewaytalk.net/person/options

freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

will try it thanks


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Walt
That worked. I guess I am going to have to learn to code. Would never have found that issue.
Thanks John


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

At least learn to use the Developer Tools in Safari. That’s how I found it. Color-coded source view means that you see a great wash of green text in the source code, since the commented out parts are colored that way.

Walter

On Jun 10, 2014, at 11:37 AM, John Robinson wrote:

Walt
That worked. I guess I am going to have to learn to code. Would never have found that issue.
Thanks John


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Noticed that the ewlogowhite logo is a jpeg and so looks a bit fuzzy, make it a png with millions of colours and it should appear sharper (if the original is so).


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options