Imbedding Flash Audio Player in a Freeway Page

Hi,

I’ve searched the web and forums, and I’ve had some difficulty in getting a flash player to appear on my freeway pages. Here’s what I’ve done:

I took the script from this page:

http://www.macloo.com/examples/audio_player/

and downloaded the player files from the link on the top of that page. I created an Audio folder on my site, and uploaded music and the player files in the proper location. I first tried to put the entire player script as an “Insert>Markup Item…”, I then tried to take the first line:

(with my appropriate address) and insert it as a HTML Markup in the before area, putting the rest as a Markup Item and neither has shown the player in the window.

Here is the site I am publishing it to, so you can see what I’ve tried:

http://www.taylorschools.net/west/chorus/recordings.html

Note that this page isn’t linked from the rest of the site yet, because I’m leaving it solo until I’ve got the issues solved.

Any help that can be offered about where to place the scripts, or anything I am missing would be very appreciated!!!

Dave

PS - you can see I’ve used 2 other music players on the site if you follow the button bar at the top - A java widget on the Home Practice page, and the Yahoo player on the Gallery page.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Did you use an FTP application to create a folder called ‘audio’
inside the ‘chorus’ folder, and did you upload the player.swf into
that folder? My browser says that file is missing.

Walter

On Mar 18, 2009, at 10:18 AM, Dave Martin wrote:

http://www.taylorschools.net/west/chorus/recordings.html

Note that this page isn’t linked from the rest of the site yet,
because I’m leaving it solo until I’ve got the issues solved.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hmm… The file is there, and shows as a shockwave file. Could this be an issue with my server not supporting flash/shockwave? I know my school’s server is not exactly state-of-the-art. I don’t know enough about the effect of the server to know if this would stop the script from recognizing the player.

Dave


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Nope, but it could have something to do with permissions. Check that
the file itself (the flash file) has permissions 644 or 664 (world-
readable). Use your FTP application to do this. In Transmit, select
the file in the server folder and press Apple-i.

Walter

On Mar 18, 2009, at 11:04 AM, Dave Martin wrote:

Hmm… The file is there, and shows as a shockwave file. Could this
be an issue with my server not supporting flash/shockwave? I know
my school’s server is not exactly state-of-the-art. I don’t know
enough about the effect of the server to know if this would stop the
script from recognizing the player.

Dave


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I used Transmit (I actually use a PC to transfer the files to the site, as it connects via the PC’s network places) to get info on the file, and it said the Octal permissions was 744. I changed this to 644, applied, entered my admin pw, and tried to upload it again. I did the same with 664 permissions. No dice.

I am sure the path is correct for loading the file… Do you still show it isn’t loading? Any other ideas?

BTW, thanks.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The Folder must be 755, the Files within it must be 644. If the folder
really was 744, then it would be un-browseable by the public. (On a
folder, the executable bit is used to indicate that the folder may
have its contents listed.)

Walter

On Mar 18, 2009, at 12:04 PM, Dave Martin wrote:

I used Transmit (I actually use a PC to transfer the files to the
site, as it connects via the PC’s network places) to get info on the
file, and it said the Octal permissions was 744. I changed this to
644, applied, entered my admin pw, and tried to upload it again. I
did the same with 664 permissions. No dice.

I am sure the path is correct for loading the file… Do you still
show it isn’t loading? Any other ideas?

BTW, thanks.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Allright… the folder is 755, the file is 644 (I had also tried it at 664 at your advice). I set it back to 644, and re-uploaded.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

You need to check the current properties while it’s on the server, and
change whatever it is on the server, each time you upload, the file is
replaced and you may find that it is set to different permissions than
you need. There is a property of every folder on a server called
umask. This property defines what will become of files added to that
folder – default permissions, ownership, other flags – and each time
you upload, the files will be affected by this property.

One other thing occurs to me – could you set Transmit to the columns
view (so you can visualize the hierarchy of folders in play here) and
make sure that there really is a folder structure like this:

[your web root folder, where index.html is]/west/chorus/audio/

and that this file exists:

[your web root folder, where index.html is]/west/chorus/audio/player.swf

west, chorus and audio must be at 775 or 755, player.swf must be at
664 or 644.

If all of these things are true (and I really truly don’t believe they
are, or else it would Just Work™) then I have no other ideas here.

Walter

On Mar 18, 2009, at 12:33 PM, Dave Martin wrote:

Allright… the folder is 755, the file is 644 (I had also tried it
at 664 at your advice). I set it back to 644, and re-uploaded.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks. The server uses a shared windows folder to connect, and for the life of me I can’t get my Mac to connect to it. I workaround by using a USB drive to transfer the files to the PC, where I upload them. I’ll see if I can find a comparable utility to check file permissions on the PC.

Thanks for all your help… I’ll post back if I can get it to work.

Dave


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Dave,
Looking at your HTML code for this page I can see that you appear to have two
problems;

  1. The link to the SWF file appears to be incorrect. It should be simply;
    audio/player.swf
    and not;
    www.taylorschools.net/west/chorus/audio/player.swf
  2. The MP3 file also appears to be missing. According to the code it should be
    here;
    http://www.taylorschools.net/west/chorus/Riu.mp3

Once you get these fixed I think you’ll be back in action.
Regards,
Tim.

Extend Freeway the way you want with FreewayActions.com
http://www.freewayactions.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Brilliant!

And oh, was I dreading how to figure out Windows vs UNIX permissions!

Thank you both. The player is now working, and I’m going to get hopping on coding pages to use the new player.

Dave


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options