Moo Tools Lightbox & Firefox

Hi All
I have a weird one here. I am using Weavers Moo Tools and getting strange behaviour from Firefox 2.0.0.9 The pages in question are hosted on 2 different servers - on 1 the action works fine on the other it either doesn’t work or sometimes the image appears in the same window and off to one side but not above the parent window. Click on the sign images.
Safari 3.0.3 works on both sites - no problem.
The pages are here: Top link OK bottom dodgy.

http://www.signonscotland.net/Products/estate.html

http://www.signonscotland.co.uk/Products/estate.html
As you will see the pages are the same - so what’s going on?

Thanks for looking - David


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi,
Just some loose ideas:

  1. It seems that the problem comes from CSS not javascript as even with the “wrong” displayed pages, it’s possible to close the pop-up window with Ctrl-x.

  2. With Firefox, open the Error Console and see what happens. May be the two http servers have different configurations. In particular, look at the error about the MIME type of the CSS file:

“Error: The stylesheet http://www.signonscotland.co.uk/Resources/slimbox.css was not loaded because its MIME type, “text/plain”, is not “text/css”.
Source File: http://www.signonscotland.co.uk/Products/estate.html
Line: 0”

Hope this helps.


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I feel obliged to comment here: JJBee, thanks for the notice of the CSS not being flagged properly. This is a server configuration issue, not really one with anything that you can change through FW.

Someone much more knowledgeable about the exact config location should be of better help.

If needed, blow the conch shell of the Server Gurus…dooWOOOOOOOoooo…


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi JJBee

"…its MIME type, “text/plain”, is not “text/css”. "

How can I influence this if it is the root of the problem? Obviously the css is written by the action or is it the server that interprets its type according to its configuration.

David


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi,
Try this:

  1. send your page to the W3C validator:
    http://validator.w3.org/check?uri=http%3A%2F%2Fwww.signonscotland.net%2FProducts%2Festate.html&charset=(detect+automatically)&doctype=Inline&group=0
    It’s always a good idea to test your pages with W3C validators (for (x)html and css).
    Look at the first error…

  2. try to wipe the close () tag of line #5:
    REF="…/Resources/slimbox.css">

  3. Don’t make any other changes (don’t try to correct other errors for now) and test your page(s) with FF/Safari.

Hope this helps.


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks JJBee - I tried that but it made no difference.

Any other suggestions.

David


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

A way to test whether the issue is specifically with the server or the css file is to convert the co.uk site to use an ‘External CSS’ file, as set via the Document Setup dialog under the File Menu.

Doing this, and publishing should case the page to display out of sorts, even the text and such. As a corollary, the co.uk site should display fine when viewed locally in the very same browsers that appear to be malfunctioning with the live site even now.

The telltale is that the pages (.com vs .co.uk) are ostensibly identical and that the css files are identical as well.

Do you have a server control panel that you can log into for the co.uk server? cPanel or webmin or something like that? Under those, there should be a listing for MIME types that you can indicate file extensions and how to ‘serve’ those pages to the browser.


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Weaver - I did as you suggested and did the external stylesheet thing. It turned the site to mince (a scottish expression). So I guess you were right about the server.

Which brings to mind another site hosted on this server (which I didn’t create) which has the same problem with FF - www.auldtonstoves.co.uk

The hosting company is CWCS and I have been gradually moving all my sites to the cheaper and more feature laden Have-Host. And no, I don’t have access to a control panel where I can do anything about Mime types.

So I guess it is support ticket time with CWCS - how should I word it to make myself understood?

Thanks again - David

PS to Walter - can you add a feature here so that if you have just typed a big long post and clicked send so that you don’t get the error message ‘you need to be logged in to post’ and it wipes all your typing - just a thought.


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 6 Nov. 2007, 9:22 pm, DeltaDave wrote:

So I guess it is support ticket time with CWCS - how should I word it to make myself understood?

Thanks again - David

Tell them that you need to serve css files (files with a .css extension, to be utterly pedantic) with the mime-type text/css.

PS to Walter - can you add a feature here so that if you have just typed a big long post and clicked send so that you don’t get the error message ‘you need to be logged in to post’ and it wipes all your typing - just a thought.

I am working on that, it has already bitten me a couple of times. Truly sorry.

Walter


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

One thing to try while you’re waiting on the support crew:

If you have an .htaccess file already, open it for editing in a text editor. If you don’t, then create a plain text file, and put the following line of text in it.

AddType text/css .css

If you are creating this file for the first time, you will discover that you can’t name a file with a leading period (full stop) in Finder. So name the file htaccess or george or anything you like. Then after you have used an FTP client to move the file onto your server, rename it in place to be .htaccess.

Reload your page, and see if it still works. This shouldn’t cause any harm on a properly configured server, it should just fix the one problem you are having. But if your server isn’t acting kindly, you may have one of the many flavors of 5xx error messages. If you do, then delete it and wait for the help desk to finish their Red Bull.

Walter


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Walter - and other helpful people
I contacted the support lot and they emailed me back

“I have added the MIME type to your domain configuration.”

But the problem persists.
And I also followed Walter’s advice and added the htaccess file - but that made no difference either .

What now?

David


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Take a look at the line where you link in that file:

 <LINK media="screen" REL="stylesheet" TYPE="text/css" HREF="../ 

Resources/slimbox.css">

Note how you have a </LINK> at the end of it? Try deleting that bit
right there. If this is being added by the Action, then contact the
Action author. This tag doesn’t really want a closing tag. In this
HTML level, you would leave it just as the opening tag. In XHTML, you
would want to “self-close” the tag, with a trailing slash before the
closing >.

Walter

On Nov 7, 2007, at 2:29 PM, DeltaDave wrote:

Hi Walter - and other helpful people
I contacted the support lot and they emailed me back

“I have added the MIME type to your domain configuration.”

But the problem persists.
And I also followed Walter’s advice and added the htaccess file -
but that made no difference either .

What now?

David


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi,
It seems ok for me!
The page at:
http://www.signonscotland.co.uk/index.html
looks right and images open in their own window.


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 7 Nov. 2007, 6:46 pm, JJBee wrote:

Hi,
It seems ok for me!
The page at:
http://www.signonscotland.co.uk/index.html
looks right and images open in their own window.

It works fine in Safari, but Firefox is being pedantic or something.

Walter


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Well, sorry for the wrong link, the right one is (of course):
http://www.signonscotland.co.uk/Products/estate.html

Beside that, that’s what I get when displaying the Response Headers (using the nice Firefox extension named Web Developer (a must have)):

"Server: Zeus/3.4
Date: Wed, 07 Nov 2007 19:51:10 GMT
Content-Type: text/css
Content-Length: 1545
Last-Modified: Tue, 06 Nov 2007 21:56:14 GMT

200 OK"

As you see, the css file is now correctly sent with the right mime type.


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

So maybe we have a cache issue any more…

Walter

On Nov 7, 2007, at 2:57 PM, JJBee wrote:

As you see, the css file is now correctly sent with the right mime
type.


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Yes Walter it looks like it was a cache issue. I used Firefox add-on Clear Cache Button and it is all working as it should.

But interesting point you make about the “” - that isa question for Weaver I suppose.

Thank you all for your help on this one.

David


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Well that didn’t display that bit of code which should have read as “closing link tag”
BTW how do you do that walter - display the code?

David


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

If you’re adding a word or two, then just put back-ticks around it
code here. If you want to put a bunch of code in, like a whole
block of code, then put four or more spaces in front of each line of
the code block:

 <?php
 $test = 'foo';
 for($i=0; $i < 20; $i++){
     print $i;
 }
 ?>

There’s an auto-formatter in there that’s supposed to pick those
kinds of things up, but I need to add LINK to its regular expression
so it knows to escape that.

Walter

On Nov 7, 2007, at 5:49 PM, DeltaDave wrote:

Well that didn’t display that bit of code which should have read as
“closing link tag”
BTW how do you do that walter - display the code?

David


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options