New gallery not appearing correctly in any browser

I have just added a new Gallery to a page of galleries using the Focus gallery and it is misbehaving. On my computer everything works fine and there are no problems, everything appears as it should. I have also tried using other Exhibeo galleries as an alternative and the results are much the same, so no gallery works properly. All the other galleries work as they should on the website.

Initially when I create a new gallery I just duplicate the first gallery, change the title, replace the gallery in the duplicate with a new one and then upload with no problem. I did the same this time.

Having uploaded when I go to the galleries page the first thing I notice is that there is no green border around the 2022 Spring Gala as there is on all the other galleries. If you click onto this gallery to display it the gallery appears but the background, which is grey, fails to appear. Secondly there are no controls anywhere on the page. If you hover over the picture the usual hand appears and on click the picture changes to the next one. Of course this should be done with the control on the right side which is missing.

If you try to return to another page on the website the navigation bar is frozen on this page so you cannot change page.

This is happening in all the browsers I have tried, Firefox, Safari and Chrome, so far.

I am using The latest Xway version B5 and the gallery is built using Exhibeo version 2.0.10. I also tried building the gallery in an earlier version of Exhibeho and the result was the same. I am using Montery version 12.3.1.

The gallery page can be seen at Galleries and the offending gallery is the first one, 2022 Spring Gala. The screen shots show how it is and how it is and should be.

Help would be appreciated as I am stuck.

Hi David,

If it’s working correctly on your computer, that suggests an upload problem.

Something that can be helpful in this situation is to choose Show Page Source from Safari’s Develop menu [*]. When I do that for your page I see an error: “Failed to load resource: the server responded with a status of 404 (Not Found):

What this says is that one of the CSS files that is required for the gallery has not been uploaded. You need to make sure that all the files that are in the css folder within the document’s Site folder are uploaded: this should happen automatically if you use Cyberduck or Transmit to synchronise your local Site folder with the online folder.

[*] If you don’t see a Develop menu in Safari, see Use the developer tools in the Develop menu in Safari on Mac – Apple Support (UK)

Hi Jeremy,

Thanks so much for that. Just uploaded the CSS file and bingo all working fine. Such a relief as I was stymid and thank goodness for this wonderful forum!