Opening v4 files

I have just opened a v4 file in v5 beta and there are quite a few areas where I have to check and re-work, i.e. text flow, link colours etc. I know this is a beta and things do get ironed out, but are there areas that will need checking - it’s not too bad if it’s obvious, but if it’s not obvious it could be a problem if anything is missed, especially when converting files with alot of pages.


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Nathan.

The engineers at Softpress took a long time working on FW5 to get it to open FW4 and earlier files smoothly.

The thing is that there have been some changes under the hood, like the way HTML boxes are nested as children, and the way lists are handled, which may cause the odd issue.

If you think the problems you’re seeing are significant enough, drop SP a line via the FW5 beta page and let them know. They may well ask for the file to test against.

Cheers

Heather


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Now try opening a v3 file in the v5 beta. =:-o


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 28 Jan. 2008, 11:28 pm, JDW wrote:

Now try opening a v3 file in the v5 beta. =:-o

Opening a version 3x file in version 4 was never a problem free operation either, so it’s not surprising that it has only gotten worse with the many new changes to version 5. I think it’s best to give up the idea of converting those v3 files and just start over.


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Chuck, have you tried opening your v3 files in the v5 beta? Because when I do, all the menus get grayed out and Freeway locks up.

So it’s not simply a matter of old files needing to be reworked. I can’t open my v3 files in v5 AT ALL. Of course, I have reported this to SoftPress. And I would encourage anyone else experiencing the “v3 lockup” to do so as well.


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 29 Jan. 2008, 1:26 am, JDW wrote:

Chuck, have you tried opening your v3 files in the v5 beta? Because when I do, all the menus get grayed out and Freeway locks up.

So it’s not simply a matter of old files needing to be reworked. I can’t open my v3 files in v5 AT ALL. Of course, I have reported this to SoftPress. And I would encourage anyone else experiencing the “v3 lockup” to do so as well.

To paraphrase an old doctor joke… “Patient: Everytime I open an old v3 Freeway file with v5 it locks up. What should I do? Doctor: Don’t open v3 files.” :wink:

Seriously, I wouldn’t waste my time opening old 3.x files.


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

YOU wouldn’t. But I would. Why? Because I have many LARGE sites still in 3.5.15 format. When I say large, I am talking about 100 pages per site/document. “Just start over” from scratch? I think not.

No doubt the old doctor will chime in with, “Just continue to use FW3.” But I would then counter-argue with the doctor that “FW3 won’t launch on Leopard” and “some newer Macs only run Leopard.” One therefore must either use FW4 or the upcoming FW5 on Leopard.

Opening FW3 documents in FW5 is an absolute must for many Freeway users. Not simply me. With that said, FW3 document import is currently broken, in my tests, in the Public Beta of FW5.

My posts in this thread are therefore a call for SP to fix this major problem, and gather support from my fellow FW users who, like me, still have sites of significant size in 3.5.15 format.


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sometime around 28/1/08 (at 21:43 -0500) chuckamuck said:

Seriously, I wouldn’t waste my time opening old 3.x files.

Nor would I. But that’s because I don’t have any sites still in 3.x
format. There will be many who do, and the described behaviour does
sound like something more serious than just ‘pages need reworking’.

k


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

If you’re an end user with a handful of your sites then you’ve probably kept up with upgrading sites.

But for designers e.g. we’ve got some 150+ Freeway sites, many are still in 3.5 then yes not opening from 3 to 5 is a big problem. Extensive upgrade time is really not wanted :frowning:


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

One must also consider that “performance” and “rework” time are significant issues that keep some sites in 3.5.15 format (which is my case).

I converted ONE of my enormous sites to FW4. I say “one” because it took a lot of work and time, so I decided to procrastinate doing so on my other sites until I had a VERY compelling reason. Another obstacle is the fact that, despite the many great features of FW4 (and now FW5) performance has taken a hit. If you still use a PPC G4 (like many of us do), you will find FW4/5 are quite a bit slower overall (UI, text handling) than FW3. This is a critical point when reworking hundreds of pages in an old FW3 document – you want to get through that task as quickly as possible. But if the app to which you are moving is slower, your job takes longer and becomes stressful. That’s how it was when I moved my ONE big site to FW4 from v3.

But the problem we all face now is FW3 compatibility with Leopard. Not a problem if we continue to use our old G4’s. But for those of us wanting to upgrade to a fast Intel Mac that can ONLY run Leopard, FW3 is no longer an option. Yes, I’ve tried it – FW3 just quits when you launch it under 10.5. Lousy performance of FW4/5 vs. FW3 will somewhat be offset by a fast Intel processor and native code of FW4/5, but the major task of “reworking the document” is still there.

Yet another big issue I’ve faced is with fonts. I’ve you’ve got similar yet different font families on your Leopard Mac (as I do), when you open your old documents in FW5, you get a font warning. Nothing wrong with that in other apps like Illustrator or InDesign because they give you freedom to replace those fonts as you would expect. But FW5 doesn’t always allow you to replace with the exact font missing. For example, if you used one font belonging to a font Family (like Arial Bold Italic), FW5 only shows you the main font Arial in the replacement font list. That means, all your Arial Bold Italic fonts in the document will be replaced with Arial, and you won’t know where those changes were made in your document either! What a mess! In contrast, Illustrator and many other OS X apps let you replace fonts with any member of a given font family. FW5 needs this functionality badly if it expects people to migrate old sites seamlessly.

All this aside, I still can’t open my 3.5.15 documents in the FW5 Public Beta, so I must simply appeal to the powers that be to resolve this.


Freeway5beta mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options