Page Not Found Problem

I am having a problem with a client’s site www.meptec.org.
My client is complaining that customers are trying to sign up for their seminars but are finding that some ( not all ) are experiencing the “Page Not Found” window when trying to register. The specific link is https://meptec.org/meptecmedicalele.html. I have never had a problem with my Mac or PC. I know that it isn’t a Browser
issue because it is happening in IE7 and Firefox as my client
informed me. About 4 months ago WaltD helped me do a redirect to a secure site and all seemed to be running fine.
Now the client is freaking out and wants to go back to a non secure site but I assured him that we didn’t need to do that. I created the site in 4 but have been working in 5 now for 2 months for a point of reference.

Can anyone shed some light here?

Thanks, Clark


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I can’t see anything wrong here in any Mac browsers, but when I try to view it in IE6 XP, I see that it takes a really long time to load. The one time I got it to partially load, it hung around trying to load blank.gif (part of the IE compatibility stuff in Freeway Pro) and then died a horrible death there. Firefox 3 on the same virtual machine has no trouble getting the page or completing the form.

What you might want to try is turning off the IE stuff in the Document Setup, then publish, then turn it on and publish again and upload. Perhaps something isn’t being put in the right place on the server.

Walter


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Slight correction: I just tried again, and the image it seems to be choking on is _clear.gif, not blank.gif. You might want to try this instead:

  1. Locate your local site folder and delete everything within it.
  2. Publish again (this will publish every file over again and make sure it’s all “clean”.
  3. Use an FTP application to empty the site folder on your server.
  4. Upload again.

Lots of work for one little pixel, but you may find that it clears the decks for you.

Walter


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Walter,
Since this site needs to be up during business hours I will try this early tomorrow morning when the traffic is at its lowest.

Clark


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Walter,
I did what you suggested and cleared the decks. I am being told that Firefox has no issues but IE6 is still giving my client problems. It will give them “page not found” on the very same registration page as well as other pages.

https://meptec.org/meptecmedicalela.html

They tell me after 2 or 3 attempts it will finally open the page. Could this be a server problem or do you think its a compatibility problem with IE?

Also, do you know the purpose of the _clear.gif & _blank.gif files? They appear in all my documents created
in Freeway.

Thanks, Clark


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

_clear.gif is used in table-based layouts to reinforce the layout.
It’s a very old (mid-90’s) trick to make a page layout in an
environment that is as layout-free as is technically possible
(classic HTML has no notion of physical structure, only text and a
hierarchy of headers). There’s a checkbox in the Document Setup or
maybe in the Preferences (can’t remember where exactly) that should
turn this off, it’s called “Reinforce Tables” or similar. This
probably won’t get rid of every single clear GIF, but it might go a
long way toward fixing it.

blank.gif is used in the Freeway “PNG-fix” for IE 6 and 7. IE renders
transparent 24-bit PNGs as having a pale gray (solid, non-
transparent) background unless you use JavaScript tricks to force it
to behave. There’s a check-box in the Document Setup where you can
turn this off and on. If you don’t use any transparent PNGs, or any
Actions or effects that create them, then you can turn this off.

As far as your underlying problem goes, I’m baffled. There’s nothing
odd in your site, nothing I could see using Firebug that might be
tripping up IE. But it certainly did hang for me, never did get IE6/
XP to even finish loading it.

Walter

On Aug 18, 2008, at 10:13 AM, Clark Brown wrote:

Walter,
I did what you suggested and cleared the decks. I am being told
that Firefox has no issues but IE6 is still giving my client
problems. It will give them “page not found” on the very same
registration page as well as other pages.

https://meptec.org/meptecmedicalela.html

They tell me after 2 or 3 attempts it will finally open the page.
Could this be a server problem or do you think its a compatibility
problem with IE?

Also, do you know the purpose of the _clear.gif & _blank.gif
files? They appear in all my documents created
in Freeway.

Thanks, Clark


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Walter,
Thanks for the detailed information. It’s still is a puzzle to me why this isn’t working. I emailed my GoDaddy ISP and asked if it was on their end.

Here is their reply:

After reviewing your inquiry it appears that you may be refering to the error “Site Contains Secure and Non-Secure Items.” This means that they are pulling files from another site or have hard coded http without the “s” for some of the files on the page. You will need to debug your code and ensure all files are pulled from your site using https.

Does this make sense regarding the redirect? If so, I know nothing about debugging code or the first step in fixing this.

I appreciate all your help.

Clark


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Actually, this makes a lot of sense.

Do you have a separate Freeway document for the secure part of your
site? When you upload to your server, do you have a separate root
folder for the secure stuff? On one of the sites I work on (hosted on
Rackspace) there is a folder in the account root called ‘httpdocs’,
and another called ‘httpsdocs’. Content for the secure site is only
available on the secure site if it is in the httpsdocs folder.

If I recall correctly, GoDaddy is hosting both secure and insecure
forms of your site out of the same folder. You may need to go to an
Action or a post-processing step with a programmer’s text editor to
rewrite all of the references to images as absolute https:// links
rather than Freeway’s standard relative links. Or, you may be able to
get away with it by putting a BASE HREF meta tag in your secure
pages. The only issue I can think of with that latter approach is
that your visitors may decide to drop the www. part of the URL, which
would cause a security error again.

Try this (requires PHP file-endings on all pages) to work around the
problem:

//in the Page/HTML Markup dialog, in the After head section
<base href="https://<?php echo $_SERVER['SERVER_NAME'] ?>"/>

You may need to adjust that if you are running in a sub-folder, but
it might do the trick.

Walter

On Aug 18, 2008, at 4:37 PM, Clark Brown wrote:

Does this make sense regarding the redirect? If so, I know nothing
about debugging code or the first step in fixing this.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options