Photoshop just stopped working

My Photoshop CS2 just topped working today for some reason. It will launch - indeed, double click an image file will launch it. But it won’t open it. I can’t open any file, either by double clicking, drag n drop nor file-open…just get a spinning beachball

Force quit says ‘Photoshop not responding’

I’ve tried trashing the prefs and relaunching but to no avail. Trouble is, there are probably prefs sprayed all over the place, and I’m not sure what to remove from where!!

I can’t reinstall as don’t have discs - machine came preloaded.

any thoughts?

Hugh


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Verifying/Repairing permissions would seem the first place to start.

Applications>Utilities>Disk Utility.app

David


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi David,

No luck there I’m afraid…


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

It depends on where it starts to stall.

Have you tried turning off fonts and restarting?

Perhaps flush font caches using Download FontNuke for Mac | MacUpdate

May be worth a try.


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

It depends on where it starts to stall.

It stalls on trying to open a file. The programme launches just fine, by whatever method you choose to invoke it, File>open, drag n drop, whatever. But it refuses to open the image file, just get endless spinning beach ball.


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Same file or multiple ones? Try others if you have not.

Another suggestion is to log in as another user and see if you can do anything then.

Before that, try creating and saving a file, close it, and open it again.


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Joe, you’re a very clever man…

It was failing on ALL files, any file.

I haven’t got another user so didn’t bother with that, but I did try ‘creating’ a new file…which I was able to do, and saved, and closed…and opened it again!

I saved it as PSD, also as JPG and could open both, even after quitting and restarting Pshop.

The amazing thing is…all my other files are now opening hunky dory just like before!

Wonder what that was all about?..

Many thanks for the thoughtful workaround!

cheers
Hugh


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Ha! It’s weird, but it seems like sometimes software/computers need a kick once in a while. Sort of like when you car battery dies and you give it a jump and it’s fine from there.


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options