Preview (and Publish) only reveals html code

I have just started the Xway tutorial, and when trying to preview or publish only html code pops up. I have done everything (me thinks) by the book so far. Can somebody get me on the right track?

Hi Jon,

That seems strange. Xway has an HTML view, but there is a separate Web view. I think you’re also saying that previewing in a browser doesn’t work either.

Can you share your document, or send it to support at softpress dot com?

Hello, Thank you for looking into it. Preview opens up a BBEdit html, while when Publish nothing happens. Also, I’ve tried to redownload Xway.

I’m sending you the documents via email. I didn’t find any way of attaching it to this message.

Hi Jon,

  1. Preview publishes your current page and displays it in your default web browser.
  2. Publish publishes (outputs) your entire site, so it is ready to upload.

I think you may have set BBEdit to be your default web browser (look in System Preferences > General). If that’s not the case, perhaps you’ve set it to be the default application for opening HTML files.


  1. My default browser is Firefox.

  2. Publish doesn’t publish anything. As of now Preview is greyed out, as is Preferences (in Xway).

Have you had time to look at the document I sent?


Hi Jon,

I don’t have any problem previewing or publishing your document.

It’s fine that Preferences is disabled (there aren’t any, yet). Print and Page Setup are also disabled (Xway doesn’t support printing yet).

How do you know that Publish doesn’t publish anything? Do you have a Site folder? (File > Show Site Folder)

It’s strange that Preview is disabled but Publish presumably isn’t.

Does Xway’s internal preview work for you? (Choose Web Preview from the View menu or click on the Web Preview tool in the toolbar.)

Hello Jeremy,

The site folder is located inside the “Xway test” site icon, presumably put there automatically as I’ve been following the instructions. Seems a bit strange to me, as different to Freeway.

Web Preview in the View menu is greyed out.


There seem to be a few things going on:

  1. Originally you were able to preview, but the page was opened in BBEdit instead of a web browser
  2. You are no longer able to preview at all because Preview is disabled, along with the Web view

The second issue suggests that you have turned off the Publish checkbox for the page you are working on. Preview is disabled if this checkbox is turned off. If you are working on a master page, Preview is disabled if all the master page’s instance pages have Publish turned off.

The first issue is something I can reproduce if I set BBEdit to be the default application for opening HTML files:

  1. Select an HTML file (any HTML file) in the Finder and Get Info
  2. Click on the Open with popup and choose BBEdit instead of Safari or Firefox (etc.)
  3. Click on the Change All button.

The way to get out of this situation is to reset your default browser in the General pane of System Preferences. E.g. change it to a different browser and back (just clicking on the popup and selecting the current default browser also works for me).

Thank you. I will look into your email after the weekend. Have a good one.

Ok, back to work. Publish checkbox was not disabled, but I think resetting the default browser was what resolved the problem. I have no idea why or how, but thanks anyway for the assistance.

While I have your attention could you tell me if it is right that the site folder should live “inside” Xway, as it is at present? As of now I have to Show Package Contents.


The Site Folder is inside the Xway document package, not the Xway application package, hopefully. One of the pain points of Ye Olde Freeway was the way that the Site Folder could get lost (at least in people’s minds), since it could be anywhere. And if you moved the document to another storage volume (server, a different drive), even your Mac could lose track of it. So having the Site Folder under the application’s firm control is a good thing, at least in my experience and imagination of problem points.

Right now, since Xway can’t do the upload part of the problem, this makes it slightly awkward for you as a user, and I completely get that. I believe the long-term plan is to have the Site Folder be something you rarely need to locate with both hands, as it were.


Yes, there were sometimes a problem with the site folder location in Freeway.

Thank you for your help.


You can display the Site folder by selecting Show Site Folder from the File menu. Be careful not to change anything that is in the document package, outside the site folder.