[Pro] a challenge for all challenges

Can someone tell me why this 1st page flashes black prior to the Supersizer background image showing while the second link does not?

http://hoffkids.com/bgtestfromblk.html

http://hoffkids.com/backgroundtest.html

THe difference between the two is the following…
The first page HAD a black background on the page that was removed prior to putting the background supersizer action on.

The second one had a BLANK master2 then added the BG action.

The reason I need to figure this out, is because I am going to add the BG action to a page I made already w/black background which I will remove. Therefore I need to figure it out becuase I have the page done already I just want to change the black out for the action and want it to work like the 2nd link above.

Thanks.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

new info.

on the page that flashes black which I have “none” as the page background, I changed it from none to a picture just to see what happens and it still flashes black.

All I can think of is it is affected because it is working off of MASTER1 which has a black background?

I also tried making the background WHITE and this helped the problem a little bit…
as it flashes white instead

http://hoffkids.com/bgtestfromblktow.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Because your body tag has a background property of #111 (almost black).

Todd
http://xiiro.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

excellent- can you help me to get rid of it (or change it t whatever would be “none”

thanks!!!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

excellent- can you help me to get rid of it (or change it t whatever would be “none”

Open the main Styles Editor and look for a style name named ‘body’ (though technically it’s a tag name, not a ‘style’) and see if there’s a background property.

Todd
http://xiiro.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

do I go to EDIT at the top, then styles?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

do I go to EDIT at the top, then styles?

Sure, that’s one way.

Todd
http://xiiro.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

did that but nothing under column NAME says “body” if that is where I should be looking…


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

where did you see the thing about the 111 the source code? I looked there and did not see anything.

on this site…

http://hoffkids.com/bgtestfromblk.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

did that but nothing under column NAME says “body” if that is where I should be looking…

Then open the Inspector palette and click the ‘brush’ icon, you should see a ‘Background’ picker … choose a color.

Todd
http://xiiro.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The background color is in an external stylesheet produced, I assume, by
the action. If you look at the file referenced in the head of your document
you will see it “Resources/supersized.css”

You can manually edit that, but why – that doesn’t change anything but what
color ‘flashes’ before the image loads. I say live with it, it’s not too
bad.


Ernie Simpson

On Sun, Jul 8, 2012 at 12:23 AM, Barry Hoffman email@hidden wrote:

did that but nothing under column NAME says “body” if that is where I
should be looking…


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

of course I did that- the background color says “None”

what made you say that there was something that says body tag property#111?

On 8 Jul 2012, 4:27 am, Todd wrote:

did that but nothing under column NAME says “body” if that is where I should be looking…

Then open the Inspector palette and click the ‘brush’ icon, you should see a ‘Background’ picker … choose a color.

Todd
http://xiiro.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

BIg Erns,

I have to disagree because if that was true it would always flash black when the BG action was used wouldn’t it?

I showed that when I started with a clean master2 it did not flash black; doesn;t this prove it must be related to how my page was BEFORE I removed the black background (which also seems coincidental to be black and that is what I had before I removed it…)


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I have to disagree because if that was true it would always flash black when the BG action was used wouldn’t it?

I’m looking at the stylesheet for the action and the body tag has background of #111. That’s where it’s coming from. Remove it and see for yourself.

Todd
http://xiiro.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Todd, sorry you must think I know what I am doing (beginner here).

I have zero idea when you say you looked at the stylesheet for the action and the body tag…

I have no idea how to see it , remove it, etc…

Thanks for your help, I just have no idea on this end…


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I have zero idea when you say you looked at the stylesheet for the action and the body tag…

I have no idea how to see it , remove it, etc…

Thanks for your help, I just have no idea on this end…

Then go back into the Styles Editor and create a new style like this:

  1. In the ‘Tag’ field enter ‘body’ (no quotes).
  2. TAB over to the ‘Name’ field and if there’s anything in that field DELETE it and TAB out; it needs to be empty.
  3. Select a background attribute and pick the white color (not ‘None’).

See if that helps.

Todd
http://xiiro.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

ok-thanks!

will do now.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I have zero idea when you say you looked at the stylesheet for the action and the body tag…

I have no idea how to see it , remove it, etc…

There’s a CSS file named ‘supersizer’ in the Resources folder for your site. If you were to open that file in a proper text editor you will see that there are 3 instances of: background: #111;.

That’s how I know it’s coming from that stylesheet, I ‘extracted’ the 'sheet from your site with a 3rd Party CSS tool.

Todd
http://xiiro.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

very cool.

was that based on just this page or other pages?

http://hoffkids.com/bgtestfromblk.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

very cool.

was that based on just this page or other pages?

http://hoffkids.com/bgtestfromblk.html

On both pages you posted. But it’s going to be on any page that uses Supersizer.

Todd
http://xiiro.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options