[Pro] Animationfx Action and Menus

Has anyone had an issue with their responsive mobile menus not working if you are using the animationfx action?

Billy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Nope, works just fine for me.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Have you added any other JS to the page, long-hand maybe? Link?

Walter

On Jun 9, 2016, at 1:26 PM, billy kimmel email@hidden wrote:

Has anyone had an issue with their responsive mobile menus not working if you are using the animationfx action?

Billy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

No other js on the page.
Here is the link: http://smartytest.com/rick

If you make your browser small enough to see the responsive hamburger, then choose one of the menu items, you will see it will go to that part of the page but the menu doesn’t collapse away.

Billy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

No other js on the page

What about embed-player.js, ad_status.js, jquery, smoothscroll, jq-simple-modal.js and wow?

And Exhibeo and WebYep etc etc.

Strip it back and add them one at a time until you hit a problem.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

You can’t mix the FX Actions and jQuery. The FX Actions (built in to Freeway) are based on Prototype/Scriptaculous, and they don’t have any sort of compatibility shim to allow those two to play nice. It’s also an incredibly wasteful thing to have Prototype and jQuery in the same page, because they both do the exact same things (slightly differently). One or the other, and if you use jQuery for anything, don’t use any of the built-in FX Actions or any of my Scripty Actions.

Walter

On Jun 12, 2016, at 6:56 PM, DeltaDave email@hidden wrote:

No other js on the page

What about embed-player.js, ad_status.js, jquery, smoothscroll, jq-simple-modal.js and wow?

And Exhibeo and WebYep etc etc.

Strip it back and add them one at a time until you hit a problem.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I don’t have any of the mentioned above on my page other than Web Yep which does use a jQuery modal window and lightbox.
I never had an issue with this on other sites that I have built the exact same way. As far as exhibeo is concerned there shouldn’t be a problem, right? I mean it was designed to work with Freeway and Softpress created the CSS responsive menu action, so I’m confused.

I turned off any FX Actions and still have the issue.
Billy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

So I rebuilt the menu and suddenly it works fine. Some kind of corruption? These things can drive one nuts.

One other question.
If I want to have a background color on hover Only in the responsive part of the menu, what do I reference?
.responsive-menu as class or fwNavcontainer1

Billy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options