[Pro] audio in the website

Hello again. Ive got a question about audio. I ve tried with background audio and with audio.js action, but both have the same problem: If you copy and paste the element in every page, the sound start again when you click any section button. So you cant have the audio playing as long as you visiti the web, because it is starting again and again…

I think a way to make it is with frames, but, perhaps there is another way. Is possible?

Thanks.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

one of a hundreds nearly similar lists on board that can be reached by typing “background music” into the search facility above:

http://www.freewaytalk.net/thread/view/87112#m_87116

Just to prevent Walter from writing everything each time new.

Cheers

Thomas


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks. Its quite usefull this idea about getting it on a new window.

I did the search before asking, but as audio player, web audio, web music… and I didn’t find anything to help me about this.

Besides, at the beginning, I installed freeway in spanish, and It is a mess, because the translation is really strange, there are sentences that have no sense at all, and actions, commands and others are semi-translated, so I don’t know how things are really named. When I read at the forum “use the action blablabl” I need to imagine how it has been called in the semi-spanish of freeway. Ive tried to reinstall in english, but I couldn’t find how to. I desinstalled and reinstalled again, but its in spanish again !!!

Thanks again.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

What language is your computer set to use for menus etc.? I believe Freeway takes its cue from that (Language & Text preference pane).

Walter

On Mar 31, 2012, at 12:22 PM, rakeljuice wrote:

Besides, at the beginning, I installed freeway in spanish, and It is a mess, because the translation is really strange, there are sentences that have no sense at all, and actions, commands and others are semi-translated, so I don’t know how things are really named. When I read at the forum “use the action blablabl” I need to imagine how it has been called in the semi-spanish of freeway. Ive tried to reinstall in english, but I couldn’t find how to. I desinstalled and reinstalled again, but its in spanish again !!!

Thanks again.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

My computer is set in Español ISO. In system preferences I have spanish for first and English for second. And in Freeway I cant find anything about changing language.

Thanks.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

That’s the caveat:

To have Freeway “english” you need to bring in your system prefs english on the first place. Quit Freeway and restart. But this in fact will set all other applications with their next start in english, too.

Cheers

Thomas


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Try, just for a moment, dragging English above Spanish in the list of languages. You may need to restart your computer to see the change, but Freeway should pick up the English translation automatically.

If you have suggestions for better translations, I recommend you make a list and send them to support(a)softpress.com. You can either put the bad Spanish next to the correct Spanish, or use English as the key and show what you would prefer opposite that.

Walter

On Mar 31, 2012, at 2:54 PM, rakeljuice wrote:

My computer is set in Español ISO. In system preferences I have spanish for first and English for second. And in Freeway I cant find anything about changing language.

Thanks.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks. Two things:

  • Ive changed the language as waltd said. Now Ive got freeway in english!! Ive got the computer in english aswell, but doesnt matter. Before, I had all the programs in english aswell. The finder is the only I was using in spanish.

  • Audio. Ive solved the audio with the new span window, but now i dont know how to close it. Ive done:

  1. In the master, so it is in all the pages, I open the new window with the span new window action

  2. In the master aswell, I put a button with the link javascript:audio.close() where audio is the window name.

Opening works from everypage, but Close only works from the index.

  1. I also put a javascript:audio.close() in the new window and it works.

So, how can I close the window? The pages (every page but not the index ) are in a docs folder. Ive tried with javascript:parent.audio.close() but it doesnt work at all.

Any help?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I forgot the link for viewing the audio thing: www.ladiosaimpura.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hello again. Any idea about closing this new window, please?

Ive put the question in javascript forums, but the answers are related to common programmed pages, so I dont know how to implement them in freeway.

Ill explain what I did better:

The web www.ladiosaimpura.com has several pages. Index is in root, and others are in /docs folder. From every page (index and others) I can open a pop up window called “audio” with the background action on it. I open the window with spawn new action. In every page I add a button with the external link “javascript:audio.close()” to close this pop, but it only works from the index, not from the other pages.

Thanks


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The Spawn New Window has a Close Window Action. On the web page that is opened in the Spawn New Window Actions, draw out a graphic box and apply the Close Window Action to it.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hello, Paul

I didnt see before the Close Window Action because it is in different place from the spawn New Window:
spawn- Insert>Action Item (dont need an item)
close - Item>Action (need to create the item)

But now Ive found it, thanks a lot, my question is: I’ve put the Close Window in everypage, but it doesnt work. In the action palette Ive set javascript; and # in the selector but any of them works. They just close the page I am, not the window called “audio” Ive opened with spawn new window. There is no place to tell the action wich window I want to be closed

Thanks.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Aha. Okay, you need to figure out what JavaScript name you called that audio window. Then a call to [window name].close() will do the trick.

If you used Spawn New Window to open the audio window, then the name you need is found in the “Internal JavaScript Name” field. Whatever you enter there will become the name of the opened window in the browser’s memory space. So if you had item42 in that field, you would attach the following URL to your close button:

javascript:item42.close()

If that doesn’t work, then try this: apply a blank URL to the button element (either # or javascript:) and then use the Hyperlink dialog’s Extended interface to add an onclick handler that looks like this:

  • Name: onclick
  • Value: item42.close();

Walter

On Apr 5, 2012, at 10:47 AM, rakeljuice wrote:

Hello, Paul

I didnt see before the Close Window Action because it is in different place from the spawn New Window:
spawn- Insert>Action Item (dont need an item)
close - Item>Action (need to create the item)

But now Ive found it, thanks a lot, my question is: I’ve put the Close Window in everypage, but it doesnt work. In the action palette Ive set javascript; and # in the selector but any of them works. They just close the page I am, not the window called “audio” Ive opened with spawn new window. There is no place to tell the action wich window I want to be closed

Thanks.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

nops… it doesnt work at all… The first method I tried before asking, but it didnt work. The second one Ive tried it now, and it doesnt work…

Is it possible to happens this because of the pages are in a folder called docs, not in root?

Now, in the web i have the first method in english version and the second one in spanish version. And I ve changed the name of the window, because audio is quite common word. Now its called sonido.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Is it possible to happens this because of the pages are in a folder called docs, not in root?

No

Can you post a link to your page(s)

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The link: www.ladiosaimpura.com

Now, in the spanish version is made with the extended method, and the english one with the no extended one.

If you press audio on in any page, and then press audio off in the same page it works, but if you press audio on in synopsis for example, and audio off in pictures, it doesnt work.

Thanks again.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options