[Pro] copied files in site folder

What am I doing that makes the files get copied in the site folder and resource folder? I have 13 of the same file and 4 or 5 of some others. ANNOYING and TROUBLESOME!!!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

What am I doing that makes the files get copied in the site folder and resource folder?

I am afraid that you are going to have to be a bit more specific - you haven’t even told us what version of FW you are using or given us a link so that we can see your pages online. Are you uploading with FW? Are you adding anything to the site or Resources folders?

Without more information we can only speculate.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Empty the entire site-folder, making sure to save and rescue any manual added files. Publish again. I’m not aware what Freeway causes storing the 10th duplicate of the original but it’s a known issue.

You may “delete and republish” from time to time.

Cheers

Thomas


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Sorry for the slow reply but I’m in a different time zone (U.S.A. central). I’m writing this on Tuesday at 8AM my time.

David,
I’m using FW7 pro and am on a mac laptop.
The sight I did is www.scottseed.net.
Yes, I have added files to the resource folder when the uploaded version doesn’t have the image popping up…so i take the file and place it in the resource folder;

Everytime I make a change, I place everything in the htdocs folder through filezilla not FW.

Thomas,
I recently created a test directory in the htdocs and uploaded the whole website to test it and I got 13 “FW_SendForm_contactus.php” files.

Thanks,
pete


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Everytime I make a change, I place everything in the htdocs folder through filezilla not FW.

In that case only upload the most recent version of the “FW_SendForm_contactus.php” file.

Alternatively delete all versions of the same file before doing a final publish and upload. That way you will only get one.

Yes, I have added files to the resource folder when the uploaded version doesn’t have the image popping up…

You would be better getting to the root cause of the missing pop up images than this workaround.

If you weren’t manually uploading then this would be a NO-No as FW will ignore anything in the Site folder unless it was aware of its presence as it was added via an action or through FW itself and not upload it.

The other danger is that FW will rename Resources at publish time if there is one there already with the same name. You may be creating the problem for yourself.

Any particular reason you don’t use FW to upload?

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

This is only true if the file exists in your Site Folder on your Mac. Freeway does not care at all about a file in your server’s site root with the same name. It will cheerfully overwrite your existing file on the server. But on the Mac, there are protections built into the Finder that make it not possible to save a file with the same name in the same folder, unless the application doing the saving either already has an open file handle to it, or deletes it before writing.

Walter

On Jul 21, 2015, at 5:09 PM, DeltaDave email@hidden wrote:

The other danger is that FW will rename Resources at publish time if there is one there already with the same name. You may be creating the problem for yourself.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

There’s no reason why I don’t use FW to upload files other than I’v never done it that way before. I’ve always used filezilla. Comfortable with that.

Link on how to upload with FW would be appreciated.

So basically, select the files you want to display on the page and let FW place them in the resource folder…And if it doesn’t show? Could the directory, where the file exists, be to far down the directory line?

Thanks for your help guys.

pete


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Link on how to upload with FW would be appreciated.

Open File >Document Setup then click on the Upload Tab

Fill in the details the same as you would with FZ ie

Upload: FTYP

Server: www.yoursite.com

Directory: usually something like public_html or htdocs etc.

Username: your_username

Password: your_password

Web Address: http://www.yoursite.com

FTP Mode: Automatic should do it but if you have issues then Toggle Passive/NonPassive and see which is best.

So when you want to do an Upload all you do is Cmd + U (File>Upload) = Major Time Saver

And if it doesn’t show? Could the directory, where the file exists, be to far down the directory line?

Nope - Upload with FW and FW knows exactly where to put all the files.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I know experts never use or read a manual. Me didn’t neither. Reviewing my strategy, a loss of min half a year or so.

But never forget:

There had been guys in the past, writing excellent prose being aware of unrecognized at all. It must be frustrating doing such a work. But they did! Writing a manual - a nice one btw.

And even if they forget a significant chapter in a manual, we could ask them for writing one.

Freeway feeds us, takes care of every process the best it can and finally powders our asses. Most of the time I make use of this (especially the part with powder) - sometimes not.

Unfortunately, this manual can’t generate a link to its self.

Cheers

Thomas


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Thanks guys,
few more questions;

  1. which FW_SendForm_contctus.php do I delete since i have 14 in the site folder? Do I keep the first one or the …contactus13.php one?

  2. is my FW site file (where I’m placing and designing with all my elements) suppose to be in the site folder or outside. I have it inside the site folder.

  3. I have an iframe commodities feed from a third party…will publishing break that link? I have never published my site before.

thanks everyone,
pete


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Delete all of them, then delete all of the copies from your Site Folder on your Mac, then publish once and upload. After this, you should only have one, without the numeric extension.

Walter

On Jul 22, 2015, at 11:45 AM, pete email@hidden wrote:

Thanks guys,
few more questions;

  1. which FW_SendForm_contctus.php do I delete since i have 14 in the site folder? Do I keep the first one or the …contactus13.php one?

  2. is my FW site file (where I’m placing and designing with all my elements) suppose to be in the site folder or outside. I have it inside the site folder.

  3. I have an iframe commodities feed from a third party…will publishing break that link? I have never published my site before.

thanks everyone,
pete


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Do I keep the first one or the …contactus13.php

The most recent. OR - delete them all and republish once more to be left with one.

I have it inside the site folder.

The FW doc should NOT be within the Site Folder. Typical structure

Project Folder - which contains:

FW Doc

FW.backup file

Media Folder (original artwork, files, text docs etc

Site Folder (which contains html pages, Resources Folder, CSS files etc.) KEEP OUT!

I have an iframe commodities feed from a third party…will publishing break that link?

No - you can see it in preview I assume. Publish is no different.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Thank you D.
Will do!

pete


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options