[Pro] create email, pix not found

Hi!

I created a master email page holding 2 graphic items, one as a background and the 2nd ones as a logo, and a few html items around with some text. Nothing fancy, I believe. I then created an instance email page of the master, applied the create email action on both master and instance pages, with the “preview on server” option on. I built, uploaded successfully, preview and… lo my graphs are not found, replaced with question mark pix. I verified the file has been uploaded in the right place…

What could be the problem? Did I miss something important in the process here?

Tx in advance,

Claude


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Claude,
Do you have a url of the page online that you can share with us? It
sounds like the path set in the document setup may be incorrect.
Regards,
Tim.

On 14 Oct 2010, at 20:47, claude wrote:

What could be the problem? Did I miss something important in the
process here?


Tim Plumb
Creative Director
Softpress Systems

Follow us on Twitter: http://www.softpress.com/tny/064
Join us on Facebook: http://www.softpress.com/tny/063
Looking for a webhost? We love FatCow: http://www.softpress.com/tny/05v


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 14 Oct 2010, 9:13 pm, TIm Plumb wrote:

Hi Claude,
Do you have a url of the page online that you can share with us? It
sounds like the path set in the document setup may be incorrect.

Yes, of course, after all we deal with public stuff here {:-). Here it is:

http://celticcenter.eu/fi/tiedotteet/tiedote102010.html

You’ll notice the pix in the middle of the header (a green logo) is not found. I removed all other pix to make things simpler. The text and setup is fine though on safari.


Claude


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

wrong path (why the heck …?) actual:

http://www.celticcenter.eu/fiResources/x100a1a.gif

correct path (should be)

http://www.celticcenter.eu/Resources/x100a1a.gif

It’s the reason for not finding it, but I do not have an explanation for it. By default, FW is using Resources folder for the images, but the path pointing to a fiResources folder

Thomas


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 15 Oct 2010, 9:30 am, Thomas Kimmich wrote:

wrong path (why the heck …?) actual:

http://www.celticcenter.eu/fiResources/x100a1a.gif

correct path (should be)

http://www.celticcenter.eu/Resources/x100a1a.gif

It’s the reason for not finding it, but I do not have an explanation for it. By default, FW is using Resources folder for the images, but the path pointing to a fiResources folder

Hmm, I am a bit puzzled by this one. I re-instantiated the email page from the master. The master gif’s name is x100, automatically picked from the name of the file. I actually manually inserted the pix inline in a 2x3 table, in the merged 1-2 and 2-2 cells. The master looks fine. After instantiation, for some reason the new page holds a pix with name changed to x100a (letter “a” automagically added by FW), and no sign of inheritance in the left pane, i.e. no parenthesis after the x100a pix name, as if the pix was disconnected from the master pix and duplicated. This looks weird to me and I don’t understand what happens, could it be the reason of my problem?

I just re-uploaded the page. Preview still does not work the link to the pix is still broken.


Claude


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Yes - maybe partially - in fact the master point of the question is:

why is your sourcecode pointing to a fiResources folder and not to the “common” Resources folder FW is creating by default?

It’s this part: look at the img src=

Celtic Center .EU

x100a1a

Kuukausitiedote

neither path nor filename matches the needs.

I cleared up this and set the path and name to what it should be:

http://www.kimmich-dm.de/newsletter/tiedote102010.html

and it will work.

Thomas


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 15 Oct 2010, 12:46 pm, Thomas Kimmich wrote:

Yes - maybe partially - in fact the master point of the question is:

why is your sourcecode pointing to a fiResources folder and not to the “common” Resources folder FW is creating by default?

I have no idea how that non existent folder name has been formed and I agree with you that it looks suspicious. I may have an explanation but not the fix. Folder leafname concatenation is crooked in this case.

My site is in 3 languages, Finnish, English and French. All page files are located under 3 directories: /fi, /en and fr/. I manually created these folders in FW and manually create my page instances under either one of these folders. It is the way recommended by softpress, if I recall, and that suits me fine. Until I applied an email create action…

Now, I have the feeling that FW concatenates wrongly the subdirectories, adding from times to times an un-needed leaf name, hence the “fiResources” instead of likely “Resources”. I had a look at the content of the links I formerly created in the pagethat you modified below and… some of them are broken, holding one of these extraneaous leaf name. I verified these are broken as well the same way in the original built file upkoaded from my computer. The crooked links are:

http://www.celticcenter.eu/fien/home.html → “fien” should be “en”, extraneous “fi” added here

http://www.celticcenter.eu/fifr/accueil.html → “fifr” should be “fr”, extraneous “fi” added here

http://www.celticcenter.eu/ficentre.html → “ficentre.html” should be “centre.html”, extraneous “fi” added here

Do we have a pattern here? I am not sure. Why “fi” and not any other folder name? Finland is the country I am living in but, well… I am lost for now. What I know is that my email page is not usable.

It’s this part: look at the img src=

neither path nor filename matches the needs.

I cleared up this and set the path and name to what it should be:

http://www.kimmich-dm.de/newsletter/tiedote102010.html

and it will work.

The link above, after your fix, works, showing the pix, but there are still problems in paths wrongly (IMO) created by FW.

Any idea of what I could do?


Claude


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Claude,

A few questions:

Are the folders "f"i and “tiedotteet” in Freeway on just on your server?
What have you got in your Web Address field in the Upload dialog?
How have you uploaded your site?

Joe

On 15 Oct 2010, at 15:16, claude wrote:

On 15 Oct 2010, 12:46 pm, Thomas Kimmich wrote:

Yes - maybe partially - in fact the master point of the question is:

why is your sourcecode pointing to a fiResources folder and not to the “common” Resources folder FW is creating by default?

I have no idea how that non existent folder name has been formed and I agree with you that it looks suspicious. I may have an explanation but not the fix. Folder leafname concatenation is crooked in this case.

My site is in 3 languages, Finnish, English and French. All page files are located under 3 directories: /fi, /en and fr/. I manually created these folders in FW and manually create my page instances under either one of these folders. It is the way recommended by softpress, if I recall, and that suits me fine. Until I applied an email create action…

Now, I have the feeling that FW concatenates wrongly the subdirectories, adding from times to times an un-needed leaf name, hence the “fiResources” instead of likely “Resources”. I had a look at the content of the links I formerly created in the pagethat you modified below and… some of them are broken, holding one of these extraneaous leaf name. I verified these are broken as well the same way in the original built file upkoaded from my computer. The crooked links are:

http://www.celticcenter.eu/fien/home.html → “fien” should be “en”, extraneous “fi” added here

http://www.celticcenter.eu/fifr/accueil.html → “fifr” should be “fr”, extraneous “fi” added here

http://www.celticcenter.eu/ficentre.html → “ficentre.html” should be “centre.html”, extraneous “fi” added here

Do we have a pattern here? I am not sure. Why “fi” and not any other folder name? Finland is the country I am living in but, well… I am lost for now. What I know is that my email page is not usable.

It’s this part: look at the img src=

neither path nor filename matches the needs.

I cleared up this and set the path and name to what it should be:

http://www.kimmich-dm.de/newsletter/tiedote102010.html

and it will work.

The link above, after your fix, works, showing the pix, but there are still problems in paths wrongly (IMO) created by FW.

Any idea of what I could do?


Claude


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 15 Oct 2010, 2:44 pm, Joe Billings wrote:

Hi Claude,

A few questions:

Are the folders "f"i and “tiedotteet” in Freeway on just on your server?

I created “fi”, “fr”, and “en”, as well as “tiedotteet” (under “fi”) from FW, and uploaded only from FW. That means all these are both on my server and in FW.

What have you got in your Web Address field in the Upload dialog?

Document setup dialog content:

Method: FTP
Server: iteurope.ie
Directory: www/
User name: xxxxx
Password: xxxxx
Web address: http://www.celticcenter.eu/
FTP method: Automatic

How have you uploaded your site?
Using only FW, File->Upload

Did I answer your questions, Joe?


Claude

Joe

On 15 Oct 2010, at 15:16, claude wrote:

On 15 Oct 2010, 12:46 pm, Thomas Kimmich wrote:

Yes - maybe partially - in fact the master point of the question is:

why is your sourcecode pointing to a fiResources folder and not to the “common” Resources folder FW is creating by default?

I have no idea how that non existent folder name has been formed and I agree with you that it looks suspicious. I may have an explanation but not the fix. Folder leafname concatenation is crooked in this case.

My site is in 3 languages, Finnish, English and French. All page files are located under 3 directories: /fi, /en and fr/. I manually created these folders in FW and manually create my page instances under either one of these folders. It is the way recommended by softpress, if I recall, and that suits me fine. Until I applied an email create action…

Now, I have the feeling that FW concatenates wrongly the subdirectories, adding from times to times an un-needed leaf name, hence the “fiResources” instead of likely “Resources”. I had a look at the content of the links I formerly created in the pagethat you modified below and… some of them are broken, holding one of these extraneaous leaf name. I verified these are broken as well the same way in the original built file upkoaded from my computer. The crooked links are:

http://www.celticcenter.eu/fien/home.html → “fien” should be “en”, extraneous “fi” added here

http://www.celticcenter.eu/fifr/accueil.html → “fifr” should be “fr”, extraneous “fi” added here

http://www.celticcenter.eu/ficentre.html → “ficentre.html” should be “centre.html”, extraneous “fi” added here

Do we have a pattern here? I am not sure. Why “fi” and not any other folder name? Finland is the country I am living in but, well… I am lost for now. What I know is that my email page is not usable.

It’s this part: look at the img src=

neither path nor filename matches the needs.

I cleared up this and set the path and name to what it should be:

http://www.kimmich-dm.de/newsletter/tiedote102010.html

and it will work.

The link above, after your fix, works, showing the pix, but there are still problems in paths wrongly (IMO) created by FW.

Any idea of what I could do?


Claude


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Yes, thanks. Could you send your Freeway file into support(a)softpress.com and mention this thread and we’ll take a look at it as soon as possible.

Many thanks,

Joe

On 15 Oct 2010, at 16:10, claude wrote:

On 15 Oct 2010, 2:44 pm, Joe Billings wrote:

Hi Claude,

A few questions:

Are the folders "f"i and “tiedotteet” in Freeway on just on your server?

I created “fi”, “fr”, and “en”, as well as “tiedotteet” (under “fi”) from FW, and uploaded only from FW. That means all these are both on my server and in FW.

What have you got in your Web Address field in the Upload dialog?

Document setup dialog content:

Method: FTP
Server: iteurope.ie
Directory: www/
User name: xxxxx
Password: xxxxx
Web address: http://www.celticcenter.eu/
FTP method: Automatic

How have you uploaded your site?
Using only FW, File->Upload

Did I answer your questions, Joe?


Claude

Joe

On 15 Oct 2010, at 15:16, claude wrote:

On 15 Oct 2010, 12:46 pm, Thomas Kimmich wrote:

Yes - maybe partially - in fact the master point of the question is:

why is your sourcecode pointing to a fiResources folder and not to the “common” Resources folder FW is creating by default?

I have no idea how that non existent folder name has been formed and I agree with you that it looks suspicious. I may have an explanation but not the fix. Folder leafname concatenation is crooked in this case.

My site is in 3 languages, Finnish, English and French. All page files are located under 3 directories: /fi, /en and fr/. I manually created these folders in FW and manually create my page instances under either one of these folders. It is the way recommended by softpress, if I recall, and that suits me fine. Until I applied an email create action…

Now, I have the feeling that FW concatenates wrongly the subdirectories, adding from times to times an un-needed leaf name, hence the “fiResources” instead of likely “Resources”. I had a look at the content of the links I formerly created in the pagethat you modified below and… some of them are broken, holding one of these extraneaous leaf name. I verified these are broken as well the same way in the original built file upkoaded from my computer. The crooked links are:

http://www.celticcenter.eu/fien/home.html → “fien” should be “en”, extraneous “fi” added here

http://www.celticcenter.eu/fifr/accueil.html → “fifr” should be “fr”, extraneous “fi” added here

http://www.celticcenter.eu/ficentre.html → “ficentre.html” should be “centre.html”, extraneous “fi” added here

Do we have a pattern here? I am not sure. Why “fi” and not any other folder name? Finland is the country I am living in but, well… I am lost for now. What I know is that my email page is not usable.

It’s this part: look at the img src=

neither path nor filename matches the needs.

I cleared up this and set the path and name to what it should be:

http://www.kimmich-dm.de/newsletter/tiedote102010.html

and it will work.

The link above, after your fix, works, showing the pix, but there are still problems in paths wrongly (IMO) created by FW.

Any idea of what I could do?


Claude


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 15 Oct 2010, 3:44 pm, Joe Billings wrote:

Yes, thanks. Could you send your Freeway file into support(a)softpress.com and mention this thread and we’ll take a look at it as soon as possible.

Done. Tx to you in advance!


Claude


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Claude,

a shot in the dark:

all content (images) of the subfolders (fi, en, fr) are going to the “Resources” folder in your main root

celticcenter.eu/Resources/

The “newsletter” is situated in

celticcenter.eu/fi/tiedotteet/tiedote102010.html and the email-action is chaining all its contents to somewhere in this subfolder.

This makes sense cause these links must be absolute, but only then if you see your newsletters as a seperate project.

One thing you could do is:

Create a new freeway-file, copy and paste the contents of the existing tiedote102010-page into this new page.

And now important, important!!! to set the correct directory (in that case s.th. like www/fi/tiedotteet/ :

Upload settings:

FTP Server: iteurope.ie
Directory: www/fi/tiedotteet/
User name: xxxxx
Password: xxxxx
Web address: http://www.celticcenter.eu/
FTP method: Automatic

and reupload this again. This enforces Freeway to create a new “Resources” in the tiedotteet folder and helps the action to chain it correct. (Just a proposal, but interesting to know if this could work.

Thomas


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

forgot to mention:

rename your index.html to tiedote102010.html in the inspector.

Thomas


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 15 Oct 2010, 4:00 pm, Thomas Kimmich wrote:

Hi Claude,

Hi Thomas!

a shot in the dark:

all content (images) of the subfolders (fi, en, fr) are going to the “Resources” folder in your main root

Ok, I guessed do.

celticcenter.eu/Resources/

The “newsletter” is situated in

celticcenter.eu/fi/tiedotteet/tiedote102010.html and the email-action is chaining all its contents to somewhere in this subfolder.
This makes sense cause these links must be absolute, but only then if you see your newsletters as a seperate project.

I am not sure of what you mean here. I’ll tell you my plans. My newsletter is closely related to my website, in particular all subsequent newsletters will be linked from the site as soon as they have been issued and distributed. I could implement the newsletters as a separate project but that slightly complicates things. What about if I start having translation in 3 languages of this newsletter? I think it is far better to implement the emailed newsletter under the website project. Just my feeling today. I may be wrong.

One thing you could do is:

Create a new freeway-file, copy and paste the contents of the existing tiedote102010-page into this new page.

And now important, important!!! to set the correct directory (in that case s.th. like www/fi/tiedotteet/ :

Upload settings:

FTP Server: iteurope.ie
Directory: www/fi/tiedotteet/
User name: xxxxx
Password: xxxxx
Web address: http://www.celticcenter.eu/
FTP method: Automatic

and reupload this again. This enforces Freeway to create a new “Resources” in the tiedotteet folder and helps the action to chain it correct. (Just a proposal, but interesting to know if this could work.

I see. This is a good test which I may have to run sometimes soon, but I need to know what I have done wrong or what has gone wrong so far prior to it.

Thanks a lot for your precious help, Thomas!


Claude


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I am also having problems uploading a page with a ‘Create email’ action.

I have created a folder on root level of server ftp://deniseblack.co.uk
Named it “email”

What should the ‘Directory’ and ‘Web Adress’ settings be?
Most times refuses to upload, or if it does the graphics don’t show.

Using Transmit I can see nothing is going into the ‘email’ folder and no new internal Resources is being created.

This is a time consuming, hair-greying issue.

I have up until now loved Freeway, but now my love is unrequited…! OUCH!!!

Please help!

Graeme


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I have created a folder on root level of server ftp://deniseblack.co.uk Named it “email”

Do you normally ftp rather than use FW for upload?

If using FW then just create the subfolder ‘email’ in the FW doc and the Directory and Web Address settings are the same as your FW doc.

Your email page is then created within the email folder in the FW doc.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

No, I normally upload within FW and am doing so here, just created the ‘email’ folder on the server as instructed in the "What’s new in FW 5.5 pdf.

G


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

This from that Guide

You can either create the email as a new page of your current site (inside a new folder in your Site Panel), or you can create a new file independent of your current site file. The first method is the quickest and simplest as Freeway will do all the work for you.
Creating an email within your current site
To make the email within your current site, go to Page>New Folder, give this new page folder a name (perhaps “email”, without the quotes) and click OK. Now, with the folder selected in the Site Panel, go to Page>New Page, give the page a name then click OK. Because the new page is in a new page folder, this will create a specific directory on your web server when you next upload the file, and this directory is the one your email will use for its resources.


So it doesn't actually tell you to create that folder on the server - just within the FW doc.

D



_______________________________________________
freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options