[Pro] CSS not publishing

I’m using FW 5.4 and noticed that the style sheet file is not publishing to the CSS folder. All I can see in the CSS folder is the IE6.css file but not the sheet1.css file. The site displays fine. Changing to publish external style sheets in the Doc Setup makes difference.

Anybody have any ideas what’s wrong


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Try holding down the Control key and choosing Publish Everything
(hidden menu command in the File menu). See if that sorts it.

Walter

On Jul 30, 2009, at 3:10 PM, Helveticus wrote:

I’m using FW 5.4 and noticed that the style sheet file is not
publishing to the CSS folder.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I can’t tell if it’s working or not. I hope it is.

You said you checked the box for “External StyleSheets” and it made a difference? If you didn’t check that box then it’d all be within the HTML document (aka ‘inline’) thus no external file, obviously.

Just trying to figure out what’s going on.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Nope I did not use the external CSS option.

Publish everything is not helping either.
Now the CSS folder is empty not even the IE6.css file is showing up

I republished to a new folder, but no luck


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The external CSS option is required if you want any CSS to be published in an external stylesheet. If you un-check this, you will have only in-page styles, nothing will be pushed out.

Walter


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Okay I republished with external style sheets On.

Now only my second style sheet I made for my WebYep Rich Text items show up.

No sheet1.css or IE6.css


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

This is a bit confusing, could you clarify exactly what you are
doing to publish external stylesheets. Are you using Actions, are you
manually uploading, are you setting the sheet to be external in the
document setup dialog? It sounds like you could be using a combination
of all of the above but it isn’t clear from your posts.

Also, how are you publishing, are you using File>Publish/Preview in
Browser or File>Upload>File Copy/MobileMe?

Thanks,

Joe

On 31 Jul 2009, at 00:43, Helveticus wrote:

Okay I republished with external style sheets On.

Now only my second style sheet I made for my WebYep Rich Text items
show up.

No sheet1.css or IE6.css


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I have noticed this issue “many times” with Freeway, the style sheet
not publishing (mainly not overwriting the existing styles sheets when
changes are made).

My solution is to delete the CSS folder in the site folder and then
publish. This seems to kick Freeway into action.

David

On 30 Jul 2009, at 20:10, Helveticus wrote:

the style sheet file is not publishing to the CSS folder.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I did not use the external CSS action. I first published the site with the External CCS check box “OFF” in the Document Setup - Output Options. Then I republished with the checkbox “ON”

I also noticed that sometimes my sites will publish without all the Resources in place. At times it will place all the files and sometimes only 2 or 3. I noticed this when I publish and view the page in a browser that a background or navigation sprite images are missing. When I view the Resources folder those files were not published. Usually a simple Publish or Publish All will do the trick but for some reason the CSS files are a bit more stubborn.

David’s trick of deleting the CSS folder did help though.

The only reason I noticed the CSS issue, WebYep was not seeing my separate style sheet I created for a Rich Text Item. I finally recreated the style sheet in CSS Edit and then just specified the path in the WY RTI action.

Marcel


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Well I’m glad you got it figured out. I’ve never experienced that before but hopefully it’ll help other people with that problem.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options