[Pro] forms and the form setup

Greetings,

I have a script on my server for processing a form on a freeway-designed website.

The php script has been put in place, and to test it, I used an html form and inserted it into a markup item on the page.

The html form worked, the php script processed the information and sent it to me in an email. (This is the end goal, great !!)

Now, I took off the markup with the html form, and began putting in some fields with Freeway…just a couple of text fields to test and see if it will work.

I then opened the Form Setup, and changed the pull down bar to “POST”, and in the action field, I put in the path to the server that contains the script:

http://www.mrweblink.com/formtoemailpro.php

I then published and uploaded the site. As I test it, it will not work. I’m missing something and can’t figure out which step that I am missing.

In the Freeway manual on pg 296, it discusses setting up form scripts. There is a paragraph that says to copy the script to the clipboard, and then go to Freeway and choose PASTE SPECIAL from the edit menu, and that the Form Setup dialog and data will have appeared.

There is no PASTE SPECIAL command under the edit menu…just paste.

Trying to make all this jive, and can’t. Need help.

Thanks,

Rich


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The important thing about recreating your markup form within FW is to ensure that your FW created form fields are named exactly the same as your Markup ones (and also the same type) ie checkbox for checkbox etc.

If you do this and change as you have to post to the existing handler you should be fine.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

One place to look very carefully on this sort of problem is as follows: if you draw a form element on the page in freeway, and only look in the left-most tab of the inspector, you might believe that you named the field correctly. But if you look on the output tab, you’ll see a field named Name. This is the only thing you should be looking at. The field on the left tab is called Title, I think, and it gets converted to the id of the div tag that freeway uses to position the field on the page.

Walter


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Walter,
Not sure if I am having the same issue or not, but I am also having trouble with the Form Action. I am using the Form Setup with Post and Action set to http://www.mysite.com/cgi-sys/FormMail.cgi

I have four fields and a graphic submit button. It looks great! But, it isn’t working. I don’t see the code I expect:

..... lotsacodehere ......

Any suggestions?

Thanks Jan


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Post a link to your form page Jan and we can have a look.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

http://www.myreadycenter.com/alphasite/workwhere.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Is this an inline layout? There’s a bug in Freeway that causes it to
drop the form tag on inline layouts. Simplest fix is to draw a single
Button form element somewhere on the pasteboard (I like above the
page, it will never show). This triggers the form to be built based on
the Form Setup dialog preferences.

Walter

On Jul 22, 2010, at 6:04 PM, jan smoot wrote:

Welcome myreadycenter.com - BlueHost.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Arg. Yes it is. Thanks for the heads up. I will try your fix.

Jan


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Walter. Fix worked fine.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

One more question. Is there a way to include the name and email from the form in the body/text of the email? Now it’s in the email from field, but would also like it in the email itself. And anyway to delete the submit.x: 60 submit.y: 20 lines from the email?

Thanks for the extra tips. Jan


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Can’t say without seeing the innards of that CGI. It should be
possible, but Perl is not one of my strong suits.

Walter

On Jul 22, 2010, at 6:41 PM, jan smoot wrote:

One more question. Is there a way to include the name and email from
the form in the body/text of the email? Now it’s in the email from
field, but would also like it in the email itself. And anyway to
delete the submit.x: 60 submit.y: 20 lines from the email?

Thanks for the extra tips. Jan


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options