[Pro] FW5 FTP Upload Trouble

Didn’t have this trouble with FW4 Pro.

Recently updated to FW5 Pro. Made a few changes to our site. When I try to upload it I get a message saying,

“Cannot complete upload because end of file. [450 Transfer aborted. Link to file server lost]”

This happens time and time again, and not in the same point of the upload, so it’s not just one particular file it’s stalling out on. Sometimes it would get a quarter of the way through, sometimes half, sometimes three quarters, but I could never get it to stay connected for the entire upload. I tried FTP Passive on and off.

I ended up uploading the site with Transmit, which had no trouble, so it makes me think it’s not a problem with the server but a problem with FW5 and the way it’s communicating with the server.

I would not like to lose the quickness and convenience of FTP uploads from FW.

Any ideas?

Thank you.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I guess it was a temporary problem with the server because today it is working fine. Yay!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Don’t know if this is the same problem but I’ve just had a similar experience updating pages to an existing site - eventually succeeded using Transmit. Tried over a couple of days at different times but got ‘Server Not Responding’ errors with latest version of Freeway Pro. Couldn’t connect at all with Cyberduck. How can you tell if it’s a server problem or some other glitch? I don’t recall having the same problems before the upgrade but willing to concede that is just a coincidence. I’ve only built a few sites in Freeway so I’d be keen to hear of other user’s experience.

Neil


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

If you ever have this issue, there’s a great diagnostic tool built in
to Freeway that can help you (or Softpress) figure out the issue. In
the Upload dialog, there is a checkbox labeled Save FTP log. Check
that and try to upload. A complete transcript of the upload
transaction will be saved (not sure exactly where, Spotlight should be
able to find it). This will have all the gory details including a
cryptic but exact error message from the offending server.

Walter

On May 6, 2009, at 6:41 AM, NeilH wrote:

Don’t know if this is the same problem but I’ve just had a similar
experience updating pages to an existing site - eventually succeeded
using Transmit. Tried over a couple of days at different times but
got ‘Server Not Responding’ errors with latest version of Freeway
Pro. Couldn’t connect at all with Cyberduck. How can you tell if
it’s a server problem or some other glitch? I don’t recall having
the same problems before the upgrade but willing to concede that is
just a coincidence. I’ve only built a few sites in Freeway so I’d be
keen to hear of other user’s experience.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi, Walter,

I did try that when I was having trouble, but unless it’s the _siteinfo file which stores that information, then I have no idea where the file is. Aside from the _siteinfo file, I don’t see any new file being created.

Thank you.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I finally found the file. It’s in your home directory, like this:

~/Library/Logs/Freeway 5/FTP Logs/ftp.log

It’s a plain text file, your Mac will open it in Console.app if you
double-click it. It will tell you every line of the way what happened
during your transaction with the FTP server.

Walter

On May 6, 2009, at 11:39 AM, wurliuchi wrote:

Hi, Walter,

I did try that when I was having trouble, but unless it’s the
_siteinfo file which stores that information, then I have no idea
where the file is. Aside from the _siteinfo file, I don’t see any
new file being created.

Thank you.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks, Walter! Great detective work! Man, I looked all over the darn place.

This is what I see at the end of the uploads that had trouble:

*** Upload interrupted [-26101] ***

or this one:

*** Upload interrupted [-39] ***

Of course, I have no idea what those bracketed numbers mean. If I have trouble in the future I’ll send the ftp log to Softpress.

Thanks!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I’m feeling a bit thick…but could someone help me find the FTP logs that are referenced in this thread.
I’ve looked in Library/Logs folder, but I cannot find a Freeway File in there.
I’m having some server problems and the host would like to see the ftp logs.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The tilde (~) stands for the user’s Home folder. So you want to look in ~/Library/Logs/Freeway 5/FTP Logs.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thank you, I was looking in the Library folder on the main disk.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options