[Pro] Google Chrome

This is more generic or Mac-centered than Freeway specific, but can anyone tell me why on my Mac Google Chrome always displays a site I created using Times Roman rather than the san-serif set I used (Verdana, Arial, etc.) The site is http://www.beanrunnercafe.com/.

I’ve even viewed it with Chrome using a Virtual Box Windows 7 server and it works fine (sans-serif fonts display), but no matter what settings I change in Chrome on my Mac can’t get the page to display the sans-serif font. Using latest version of Snow Leopard and Suitcase Fusion 3 to manage my fonts (all on mac pro)

Jeff


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 16 May 2011, at 13:43, Jeffrey Stern wrote:

This is more generic or Mac-centered than Freeway specific, but can anyone tell me why on my Mac Google Chrome always displays a site I created using Times Roman rather than the san-serif set I used (Verdana, Arial, etc.) The site is http://www.beanrunnercafe.com/.

It looks fine here: http://cl.ly/6myH. You sure you haven’t changed your default font in the preferences or have some sort of Extension running that might be causing it?

Joe


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Joe

I assume you mean preferences in Chrome? I have tried changing Chrome’s font preferences, but just to san-serif fonts. So changed Standard Font to Verdana (from Time roman) to see if it would make a difference, but doesn’t. Only extension I have running is 1Password.

If you’re talking about FW, in document setup I have Lucida Grand for standard and fixed width (defaults??)

When Chrome first came out I had all sorts of problems getting it to render fonts correctly (mostly symbols) unless it was the first browser I launched. I chalked it up to early release issues and to Suitcase.

It’s worked fine for most sites, but the three sites I created in Freeway all show in Chrome with serif fonts on my system when viewed in Chrome (when launched from domain url), and only on my system. So I was trying to figure out why this might be happening (something unique to my Freeway sites)?

Jeff


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

What version of Chrome are you using? I’m on 11.0.696.68 here. It doesn’t sound like a Freeway problem if it works fine everywhere but your machine.

What happens when you preview the site in Chrome from Freeway (you may need to add Chrome in the Browser Setup dialog in Freeway)? Also, can you make sample site, draw an HTML item, add some text and apply any font other than Times to it. What happens when you preview that in Chrome?

Joe

On 16 May 2011, at 14:33, Jeffrey Stern wrote:

Hi Joe

I assume you mean preferences in Chrome? I have tried changing Chrome’s font preferences, but just to san-serif fonts. So changed Standard Font to Verdana (from Time roman) to see if it would make a difference, but doesn’t. Only extension I have running is 1Password.

If you’re talking about FW, in document setup I have Lucida Grand for standard and fixed width (defaults??)

When Chrome first came out I had all sorts of problems getting it to render fonts correctly (mostly symbols) unless it was the first browser I launched. I chalked it up to early release issues and to Suitcase.

It’s worked fine for most sites, but the three sites I created in Freeway all show in Chrome with serif fonts on my system when viewed in Chrome (when launched from domain url), and only on my system. So I was trying to figure out why this might be happening (something unique to my Freeway sites)?

Jeff


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Looks as it should over here, with Verdana and what not.

One tip though in that you don’t have to set a font-family for any style on your page when you have it originally set in your “body” tag already. The “body” tag is one of those styles that will blanket the rest of the styles in regards to default font-family choice. You end up just producing redundant code there.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

If I preview site from within Freeway with Chrome I also get the serif font. And if I set up a blank page and draw html, font defaults to a serif, I change to Helvetica, it previews in Chrome as serif (fine in Safari and Firefox)

I realize it’s probably something on my system, but can’t seem to figure what’s causing it.

Jeff


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Try making a new user in your System Preferences, log in as that user, and try the site there from Chrome. Maybe you have a font issue or font manager issue, and a new user will likely sort that for you (since these are user-specific preferences). Once you prove to yourself that that’s the problem, you can go through your font preferences and see if you have some fonts disabled or in conflict with one another. But do this step first, as it maybe something much more global, and this will root that out.

Walter

On May 16, 2011, at 9:56 AM, Jeffrey Stern wrote:

If I preview site from within Freeway with Chrome I also get the serif font. And if I set up a blank page and draw html, font defaults to a serif, I change to Helvetica, it previews in Chrome as serif (fine in Safari and Firefox)

I realize it’s probably something on my system, but can’t seem to figure what’s causing it.

Jeff


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Not sure if it means anything, but if I go to Edit>Fonts in Freeway with no FW doc open, I get a font warning about "Internal Fonts. The following fonts are for internal use only:
[then a list of fonts such as:
Font: “LastResort” Style: “Regular” File: “MacPro
HD:System:Library:Fonts:LastResort.ttf.”

Also lists Keyboard, Times LT MM, AquaKana and Helvetica LT MM

And if I open a blank doc,and go to Edit>Fonts the only font I see in the list is Times

Jeff


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sounds like Walter’s on the right track then. Try disabling Suitcase Fusion and restarting both Freeway and Chrome. Its possible that it’s preventing some applications from accessing the fonts.

Joe

On 16 May 2011, at 15:04, Jeffrey Stern wrote:

Not sure if it means anything, but if I go to Edit>Fonts in Freeway with no FW doc open, I get a font warning about "Internal Fonts. The following fonts are for internal use only:
[then a list of fonts such as:
Font: “LastResort” Style: “Regular” File: “MacPro
HD:System:Library:Fonts:LastResort.ttf.”

Also lists Keyboard, Times LT MM, AquaKana and Helvetica LT MM

And if I open a blank doc,and go to Edit>Fonts the only font I see in the list is Times

Jeff


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Walt – set up a new account and opened the beanrunner web page in Chrome and it previews fine. So I guess that means my font management software may be causing a font conflict with Chrome?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

That seems highly likely. You may want to move your basic “web” fonts into the System fonts folder, and leave them there, always loading outside of Suitcase.

Walter

On May 16, 2011, at 10:10 AM, Jeffrey Stern wrote:

Walt – set up a new account and opened the beanrunner web page in Chrome and it previews fine. So I guess that means my font management software may be causing a font conflict with Chrome?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks everyone. I’ll have to futz around and see what I find. As long as I know it’s not a FW issue.

Jeff


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

If you’ve fiddled with your fonts in Suitcase, note that you have to restart Freeway to reload its fonts. Also (and for the same reason) it does not auto-load or even request fonts on an as-needed basis.

It sounds more and more as though your System fonts are being managed in Suitcase. I don’t recommend this.

Walter

On May 16, 2011, at 10:04 AM, Jeffrey Stern wrote:

Not sure if it means anything, but if I go to Edit>Fonts in Freeway with no FW doc open, I get a font warning about "Internal Fonts. The following fonts are for internal use only:
[then a list of fonts such as:
Font: “LastResort” Style: “Regular” File: “MacPro
HD:System:Library:Fonts:LastResort.ttf.”

Also lists Keyboard, Times LT MM, AquaKana and Helvetica LT MM

And if I open a blank doc,and go to Edit>Fonts the only font I see in the list is Times

Jeff


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 16 May 2011, at 14:33, Jeffrey Stern wrote:

I have tried changing Chrome’s font preferences, but just to san-serif fonts. So changed Standard Font to Verdana (from Time roman) to see if it would make a difference, but doesn’t. Only extension I have running is 1Password.

It looks fine here Jeffrey (sans-serif) using a virgin unaltered copy of Chrome (I never use it so its defaults are at default) and I’m also using 1Password.

best wishes,

Paul Bradforth

Buy my eBooks at:
http://www.paulbradforth.com/books/


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Like you Chrome gave me grief from Day One displaying mainly just a reams of unintelligible symbols.

I fiddled and I faffed and I gave up for a long time.

When I tried a more recent version things seemed OK

But now that I look at beanrunner I see exactly what you do - Times!

I dont use Fusion but I do use FontAgent Pro on occasion but not really as ongoing font management.

Maybe I should relook at the issue?

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Fusion’s latest version does manage system fonts, although I only have the required ones in the system fonts folder. I’ve been using Suitcase Fusion for a number of years now. I usually manually pull out all the non-required (by Apple) fonts from the System font folders, and have done so over various iterations of the Apple OS and never had any problems with my print related programs (ID, Quark, etc.) Also don’t have any problem with Firefox or Safari – just Chrome.

I don’t use Chrome much, but it is an unusual quirk that the sites I have created in Freeway, all display with Times Roman even though none of them use Times Roman.

Jeff


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options