[Pro] IE 7 Active-X warning

As a total novice to Freeway (and web development for that matter!), I need some advice from you helpful souls. Testing my site with IE7, I get the warning bar drop down quoting ‘To help protect your security, Internet Explorer has restricted the web page from running scripts or Active-X controls that could harm your computer’.

This only happens on one computer and not the other.How do I stop this happening? Please help/advise. Cheers.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Philip,
Is this when you are previewing your pages locally or after you’ve uploaded
them? I ask because IE uses security zones to determine what level of threat
the content may be to your PC. If you view your HTML pages locally (the URL
will start with a file:// reference rather than an http:// one) then IE knows
that this should be the most secure zone and clamps down on pretty much
anything that may prove to be a threat. The browser will ask you for
confirmation before any script attempts to run.
To get around this you need to tell IE that it should consider this page to
belong to another (lower) security zone. You can do this by adding a simple
comment at the top of each page called a ‘Mark of the Web’. In it’s basic form
it looks like this;

I’ve created both HTML templates and HTML content for CD-ROM distribution in the
past and have used these to prevent IE from panicking the user about scripts
running on the page.
You can read more about Mark of the Web at;
http://msdn.microsoft.com/en-us/library/ms537628(VS.85).aspx

I suspect you are seeing a difference between the two machines because their
security zones are different.
regards,
Tim.

Quoting Philip Etherden email@hidden:

As a total novice to Freeway (and web development for that matter!), I need
some advice from you helpful souls. Testing my site with IE7, I get the
warning bar drop down quoting ‘To help protect your security, Internet
Explorer has restricted the web page from running scripts or Active-X
controls that could harm your computer’.

This only happens on one computer and not the other.How do I stop this
happening? Please help/advise. Cheers.


Extend Freeway the way you want with FreewayActions.com
http://www.freewayactions.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options