[Pro] IE Text Problem

Hi all,

Just completed a site and have only just seen a strange issue when previewing on a Windows machine locally. (IE7/8) Working fine on chrome, safari & firefox

Basically, in the top-right of the site, there is a contact number & date. However, both pieces of text look as though they are cropped at both the top and bottom edges.

Here is a screenshot of the problem:

<img src=“http://www.sct-photography.co.uk/phoenix/ie/phoenixIE.png

I’ve tried arranging the layers in different orders but to avail.

Any ideas what may be causing the issue?

Thanks,

Seb


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

A link to the issue, kindly reminded by, The Big Erns.

http://www.sct-photography.co.uk/phoenix

:slight_smile:


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thank you Seb, for the link :slight_smile:

At first glance, I am thinking that date/time thing is the problem. It is
being called into the page through an iframe. Which is puzzling, as the
container for the phone number is above it, not behind it. It have
something to do with how IE7/8 handles iframes and overlapping objects.

I wonder if setting the container divs to flexible height would have any
effect? The overflow is set to visible, so I’m not sure that would help.

Why have you put things that are visually together in separate containers
like that? Why not put them in one container and use styles for each line?


Ernie Simpson

On Mon, Jun 25, 2012 at 10:38 AM, Sebastian Crewe-Turrell <
email@hidden> wrote:

A link to the issue, kindly reminded by, The Big Erns.

http://www.sct-photography.co.uk/phoenix

:slight_smile:


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

this may be related…
http://alamoxie.com/blog/web-design/stop-iframes-covering-site-elements/


Ernie Simpson


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Ernie,

Thanks for your time.

I also thought it had something to do with the date but when I removed it completely, it was still cutting the text?

I have changed the text and number to be inside a single container now with no effect. The reason I avoided this was because, it looks fine in every browser except IE. The leading between the text and number looks very different to what it looks like in Freeway. In IE the text starts to overlap etc.

I thought this may have been an easy fix but I’m not thinking that now! :slight_smile:

Seb


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Found it!

The problem is with your CSS styles for your text. You are using the
leading ( line-height ) attribute incorrectly. Delete the Leading from both
styles. for the top style – style80 – set the Space After ( margin-bottom )
to 0px. For the text below – style81 – set the Space Before and Space After
to 0px. That will fix it.

http://cssway.thebigerns.com/workbench/sebastion/sebastion.png


Ernie Simpson

On Mon, Jun 25, 2012 at 12:04 PM, Sebastian Crewe-Turrell <
email@hidden> wrote:

Hi Ernie,

Thanks for your time.

I also thought it had something to do with the date but when I removed it
completely, it was still cutting the text?

I have changed the text and number to be inside a single container now
with no effect. The reason I avoided this was because, it looks fine in
every browser except IE. The leading between the text and number looks very
different to what it looks like in Freeway. In IE the text starts to
overlap etc.

I thought this may have been an easy fix but I’m not thinking that now! :slight_smile:

Seb


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Ernie,

Thanks very much!

I am not able to make the changes right now as it’s on my computer at work but I really do appreciate that. It’s strange that it doesn’t show up in anything other than IE.

Learnt something though.

Thanks,

Seb


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Just made the changes and it did the trick!

Thanks again Ernie,

Seb


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options