[Pro] My Site is Excruciatingly S-L-O-W to load

Can some kind soul take a look at my site and coach me on what to change to increase the page load speeds. The main landing page (index page) has a load speed of over 10 seconds. The other pages have load speeds of over 5 seconds.

I built the site with FW7 using two main masters (landing and topic). I don’t think I used anything complicated or fancy because I’m very new to this, but my ignorance is very likely the cause of the problem. I used actions for rollovers and target show / hide layers and moved items around to make the site responsive. All of the images are optimized for the web, are are typically under 20Kb in size, so file size shouldn’t be an issue.

I’m in way over my head now, and don’t know next steps on how to fix my site. (BTW, I’m working on blog pages in a separate file and the site loading speed for that is over 20 seconds, so I though I should get a handle on this before putting in a truck-load more work!)

Thank you in advance for your assistance.

Kind regards,

Sue
Owner, Arkadaslik Yachting


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Visit GTMetrix http://gtmetrix.com and enter a page to test. It will give you an idea of what areas need work along with load times.

Todd

On Oct 31, 2014, at 12:32 PM, Sue Fockner email@hidden wrote:

Can some kind soul take a look at my site and coach me on what to change to increase the page load speeds. The main landing page (index page) has a load speed of over 10 seconds. The other pages have load speeds of over 5 seconds.

I built the site with FW7 using two main masters (landing and topic). I don’t think I used anything complicated or fancy because I’m very new to this, but my ignorance is very likely the cause of the problem. I used actions for rollovers and target show / hide layers and moved items around to make the site responsive. All of the images are optimized for the web, are are typically under 20Kb in size, so file size shouldn’t be an issue.

I’m in way over my head now, and don’t know next steps on how to fix my site. (BTW, I’m working on blog pages in a separate file and the site loading speed for that is over 20 seconds, so I though I should get a handle on this before putting in a truck-load more work!)

Thank you in advance for your assistance.

Kind regards,

Sue
Owner, Arkadaslik Yachting

http://www.arkadaslik-yachting.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Todd! I took a quick look and can easily incorporate (most of) the suggested changes.

Novice question here. Any idea why different analytic sites come up with such variation in page load speeds? For example, GT Metrix indicates my home page loads in 0.85 seconds, whereas other sites have shown times over 10 seconds. Why the difference?

Have a great weekend!

Sue

Visit GTMetrix and enter a page to test. It will give you an idea of what areas need work along with load times.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 31 Oct 2014, at 18:42, Sue Fockner wrote:

Any idea why different analytic sites come up with such variation in
page load speeds?

It could be down to different assumptions in visitor connection speed.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I’ve wondered about that myself. I suppose some of it might simply be because your server (or ISP) is experiencing a heavy load at that particular moment. Or perhaps these services interpret data differently. Kind of like how the Google and Bing can rank pages differently because they use different algorithms. All best guesses on my part.

Todd

Novice question here. Any idea why different analytic sites come up with such variation in page load speeds? For example, GT Metrix indicates my home page loads in 0.85 seconds, whereas other sites have shown times over 10 seconds. Why the difference?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Just opened up your site, loaded in a split second (cable 65MB/s).

Richard


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 31 Oct 2014, 7:00 pm, Richard van Heukelum wrote:

Just opened up your site, loaded in a split second (cable 65MB/s).

Richard

Yes, Sue. Same here. I just opened your website, and it loaded almost instantly.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Check out “backdraft” it makes the sites in Freeway 6, responsive


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options