[Pro] php form - doesn't work

Hi,
I’ve created a php-form by following the tutorial. It looks good, but it doesn’t work. Only the error page opens up and the form doesn’t get sent to the assigned email-address.
Where do I start looking for the problem?
Thanks for helping.
/Sonja


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The very first thing to look at is the names of the form fields.
Freeway appears to set these based on the Title field in the left-most
tab of the Inspector (while the field is selected), but that’s not
actually the case. Click on the third tab from the left, and look in
the Name field at the top of the Inspector. If you’re using the PHPFF
Action, the e-mail field must have the Name attribute ‘email’ (without
the quotes) exactly like that – lower-case, one word, no punctuation.

Look through Tim’s very complete instructions (come with the Action,
IIRC) and be sure that each field is named according to the rules. Any
fields that he did not specify for you to use, first try removing them
and see if you can get the basic form to work. After you’ve gotten
through that, next try adding them back one at a time, and be sure to
follow the PHP rules for naming:

  1. The first character of a name must be a roman letter [a-zA-Z] or an
    underscore, no other characters permitted. (No “extended characters”,
    like Ü or é, either.)
  2. No spaces, only underscores to separate logical words, or use
    camelCase for the same purpose.
  3. No punctuation except for the underscore.

The thing to remember is that even though the PHPFF Action makes all
this very easy for you, you still have to follow the rules of
programming, because that’s what’s actually going on here.

Walter

On Jul 11, 2011, at 7:36 AM, soka7705 wrote:

Hi,
I’ve created a php-form by following the tutorial. It looks good,
but it doesn’t work. Only the error page opens up and the form
doesn’t get sent to the assigned email-address.
Where do I start looking for the problem?
Thanks for helping.
/Sonja


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi waltd!
Thanks for that. Still doesn’t work. Do you have a link for Tim’s instructions?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Have a look on http://freewayactions.com for the PHP FF. It’s either
on the page or part of the download, I recall there being a big PDF
with lots of relevant detail.

Walter

On Jul 11, 2011, at 9:27 AM, soka7705 wrote:

Hi waltd!
Thanks for that. Still doesn’t work. Do you have a link for Tim’s
instructions?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Waltd. Ive got a similar problem. I’ve created a site feedback facility on a contact page using the page action PHP. I’ve followed the video tutorial to the letter and named the text fields as ‘name’, ‘email’ (without the quotes) and the text area as ‘message’. All the compulsory fields in the php action window are there and I’ve named the page contact.php but when I load the page the submit button does nothing at all. It’s as dead as a dodo.

I’m a newcomer to Freeway Pro. What is phpff?

Can you help and save my sanity?

Best wishes Batteneye


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Both of you should post a link to your pages so that we can have a look.

What is phpff?

PHP Feedback Form action

I’ve created a site feedback facility on a contact page using the page action PHP

Do you mean the PHP Feedback Form action?

Note that your page with the form on it (if you are using the PHP Feedback Form action) does not need to be suffixed .php - if you do then you lose the ability to preview locally! The php stuff is all in the action generated contact-go.php file so your form page can be an ordinary .html page.

Sonja

The first step you should make to solving your problem is to create separate error pages for each type of error ie Instead of the setting ‘One Page for all errors’ instead use ‘A page for each error’

The easy way to do this is to duplicate your existing error page, rename it suitably ‘notindomainerror.html’ and ‘serverfailureerror.html’ etc

Then on these error pages just put some large text saying which error applies.

Upload the site again with the new error pages (dont forget to select the correct one(s) in the action palette) - and try your form again.

Which error page you get will help determine the cause of your problem.

And if your site is hosted at GoDaddy then move it.

Also ensure that your server/hosting plan is PHP enabled.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks folks. Much appreciated. I was following the video tutorial and the last step was to turn contact.html into contact.php.

I’m now about to take your advice. Wish me luck!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi again. I’ve followed your instructions (Contact.php to contact.html, 3 separate error pages all properly assigned in the action palette and checked that my webhosting plan supports PHP).

When I upload the site and test it, nothing happens. could it be because I am using a test recipient email address not connected with the site?

The URL is http://www.larkara.org.uk


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Here is the link to my page:

http://www.hannington.se/prisforfraga.php

/Sonja


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

and by trying to do what David suggested:

here’s the error page:

http://www.hannington.se/serverfailureerr.html

as you see, it’s server failure
/Sonja


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I’ve also got the same problem. Spent days on it, using two different Actions, without success.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

In case any of the helpers, ask, I’ve also clicked on the ‘activate’ box in the action palette. The submit button is as dead as a dodo.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi John,
I can see that you’ve added your submit button as a layered item which instantly extracts the button from the standard form element that the Action creates. Uncheck the layer checkbox in the Inspector palette and you should find the form will now submit as expected.
Regards,
Tim.

On 12 Jul 2011, at 12:01, John Bates wrote:

In case any of the helpers, ask, I’ve also clicked on the ‘activate’ box in the action palette. The submit button is as dead as a dodo.

FreewayActions.com - Freeware and commercial actions for Freeway Express & Pro.

Protect your mailto links from being harvested by spambots with Anti Spam.
Only available at FreewayActions.com

http://www.freewayactions.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Tim, but no go. I’ve deselected layer on the button inspector palette. It’s made no difference. Any ideas?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi John,
I can see that you’ve some layered items in this form still (‘messagepad’ for example) and some of this content is sitting over the submit button stopping you from clicking on it. Try clicking on the very last couple of pixels on the lower edge of the submit button and you’ll see that the button works.
I’d suggest removing the layer items and wrap the whole of the form content in a user defined table (like this example; FreewayActions.com | PHP feedback form).
Regards,
Tim.

On 12 Jul 2011, at 12:37, John Bates wrote:

Thanks Tim, but no go. I’ve deselected layer on the button inspector palette. It’s made no difference. Any ideas?

FreewayActions.com - Freeware and commercial actions for Freeway Express & Pro.

Protect your mailto links from being harvested by spambots with Anti Spam.
Only available at FreewayActions.com

http://www.freewayactions.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Fixed. My problem (it seems) could either be the provider didn’t activate PHP (which I could through an online control panel). But I also applied the action to the form elements, rather than the page.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Tim. You’ve cracked it! Well done indeed. It’s easy when you know how. So much to learn - so little time. I really appreciate your efforts and those of the other correspondents.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Tim, you don’t see where my problems come from, do you? Still can’t get it to work.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Unfortunately I don’t. I can see that the error you are getting back is related to a response from the server but I can’t see why this would be happening.

Internally the PHP code asks the server to send the email and checks to see what the server responds with. In this instance the server is sending back an error for some reason. The vast majority of errors seen with this Action are due to required fields not being filled in correctly with only a fraction hitting issues like this.

I would suggest opening a support ticket with your web host and ask if there is anything specific that you need to do to enable PHP to send emails from your account. There are a few options in the Action that are there to deal with specific needs (setting the ini file for example) so you may find that one of those options corrects the issue.

Some hosts (GoDaddy comes to mind) will make you jump through hoops before they will let you send emails so be sure to follow their instructions.

If all else fails let me know (FreewayActions.com | Contact) and I’ll see if anything can be done with the Action to suit your server’s specific needs.
Regards,
Tim.

On 12 Jul 2011, at 17:10, soka7705 wrote:

Tim, you don’t see where my problems come from, do you? Still can’t get it to work.

FreewayActions.com - Freeware and commercial actions for Freeway Express & Pro.

Protect your mailto links from being harvested by spambots with Anti Spam.
Only available at FreewayActions.com

http://www.freewayactions.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

My web host answered that I need to authenticate somewhere in the script to be able to send via their SMTP server. Then it should work. Don’t know where/how to do that. Does anybody know?
/Sonja


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options