[Pro] PHP form not sending

I thought this was going to be easy but I must be missing something. I gathered info from my web host, created a form, completed Form Setup and added Send Form Action to the page. I have tried many different variations and either the form wouldn’t send or I would get a code page. Currently I am getting a code page but at least it makes sense. It appears to me that it is not capturing the Name and Sender Email but I am not sure why.

Would someone be willing to take a look at it?

Here’s the info from my host:
Install FormMail ValueApp (Done)

(I added to Form Setup) (I added to Form Setup) (This field is on the form)

Thanks
Karen

www.thefirstbaptistchurch.com/planyourvisit.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Karen,
If you see a page full of PHP code like this in the browser then more often than not the server hasn’t been set up to run the code correctly (or at all). Open a support ticket and ask your hosting provider if your account can run PHP scripts (most can). If they say no then you’ll be looking to either move the site to a server that does (ask here for hosting suggestions as there are plenty of Freeway-friendly hosts to be found) or use a form to mail script that is located on another server or uses another scripting language other than PHP.

Either way come back with the news from the host and we’ll sort things out for you.
Regards,
Tim.

On 19 Sep 2014, at 21:09, Karen A wrote:

Currently I am getting a code page but at least it makes sense.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Tim,
The host is suppose to handle php. They did tell us to install the FormMail Value App in our account, which we did. But I did not personally do it. So there may be an issue on that end. Thanks for that tip and I will surely be back.
Blessings,
Karen


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

(I added to Form Setup) (I added to Form Setup) (This field is on the form)

A bit confused because you mention using your Hosts formmail.php script yet you appear to be using FW’s SendForm action.

But either way it doesn’t look like your server supports PHP

Check with your hosting provider whether they do or not on the particular hosting plan you subscribe to.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Just thought that I should mention how this page looks in Safari

The reason for this is because you do not appear to have defined your font and it will display in the visitors default Font - on my version of Safari it is Verdana. Yours may be different.

I think Thomas has a screencast that will give you some guidance on this and if I can find the link I will post it here.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Oh no David I am confused enough for all of us!
Let me explain…after reading all the Freeway Pro documentation on forms and checking with my provider to be sure they handled php I embarked on creating a form.
However since the web host provider had certain criteria the only place I saw to handle that was the Form Setup…but that alone didn’t work so I have tried the php feed back form action and the send form action. Nothing seems to work.

The web host sent me this link originally http://support.myhostcenter.com/article/view/4011/Sending_Form_Submissions_by_Email_with_FormMail However after Tim’s reply I contacted them through live chat and got this. “I’m sorry we cannot troubleshoot mailscripts. Please try a different script preferably using the PHP send mail feature.” Then they gave me this link http://static.olark.com/jsclient-bucket2/follow.html
So I am still unsure of how to proceed!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I am confused David I have both previewed this page in Safari and am looking at it live with Safari and it displays correctly! What the heck? I am deflating fast!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Then they gave me this link http://static.olark.com/jsclient-bucket2/follow.html

That link doesn’t work for me.

I’m sorry we cannot troubleshoot mailscripts. Please try a different script preferably using the PHP send mail feature.

You dont want them to troubleshoot your script.

You only want them to confirm that your hosting package supports PHP and at what version.

As to the text display. Quite simply if you do not define your Font then it will display in your visitors Browser with whatever their Browsers default is set to.

For you it might be OK but I think that your target audience will have a wide variety of defaults so it is in your best interest to define the text with whatever Font you wish your visitors to see.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sorry I didn’t read all the way down David. All I saw was that glaring image. I had forgotten to change the text. I had created this page early on but since I had to wait on several things pertaining to it I left it and moved on. All the rest of the site is using Verdana. So I have now changed that. I HOPE it is better.
Thanks for the heads up.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I HOPE it is better.

Much better.

Now you just need to get your PHP status verified.

Tech support are very good at telling you what should be happening on your server ie Yes it supports PHP.

But the important question I would be asking is - Have you actually checked that my server/hosting package has PHP enabled?

You can do this check for yourself by uploading a text file to your server and see what is displayed when you visit the page in a Browser

Create a plain text file with the contents

<?php

phpinfo();

?>

Call it wxyz.php and upload it to your server ie at yoursite.com/wxyz.php

Now visit that page with your Browser and you should see a big Purple list of settings - if you dont then php isn’t working there.

Delete the file once you have done the test.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The php version is 5.2.2
They reset my site and now I it doesn’t come up at all so they are opening a support ticket.

In Form Setup I clicked on use master settings and was just going to try using the send form action now that they tell me I didn’t have to use FormMail at all.

But between those two events my website is down.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

they tell me I didn’t have to use FormMail at all.

You do not have to use any 3rd party script like FormMail if you use SendForm or the PHP Feedback form actions.

These actions create their own scripts for you and you ONLY need to set the parameters in the Action window - nowhere else!

So if you use one of those actions then do NOT use Page>Form Setup

And only use one of those actions, do not try to use both on the same page.

Best to apply one of these actions on a page by page basis - dont apply it to a Master.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Well the website is back. DeltaDave I did the .php file you recommended and I did get several pages of php info. It did say PHP Version 4.3.9 They told me the php version was 5.2.2. Could this be the problem?

I have removed everything from my website except for the SendForm Action. It is applied to the page the form is on. I have only tried it attached to the page or the html box the form is in. But this is where I started but when it didn’t work I just kept reading thinking I was missing something and it got crazy.

Now what I get is a blank white page with an icon in the upper left corner. This is the URL that shows http://www.thefirstbaptistchurch.com/FW_SendForm_planyourvisit1.php in the browser. The webpage with the form is www.thefirstbaptistchurch.com/planyourvisit.html
I greatly appreciate everyones comments and assistance.
Blessings,
Karen


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

That sounds all kinds of wrong. v4.3.9 was released Sept. 22, 2004.

Todd

It did say PHP Version 4.3.9 They told me the php version was 5.2.2. Could this be the problem?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I am also questioning that everything is enabled. I am not familiar with what the settings should be but there are some that look like they are not correct. Would you mind looking at it Todd?
You can see it at this URLhttp://www.thefirstbaptistchurch.com/wxyz.php thanks to Dave.
I just tried to check with them and they are offline for the weekend and I am sure it will take a while to get a response through the tech dept.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

For the most part your settings look similar to mine, except of course for the decade old version it shows. Clearly there’s a discrepancy between what you’re seeing and what they are claiming it’s supposed to be. Whether that’s the only reason your form isn’t working I can’t say, but it sure as hell isn’t helping.

If v4.3.9 is indeed running (and it’s not some benign mistake) then there’s a huge security risk in play that needs to be fixed immediately. Who is the host? Honestly, I would seriously consider changing hosts, there’s no excuse for running such outdated software.

Todd
http://xiiro.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

When I asked them what version of php was running in my site he asked for my domain name and then came back and told me v5.2.2. Dave had me create the file to get the php info. Although I am not positive as to what it is doing, it sure looks like it is displaying the info that is specific to my domain. My problem is I inherited this website and was just maintaining the old site until I finally dug in to teach myself how to create a website. We have never had any problems with the website but the site did not have any complex development. And very limited actions. So now it is getting tested we may be seeing some issues. I hate to say who it is until I am absolutely certain this isn’t something different than it appears to be. Thanks for your feedback. It looks like it will be tomorrow before I can get the info to move forward with this provider. I’ll keep you all posted.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The phpinfo file is simply returning all the information related to the server’s PHP installation in a user-friendly manner. If you’re on a shared server then the PHP installation is not specific to your domain strictly speaking, but to every domain that exists on the same server as your domain. If on the other hand you use a private server then it would be specific to only your site.

Clearly something is amiss.

Todd

Although I am not positive as to what it is doing, it sure looks like it is displaying the info that is specific to my domain.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 19 Sep 2014, 9:01 pm, DeltaDave wrote:

Not sure what an escort in this case would charge for one hour?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Richard,
Thanks for your response. I am amazed at how helpful everyone is in this forum. I have corrected the font issue. It was an oversight because I had rough drafted this page. But because I needed to wait on someone else to do something before I could even test this page I went on to finish everything else. Well finish what I call phase 1. Originally I was just trying to get a form under my belt and have it work. Then I could focus more on the looks and creating some other forms. So now that I have defended myself. :slight_smile: I am a newbie at web design and I assume an escort is someone that is willing to instruct or modify your web site. I have to confess I built this website for my church for free because I couldn’t take their old one. It has taken me six weeks of reading through reference manuals and watching tutorials to get it this far. In my vision I always see it grander than my skill level but I plan to get there. Sorry to be so long winded. It’s hard for me to ask for help and not explain what’s going on. If anyone has some pointers that they want to share I am open to learning. I just don’t have funds. The church didn’t ask me to do this. I just knew they needed a new presence on the web. Again I am open to all criticisms and suggestions. The website is www.thefirstbaptistchurch.com
Blessings,
Karen


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options