[Pro] Really, seriously, what is the solution to this problem?

This has to do with accessibility. Specifically the order in which a screen reader will read the items on a page.

Link is below.

Problem: On the home page, the CSS menu opens behind the items below it, but if I move the menu to the front, FW puts it at the bottom of the Items’ list and screen readers like Voiceover (the only one I have checked it with) reads it last. No amount of dragging the menu item around in the Items’ list will fix this.

For almost any other page this would be preferable (Books > Memoirs is a good example) because most screen-reader users don’t want to have to rifle through the same links every time they switch to a new page. The home page is different. It’s a must to have the main menu read as one of the first items.

If you tab through or use Voiceover on the home page or the Memoirs’ page, this is the order in which I want the items to be read. How, please tell me how, can I get the menu on the home page to be in front of the other items below it but read right after the header? There has to be a way.

http://www.northcoastsoundsystem.com/EVtest/index.html

Thank you. I appreciate this list and the help I’ve received here.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sometime around 24/6/09 (at 05:34 -0400) wurliuchi said:

How, please tell me how, can I get the menu on the home page to be
in front of the other items below it but read right after the header?

I mentioned that setting the z-index level for the div might sort
this out for you, letting you put the menu behind other items in your
Freeway layout (so the code is output last) but using the z-index to
tell the browser how to stack things up in the rendered page.

I’m not 100% certain this would do the trick, but it is very simple
to find out:

  1. In Freeway, send the CSS Menu item to the back, then publish.

  2. In the Finder, open your Site folder (note: this is generally not
    recommended practise, just do this for one-off tests) and open the
    right HTML page in a text editor.

  3. Search for the div that contains this text: id=“TopMenuWrapper”;
    it should be right down towards the bottom of the code. Find the
    z-index element within that line.

  4. Change the z-index value from whatever it might be now to 1. This
    will be the same as the first item on the page, but I don’t think
    that’ll be a problem.

  5. Save, then view the page in a browser. Does the menu still sit on
    top of things? If so…

  6. Head on over to the Actions forum and ask if there is an action
    anywhere that can assign a custom z-index value to a div.

k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Very cool Keith. A step-by-step. I love ya. I will give it a try and let you know. Thank you!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Is this relevant i regard to drop-down menus that notoriously hides
behind any swf-files, as they occupy the topmost layer whatever you do.

Elfinn

On 24. juni. 2009, at 11.59, Keith Martin wrote:

Sometime around 24/6/09 (at 05:34 -0400) wurliuchi said:

How, please tell me how, can I get the menu on the home page to be
in front of the other items below it but read right after the header?

I mentioned that setting the z-index level for the div might sort
this out for you, letting you put the menu behind other items in
your Freeway layout (so the code is output last) but using the z-
index to tell the browser how to stack things up in the rendered page.

I’m not 100% certain this would do the trick, but it is very simple
to find out:

  1. In Freeway, send the CSS Menu item to the back, then publish.

  2. In the Finder, open your Site folder (note: this is generally not
    recommended practise, just do this for one-off tests) and open the
    right HTML page in a text editor.

  3. Search for the div that contains this text: id=“TopMenuWrapper”;
    it should be right down towards the bottom of the code. Find the z-
    index element within that line.

  4. Change the z-index value from whatever it might be now to 1. This
    will be the same as the first item on the page, but I don’t think
    that’ll be a problem.

  5. Save, then view the page in a browser. Does the menu still sit on
    top of things? If so…

  6. Head on over to the Actions forum and ask if there is an action
    anywhere that can assign a custom z-index value to a div.

k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Keith,

It didn’t work. I moved the menu forward, published, saved and closed. I opened up the index file in the text editor and changed the menu’s z-index to 1, saved and closed. Opened it up in FW and VO still reads it last. Then I repeated the process changing the z-index to 2. No luck. Then I tried 3. Nope. Then I left it as 3 (its wrapper was 2) and moved all the other z-indexes down by one so there wouldn’t be any duplicate numbers. That didn’t work either.

Hey, thanks for trying. I very much appreciate that. If you think of anything else, please let me know.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

my head is not really in this right now, but if you want to alter the
z-index post publishing, there might be a way to make Freeway do that.

If whatever being sent to the back is a box that will render as a div
structure, you might try putting the intended z-index in the extended
box attributes and see if you can override Freeway’s inline styles.
Both Walter and Weaver have made actions that make it easier to remove
inline styles from a div box, setting the stage to control z-index via
a custom style. In either case, Freeway would behave as if it were in
back, but render it in front.

Hope that sparks some ideas :slight_smile:

On Wed, Jun 24, 2009 at 1:59 PM, Keith Martinemail@hidden wrote:

Sometime around 24/6/09 (at 05:34 -0400) wurliuchi said:

How, please tell me how, can I get the menu on the home page to be in
front of the other items below it but read right after the header?

I mentioned that setting the z-index level for the div might sort this out
for you, letting you put the menu behind other items in your Freeway layout
(so the code is output last) but using the z-index to tell the browser how
to stack things up in the rendered page.

I’m not 100% certain this would do the trick, but it is very simple to find
out:

  1. In Freeway, send the CSS Menu item to the back, then publish.

  2. In the Finder, open your Site folder (note: this is generally not
    recommended practise, just do this for one-off tests) and open the right
    HTML page in a text editor.

  3. Search for the div that contains this text: id=“TopMenuWrapper”; it
    should be right down towards the bottom of the code. Find the z-index
    element within that line.

  4. Change the z-index value from whatever it might be now to 1. This will be
    the same as the first item on the page, but I don’t think that’ll be a
    problem.

  5. Save, then view the page in a browser. Does the menu still sit on top of
    things? If so…

  6. Head on over to the Actions forum and ask if there is an action anywhere
    that can assign a custom z-index value to a div.


Ernie Simpson


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

It’s funny, Keith. We talked about the stacking order of items in the other thread, and I can understand why it’s like that (kinda), but here’s a perplexing way of putting it, but it’s correct: What’s on the bottom is read last but it’s in front. Or the other way: What’s on the top is read first but it’s in back.

Stupid internet.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I had a similar problem with our main web site…

I wanted the CSS menu to appear in the code at the top of the page,
not layered (i.e to the front) in freeway which then publishes the CSS
menu code last in the page.

The solution I found was to make a full box model site which kept the
CSS menu in the correct order at the top of the pages, as all the
items are now inline.

David

On 24 Jun 2009, at 10:34, wurliuchi wrote:

Problem: On the home page, the CSS menu opens behind the items below
it, but if I move the menu to the front, FW puts it at the bottom of
the Items’ list and screen readers like Voiceover (the only one I
have checked it with) reads it last. No amount of dragging the menu
item around in the Items’ list will fix this.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

You can change the z-index of the layer that holds your menu to put it at any level you like. Try this:

  1. Draw or select your menu layer.
  2. Move it in the Site pane (click your site pane into page view for this) until it is the top-most thing on the list of elements in your page (first in the source order).
  3. With the menu layer selected, choose Item / Extended from the main menu.
  4. Click on the DIV Style button in the dialog, then New.
  5. In the sub-dialog, enter Name: z-index and Value: 1000 (or some other large number to your liking).

Walter


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hey, yeah, that will work. I just did a quick test. I cut everything on the page and drew an html box the width of the page, clicked inside of it and pasted. Sure enough the menu is on top and reads right after the header. Okay, it looks like crap right now, but I don’t have a problem doing the entire page inline.

Thank you! That seems like the easiest (and maybe only) solution. I appreciate the help.

Which margin are you not supposed to use when doing these inline box models? Vertical or horizontal? Isn’t there some browser (I’m guessing IE 6 or 7) that won’t recognize one of them in a box model and you should use spacers instead?

Thanks!

On 24 Jun 2009, 11:31 am, David Owen wrote:

I had a similar problem with our main web site…

http://www.PrintlineAdvertising.co.uk

I wanted the CSS menu to appear in the code at the top of the page,
not layered (i.e to the front) in freeway which then publishes the CSS
menu code last in the page.

The solution I found was to make a full box model site which kept the
CSS menu in the correct order at the top of the pages, as all the
items are now inline.

David

On 24 Jun 2009, at 10:34, wurliuchi wrote:

Problem: On the home page, the CSS menu opens behind the items below
it, but if I move the menu to the front, FW puts it at the bottom of
the Items’ list and screen readers like Voiceover (the only one I
have checked it with) reads it last. No amount of dragging the menu
item around in the Items’ list will fix this.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Which margin are you not supposed to use when doing these inline box models? Vertical or horizontal? Isn’t there some browser (I’m guessing IE 6 or 7) that won’t recognize one of them in a box model and you should use spacers instead?

Horizontal margin gets the IE 6 (maybe 7) margin-doubling bug. Use padding on the container instead, or spacers if you must.

Walter


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Take a look at the other thread that has the same title as this one, I just posted a solution there that might be even easier than this.

Walter


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Elfinn, it’s always a good idea to take a look through existing
posts and start your own if you can’t find, otherwise your question
might get missed. It turns out that the latest thread after you posted
answered your question, I’ve just written a KnowledgeBase article for
it though, take a look here:

http://www.softpress.com/kb/questions/187/Forcing+Flash+to+appear+behind+other+content

I hope this helps.

Joe

On 24 Jun 2009, at 11:20, Elfinn Færevåg wrote:

Is this relevant i regard to drop-down menus that notoriously hides
behind any swf-files, as they occupy the topmost layer whatever you
do.

Elfinn

On 24. juni. 2009, at 11.59, Keith Martin wrote:

Sometime around 24/6/09 (at 05:34 -0400) wurliuchi said:

How, please tell me how, can I get the menu on the home page to be
in front of the other items below it but read right after the
header?

I mentioned that setting the z-index level for the div might sort
this out for you, letting you put the menu behind other items in
your Freeway layout (so the code is output last) but using the z-
index to tell the browser how to stack things up in the rendered
page.

I’m not 100% certain this would do the trick, but it is very simple
to find out:

  1. In Freeway, send the CSS Menu item to the back, then publish.

  2. In the Finder, open your Site folder (note: this is generally
    not recommended practise, just do this for one-off tests) and open
    the right HTML page in a text editor.

  3. Search for the div that contains this text: id=“TopMenuWrapper”;
    it should be right down towards the bottom of the code. Find the z-
    index element within that line.

  4. Change the z-index value from whatever it might be now to 1.
    This will be the same as the first item on the page, but I don’t
    think that’ll be a problem.

  5. Save, then view the page in a browser. Does the menu still sit
    on top of things? If so…

  6. Head on over to the Actions forum and ask if there is an action
    anywhere that can assign a custom z-index value to a div.

k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Walter,

Bingo!!! You nailed it! That worked like a charm. I had to re-index the menu’s wrapper that I use for a little extra color on the outside. I changed that to z-index 999, and I changed the menu div to z-index 1000. That did it!

Way to go, thank you. Of course I had to do it twice before it worked.

Keith, we were on the right track, we just went the wrong way, or I screwed up when I edited the index file in the text editor.

Thanks for the help, everyone.

On 24 Jun 2009, 11:41 am, waltd wrote:

You can change the z-index of the layer that holds your menu to put it at any level you like. Try this:

  1. Draw or select your menu layer.
  2. Move it in the Site pane (click your site pane into page view for this) until it is the top-most thing on the list of elements in your page (first in the source order).
  3. With the menu layer selected, choose Item / Extended from the main menu.
  4. Click on the DIV Style button in the dialog, then New.
  5. In the sub-dialog, enter Name: z-index and Value: 1000 (or some other large number to your liking).

Walter


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Yep, you were on it. Walter jumped in and helped me out. I needed to change the z-index of the menu div in the Item > Extended

window.

Thanks!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thank you!

Elfinn

On 24. juni. 2009, at 14.10, Joe Billings wrote:

Hi Elfinn, it’s always a good idea to take a look through existing
posts and start your own if you can’t find, otherwise your question
might get missed. It turns out that the latest thread after you
posted answered your question, I’ve just written a KnowledgeBase
article for it though, take a look here:

http://www.softpress.com/kb/questions/187/Forcing+Flash+to+appear+behind+other+content

I hope this helps.

Joe


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sometime around 24/6/09 (at 08:44 -0400) wurliuchi said:

Yep, you were on it. Walter jumped in and helped
me out. I needed to change the z-index of the
menu div in the Item > Extended


window.

Very cool. I’m glad to hear it ended in a reasonably workable solution. :slight_smile:

And now… off to Glastonbury to take freaky 360°
photos. I’ll be back on Monday to probably 600+
emails across various lists, so I apologise in
advance for any that I skip.

k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options