[Pro] Scripty Fader & Scroll layer problem

Before I spend any more time on this can someone tell me if these are incompatible for some reason?

In the scriptyFader Option panels I am trying to include a HTML box with Scroll Layer action applied… Ive tried all sorts of layering and parent/child combinations with no luck.

The script Fader works but the box that should contain the scroll content is blank.

Thanks
Dave


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

This sounds to me as though the ScriptyFader is doing its work before
Scroll Layer has done its. In that case, the element that Scroll Layer
is modifying is actually gone from the page by the time that SL runs.
Kudos to whomever coded that Action that it doesn’t blow up or error
out at that point, but doesn’t help you much! I’ll take a look at SF
and see if I can have it work later in the publish cycle. That could
free up SL (and other Actions) to do its thing before the elements
you’re fading are moved off page into lazy-loading “partials”.

Walter

On Mar 2, 2011, at 11:09 AM, Tychain wrote:

Before I spend any more time on this can someone tell me if these
are incompatible for some reason?

In the scriptyFader Option panels I am trying to include a HTML box
with Scroll Layer action applied… Ive tried all sorts of layering
and parent/child combinations with no luck.

The script Fader works but the box that should contain the scroll
content is blank.

Thanks
Dave


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Walter… Id really like to use these features together.

As always, your contributions here are greatly appreciated!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I just pushed a new version to the Forge:

http://www.actionsforge.com/actions/view/218-scriptyfader

Give this a try, and see if they play better together. I’ve pushed SF as far as I can – all the way to the last stop on the publishing line: fwAfterEndHTML. If that doesn’t do it, then you’re going to have to get the author of Scroll Layer to rewrite that Action to fire sooner in the publish cycle.

Walter


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Walter… I’ll give it a try!

Quick question: When I upgrade to the new version do I just drop it on the Freeway Logo as always? Does that get rid of the old version? Does that effect other pages I have with older versions of Scripty Fader?

Ooops… thats 3 questions smile Thanks again!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Yes, double-click the Action (after you unzip it), or drag it over the Dock icon for Freeway. With bundle Actions like this, it’s usually a good idea to remove the Actions from your page and re-apply them. I’ve had way too many reports of people upgrading and nothing happening. Remove the actions, publish once, then re-apply. If you have the same action on more than one page, be sure you remove it from all pages before you publish.

But by all means just try without that whole dance. It might work fine for you.

Walter


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sorry to report, but it still wont even recognize the scroll content. Thanks for the effort Walter! At least I got the new version so I could turn the spinner off if I want to !

Think I’ll try Show/hide layer and see if I can get that to work


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Show /hide fails as well… hmmmm

I know I did it right because the scroll works fine just sitting on the page.

any ideas? There must be a way, short of just creating 5 separate pages.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Could you post a failing example on line, and paste the link here?
There may be a JavaScript conflict, particularly if the author of
scroll layer used one of the shortcut methods to iterate over an
array. Prototype exacts a price for its incredible handiness – it
forces you to write excruciatingly-correct JavaScript. Not a bad
thing, IMHO. I can tell more by watching it fail in Firebug.

Walter

On Mar 3, 2011, at 9:22 AM, Tychain wrote:

Show /hide fails as well… hmmmm

I know I did it right because the scroll works fine just sitting on
the page.

any ideas? There must be a way, short of just creating 5 separate
pages.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Walt,
Sorry but I already gave up and went the individual page route. Old version is gone. Once this site is done I’ll go back and recreate a sample for you. I am interested in knowing why it didnt work.

btw, when I upgraded to the new version of ScriptyFader all the old scriptyFader actions caused java errors! (panic) then I clicked the clear java errors button in the actions palette and everything worked just fine!

I continue to be so impressed with Freeway and with this incredible support forum. I couldnt have done this without you and the others.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Could you please try the following:

Create a new blank document with two image boxes on a page (images in
them, too, just so you can see something). Click on the first box and
apply ScriptyFader to it. Click on the second and choose ScriptyFader
Option. Make sure that your first box is selected in the Option’s
picker.

Now look in the bottom-right corner of the Actions palette when each
of these boxes is selected – do you see 0.3.1 in there?

Publish – do you get the error again?

Thanks very much.

Walter

On Mar 3, 2011, at 11:44 AM, Tychain wrote:

btw, when I upgraded to the new version of ScriptyFader all the old
scriptyFader actions caused java errors! (panic) then I clicked the
clear java errors button in the actions palette and everything
worked just fine!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Walter,

I do see the 0.3.1 and everything works as it should… no errors.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Walter

I would really like to use some custom buttons to navigate through a set of scriptyfader images as Sly here is asking. However it is the fade that I want as the transition, not the ‘slide’ of a carousel. Can you suggest an option for this?

take care
jim


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

You can use the ScriptyFader Thumbnail Action to create individual buttons for each option in your fader (like the presets on a car radio). There isn’t anything like the Previous / Next buttons in Carousel, though.

Walter


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks for that Walter. I’ve just built my first Fader and just wanted to know why, when I have one Fader and three FaderOptions, each with images inside, I am able only to scroll through three frames using the FaderThumbnail. Basically there are only 3 visible frames but 4 created in the freeway document. Any explanation for the one dropped?

Here is a link to the rough page, with some placeholder images and buttons to test the action:

http://udio.co.uk/gallery2011.html

jim


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

You have to provide at least one navigation item (thumbnail) for each element in your fader, or do entirely without navigation and use the auto-fade setting to cycle through the elements in order. It’s not that all your items aren’t there, it’s that you can only get them to show when you click on the control to do so. No control, no element.

Walter

On Sep 21, 2011, at 9:22 AM, james morrison wrote:

Thanks for that Walter. I’ve just built my first Fader and just wanted to know why, when I have one Fader and three FaderOptions, each with images inside, I am able only to scroll through three frames using the FaderThumbnail. Basically there are only 3 visible frames but 4 created in the freeway document. Any explanation for the one dropped?

Here is a link to the rough page, with some placeholder images and buttons to test the action:

http://udio.co.uk/gallery2011.html

jim


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options