[Pro] scripty lightbox problem

i am working on a page dedicated to my band “walking inches”. i tried to put media-files on a page shown as a lightbox by using script lightbox. it works fine but when the hovering box is closed the background from my page turns white.
has anybody suggestions about this behavior??

thanks ,tom


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

me again. i forgot the location. you can see the page at:

http://www.walking-inches.de

the scripty lightbox effect is located at “media” on the right side “straßenmusikfestival Osnabrück -”


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The movie that you are importing into the lightwindow has a complete page in along with it, it’s not a fragment the way it’s supposed to be. That page’s body tag (and styles for same) are being injected into your page, and that’s what’s causing the problem. There’s two ways to fix this. Either, instead of linking to an HTML page, link directly to the Flash movie you want to play, or apply the PHP Make Insert Page Action to the osna.html page in Freeway. I would recommend the former rather than the latter.

Walter

On Sep 26, 2011, at 3:53 PM, tom_kemper wrote:

me again. i forgot the location. you can see the page at:

http://www.walking-inches.de

the scripty lightbox effect is located at “media” on the right side “straßenmusikfestival Osnabrück -”


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

hi walter,

and many many thanks for your help.
the page for the lightbox content will be a gallery of images. so i changed the background color for that gallery (it doesn’t exist yet) and … voila … the color is the right one.

many thanks, tom


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

No, you really cannot use a complete page as the endpoint for a ScriptyLightbox link. The only exception to this iron-clad rule is if the page in question resides on a different server than your own. In that case, ScriptyLightbox will create an iframe to hold it, and everything will be fine. When the page comes from your own server, SL assumes that you know what you’re doing, and have properly created a “page fragment” with your content, not a complete page with an HTML, head, and body tag and content. The error you saw was mild compared to what happens in certain versions of IE – they just blow up and take Windows with them.

Try applying the PHP Make Insert Page Action to your second page, and that will fix the problem in the correct manner. This may cause your gallery on that page to stop working, though, so you may want to re-think exactly what you plan to place in this lightbox.

Walter

On Sep 26, 2011, at 5:25 PM, tom_kemper wrote:

hi walter,

and many many thanks for your help.
the page for the lightbox content will be a gallery of images. so i changed the background color for that gallery (it doesn’t exist yet) and … voila … the color is the right one.

many thanks, tom


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options