[Pro] Send Form Action and blank emails

Hi.
I have been using the Send Form action on 2 sites for a while and it works really well. My client has just been in contact to tell me that they get a few emails every so often which don’t contain any details from the form.
I’m guessing that people are just clicking submit without entering any info in the fields?
Is there an easy way to prevent this or is it just one of those things?

I’m using Freeway Pro 714.

Thanks.


freewaytalk mailing list
email@hidden
Update your subscriptions at:

With a form field selected in Freeway, you can make it required in the
Inspector palette. Standard browsers won’t allow the form to be submitted
if these fields are empty, so of course this is only useful for individual
non-optional fields. Name, email and message would seem like obvious ones
to typically make required.

Simon

On Fri, Sep 6, 2019 at 11:20 AM TPW email@hidden wrote:

Hi.
I have been using the Send Form action on 2 sites for a while and it works
really well. My client has just been in contact to tell me that they get a
few emails every so often which don’t contain any details from the form.
I’m guessing that people are just clicking submit without entering any
info in the fields?
Is there an easy way to prevent this or is it just one of those things?

I’m using Freeway Pro 714.

Thanks.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:

Thanks for the quick reply.
That’s exactly what I was hoping for but I had a look in the inspector palette and can’t find any options to make the field required?

Brian.


freewaytalk mailing list
email@hidden
Update your subscriptions at:

Those options are in the Output tab of the Inspector (when the field is selected – corner handles showing). The output tab is the third from the left. All aspects of the Inspector are contextual – you only see options that apply to the selected item, or the page itself if there is nothing selected.

Walter

On Sep 6, 2019, at 7:09 AM, TPW email@hidden wrote:

Thanks for the quick reply.
That’s exactly what I was hoping for but I had a look in the inspector palette and can’t find any options to make the field required?

Brian.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:

Hi Walter.

I’m wondering if I’ve set something up wrong or am missing something. When I select a form item on my page (corner handles showing), the output tab (third from left) shows - Name, Value, Type, Maximum length, Size, Access Key - but nothing i can see in terms of ‘required’.

Brian.


freewaytalk mailing list
email@hidden
Update your subscriptions at:

Are you using Freeway 7? It’s been a while, and I don’t recall if these features were added in 6 or 7. I have 7.1.3 here, 7.1.4 is the latest version. Also, is your page itself set to output in HTML5 or an older version of HTML? These features are a part of the HTML5 spec.

Walter

On Sep 6, 2019, at 8:04 AM, TPW email@hidden wrote:

Hi Walter.

I’m wondering if I’ve set something up wrong or am missing something. When I select a form item on my page (corner handles showing), the output tab (third from left) shows - Name, Value, Type, Maximum length, Size, Access Key - but nothing i can see in terms of ‘required’.

Brian.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:

Yes I’m using Freeway 7.1.4 but it turns out the page was set to an older version of HTML. I have just selected HTML5 and I now have many more options including a ‘required’ field. That’s fantastic! Thank you very much for the solution and quick replies.

regards,
Brian.


freewaytalk mailing list
email@hidden
Update your subscriptions at: