[Pro] The Exhibeo 2 Mystery

I’ve tried the Photoswipe theme in the new Exhibeo. I like the design and setup. But here’s the thing. When clicking the thumbnails the images open up to the right and then jumps into full view. Sometimes. And when using the forward arrow half of the images disappears to the right and stays there. See the link at the bottom.

The odd thing is, used on another sight everything works flawlessly. Have a look: http://charterinmallorca.com/gallerytest.html

I have now exhausted my options and different settings to find a solution. Anybody (Joe, are you there?) care to ellaborate?

Kind regards,
Jon

PS. I’m using the Freeway forum rather than the Exhibeo one, as I would think I get a larger audience here.

http://sail-chartering.com/test2/gallerytest.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Hi Jon,

I haven’t quite unraveled the mystery… but there is a fair amount of rather tricky stuff going on at the sail-chartering site. There is the Background Supersizer action, also your construction method-- giving percentage % units to some items vertical dimensions. Some un-needed floats… It just seems like a lot going on that would concern me without the gallery difficulty.

The charterinmallorca page is a lot more traditional in its construction, has much less questionable stuff which might interfere. So, without saying so definitely, perhaps some simplification is needed-- perhaps some alternative construction?

I’m assuming you’re using Freeway 7?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Hi Jon,

Looks like it’s being caused by the center align that’s applied to your body tag. If you remove that and instead use center alignment on text or items then it should work as expected. I’ll see if there’s something we can do on our end to prevent it happening in the first place.

Actually, I just had a look and a quicker fix might be to add the following style to the page:

.pswp__img { left: 0; }

You can either add this to to the “Before ” section of the HTML Markup dialog (from the Page menu), or open the Edit Styles dialog (from the Edit menu) and type ".pswp__img” (no quotes) into the Tag field (not name - entering it in Tag will force the style to be published whereas named styles need to be applied to objects or text). You’ll then need to click the Extended button and enter “left” in the Name field and “0” in the Value field (both with no quotes).

Cheers,
Joe


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Thank you both for coming back.

Ernie, I will certainly simplify everything. At the moment this is just a test site, but of course if I’d been fully responsive in my actions I would have done everything right from the start. But I’m learning bit by bit. Thanks also to people like you.

Joe, I will do as you instructed, one way or the other, but first I will prettyfy the page according to the comments from Ernie here. Then I’m sure everything will be on track.

Jon


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Joe,

FYI after doing a quick page clean up I tried your 3 different suggestions and the solution that worked was adding the the style to “Before ” section via HTML markup. The other 2 didn’t change anything.

Thank you. And I’m back on track.

Kind regards,

Jon


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options