Problems with HTML mark up

I’m putting together a site that has e-commerce with Mal’s and the client has also requested a search facility - I’m using Atomz.

My knowledge of HTML is limited to say the least - but I’ve managed to get the search working by using the Multiple Forms Action. I’ve also (after much hair-tearing!) managed to get the word ‘Search’ to disappear on clicking but, try as I may, I can’t get this to appear in the font, size and colour I want (Verdana, 10pt, dark grey). I’ve tried inserting extra code in the Mark up box but have only achieved some really strange results!

I’d be really grateful if somebody could tell me where I’m going wrong! You can see one of the offending pages at: http://www.airfieldgroundlighting.com/Osram/osrampk30d.html

The HTML mark I’ve used is:

Hazel


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

You want to add the style to your input. Try this:

  1. Click on the text input field.
  2. Select Item > Extended from the main menu
  3. In the dialog, make sure the < INPUT > tab is selected, then press
    New.
  4. In the name field, enter style
  5. In the value field, enter color: #666; font: 10px Verdana, sans-
    serif;
  6. Okay the stack of dialogs, and preview.

You can also do this by applying a classname to the field and
defining a class style for inputs in the Edit Styles dialog. If you
have more than one to do, then do that.

Walter

On Apr 2, 2008, at 7:31 PM, Hazel Alemany wrote:

<input type=“text” name=“sp_q” style="width:154px; border:0px
solid; height:15px; padding:2px 2px; position:relative; size=“9”; "
value=“Search” onfocus=“if
(this.value==this.defaultValue) this.value=’’;”>


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Many thanks Walter . . . but I still can’t get it to work. Think I’m being thicker than usual!

The Extended tabs for the Mark up are < >

and but it doesn’t matter which one I put the style in as you suggested it still doesn’t work.

Any other suggestions would be greatly appreciated - just wish I understood more than I do!

Hazel


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Then you don’t have the text input itself selected, but rather its
parent item. Try Command-clicking directly on the text input. That
should change the selection point to the text input.

Walter

On Apr 3, 2008, at 9:14 AM, Hazel Alemany wrote:

Many thanks Walter . . . but I still can’t get it to work. Think
I’m being thicker than usual!

The Extended tabs for the Mark up are < >

and but
it doesn’t matter which one I put the style in as you suggested it
still doesn’t work.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sorry for taking so long to get back to you but my mac ‘died’ shortly after sending the last email. Now resurrected, but I’ve only just got it back from the repairers!

Many, many thanks Walter . . . it works! You’ve been a lifesaver - and incredibly patient with me!

Best wishes
Hazel


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options