Query re display of page code oddity

FW produces pages of html code. When i view them on Internet - great, all is fine.

When I view that same page in my HTML s’ware I see the code as expected = line by line, plenty of spaces to make reading easy. It means I can check that my imported html code is OK (I change nothing - just look)

However, when I click to view that page in a browser the code text is displayed without line feeds or spaces - not the page as seen on internet.

Is there some way of NOT seeing this compressed html code version and seeing how it would look on Internet ?

Regards
Nick


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 12 Oct 2008, at 10:51, NicolasAllan wrote:

FW produces pages of html code. When i view them on Internet -
great, all is fine.

When I view that same page in my HTML s’ware I see the code as
expected = line by line, plenty of spaces to make reading easy. It
means I can check that my imported html code is OK (I change nothing

  • just look)

However, when I click to view that page in a browser the code text
is displayed without line feeds or spaces - not the page as seen on
internet.

That might be because it’s not using the stylesheet that Freeway makes
to format the site as it should be. I might stand to be corrected on
that one though …

Is there some way of NOT seeing this compressed html code version
and seeing how it would look on Internet ?

Use Freeway to ‘Preview in Browser’.

best wishes,

Paul Bradforth

http://www.paulbradforth.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sometime around 12/10/08 (at 05:51 -0400) NicolasAllan said:

when I click to view that page in a browser the code text is
displayed without line feeds or spaces - not the page as seen on
internet.

When you say ‘code text’ do you mean viewing the source HTML rather
than the rendered web page? So you’re checking out the actual HTML
code?

If so, then you are probably looking at code that’s been produced
with your document set to ‘More Efficient’ rather than ‘More
Readable’ output mode. This produces exactly the same code - EXCEPT
that there is no unnecessary padding to present a more readable code
display. Browsers don’t need that nice indented structure or
extraneous returns, the only reason they are there is to make the
code easier for us poor humans to handle if we want to poke around in
it ourselves.

With your Freeway document open, choose File > Document Setup, then
click the Output tab. The second menu in that pane is the ‘HTML code’
one. Set this to More Readable rather than More Efficient, then
output your site again.

Any use? Or did I misunderstand the problem? If so, could you post a
link to a page that shows the issue?

k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

What a marvellous Forum (and friends who help).
Off to check some things as suggested - and will respond tomorrow (Monday).
Nick


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options