Removing underlines in links

Hi all,

I’m having trouble trying to remove underlines from links. I have created a style which I would like for my heading links and have not chosen underline. I have also selected items manually and set the links properties so underline is off. Despite this, when I retrieve stories from our database and apply the style with PHP there are always underlines there.

I’m guessing there is some way to do this with extended attributes but I’m afraid I have no idea how to do it. If anyone could offer a suggestion how to remove underlines from links I would be most appreciative.

cheers

'k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

While the link is highlighted,
Go to:
extended > and enter:

text-decoration
none

/ Omar

::: Communication to improve civilisation :::

s_ip

On 22 maj 2012, at 02:41, Kim Kohen email@hidden wrote:

Hi all,

I’m having trouble trying to remove underlines from links. I have created a style which I would like for my heading links and have not chosen underline. I have also selected items manually and set the links properties so underline is off. Despite this, when I retrieve stories from our database and apply the style with PHP there are always underlines there.

I’m guessing there is some way to do this with extended attributes but I’m afraid I have no idea how to do it. If anyone could offer a suggestion how to remove underlines from links I would be most appreciative.

cheers

'k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 22/05/2012, at 1:52 PM, okn wrote:

While the link is highlighted,
Go to:
extended > and enter:

text-decoration
none

If I highlight a link I don’t see anywhere to choose extended. I can’t actually do it on my links directly (they’re generated dynamically via PHP) but I can’t even see how to do it on a standard link.

'k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Highlight your link text, then press Apple-K (Edit / Hyperlink). The Extended button is near the bottom of the dialog, on the right side.

Walter

On May 22, 2012, at 10:16 AM, Kim Kohen wrote:

On 22/05/2012, at 1:52 PM, okn wrote:

While the link is highlighted,
Go to:
extended > and enter:

text-decoration
none

If I highlight a link I don’t see anywhere to choose extended. I can’t actually do it on my links directly (they’re generated dynamically via PHP) but I can’t even see how to do it on a standard link.

'k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

You can use the Text Link Style action which is applied to an HTML container and gives you the option to turn off underlining on all links within that container - ie doesn’t have to be applied directly to a link.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 23/05/2012, at 12:34 AM, Walter Lee Davis wrote:

Highlight your link text, then press Apple-K (Edit / Hyperlink). The Extended button is near the bottom of the dialog, on the right side.

This is still eluding me. I have changed the extended attributes of the style and I’m still getting underlines. I place a HTML item on the page, assign the style and it displays in Page mode without an underline but when I Preview or publish it the underline appears. I’ve selected the text and changed the extended attributes of the hyperlink and it remains underlined. The source is:

This is a linked heading

which tends to indicate the "none" extended attribute its set but somewhere along the lone Freeway is adding the underline - I think at the style. Does anyone have any other suggestions on how to stop these underlines?

freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Text-decoration is a css style, and so requires the style=" " to contain
it, i.e. style="text-decoration: none; " I wouldn’t put the style inline
like that, but if you insist then command-k (Edit>Hyperlink) open the
Extended dialog window and type style into the first box and then
text-decoration: none; into the second. This will cause Freeway Pro to
put the style attribute inline on the anchor tag.

The problem with putting the text-decoration attribute inline is that it
only works on that one link anchor. If you want all links on the page, or
just links in certain html boxes to have that appearance, then you have to
repeat that with each one. The simple css way to kill all the link
underlines is to do it with a style.

Here’s a simple recipe:
1 Open the Edit Styles window
2 Make a new style
3 in the box marked Tag (right pane, top left) type a lowercase a
4 in the box marked Name, delete whatever Freeway has put into it. Press
the Tab key to exit focus on that box and keep Freeway from trying to fill
it again
5 Open the Extended dialog (button is upper right)
6 Make a new attribute
7 Make the name text-decoration and the value none
8 Close all the style windows
9 Press command-p

You’re done. Every link you make will automatically display no underline,
and you just made Freeway jump a hoop for you!

Bonus: you can use the style you just made to set the color of all your
links as well… in the Edit Styles window, click the plus sign in the
Character segment of the right pane and choose Color… omg, you are learning
CSS! :slight_smile:


Ernie Simpson

On Wed, May 23, 2012 at 2:23 AM, Kim Kohen email@hiddenwrote:

On 23/05/2012, at 12:34 AM, Walter Lee Davis wrote:

Highlight your link text, then press Apple-K (Edit / Hyperlink). The
Extended button is near the bottom of the dialog, on the right side.

This is still eluding me. I have changed the extended attributes of the
style and I’m still getting underlines. I place a HTML item on the page,
assign the style and it displays in Page mode without an underline but when
I Preview or publish it the underline appears. I’ve selected the text and
changed the extended attributes of the hyperlink and it remains underlined.
The source is:

This is a linked heading

which tends to indicate the "none" extended attribute its set but somewhere along the lone Freeway is adding the underline - I think at the style. Does anyone have any other suggestions on how to stop these underlines?

freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Here’s an even shorter set of steps to the same end:

  1. Click on the pasteboard, so nothing on the page is selected.
  2. In the Inspector, move to the style tab (second from left) and open the Links segment.
  3. Click once on each of the U buttons to the right of the Link, Visited, Hover, Active style pseudo-classes. The visual feedback on the button icons is nearly invisible, but if you’re watching the designed page, you’ll see all of the underlines disappear immediately.

That’s it, you’re done. If you’ve done this on a master page, it’s now true for the entire site.

Walter

On May 23, 2012, at 4:15 AM, Ernie Simpson wrote:

The simple css way to kill all the link
underlines is to do it with a style.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 23/05/2012, at 6:15 PM, Ernie Simpson wrote:

Text-decoration is a css style, and so requires the style=" " to contain
it, i.e. style="text-decoration: none; " I wouldn’t put the style inline
like that, but if you insist then command-k (Edit>Hyperlink) open the
Extended dialog window and type style into the first box and then
text-decoration: none; into the second. This will cause Freeway Pro to
put the style attribute inline on the anchor tag.

Many thanks, i’ll try this in the morning.
'k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options