ScriptyLightbox2

Many thanks Walter for your quick response

Matt.


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Walter, I recently found a way to run IE9 on my Intel iMac legally and free of charge:

It’s great because it allows me to test the sites I create in Freeway, in the latest version of Microsoft’s “attempt at a browser.” :slight_smile:

I was please to see the shadow I’ve applied to my CSS Menus actually displays in IE9 (in Windows7). Menu shadow never worked at all in IE6 or IE7 or IE8 (in WinXP). However, I did find a problem in IE9 with regard to ScriptyLightbox2.

The reason I even use ScriptyLightbox2 is so I can make some graphics or even HTML content appear to hover above the existing page, rather than force a jump to a new page or open a new window. All Mac browsers work fine to do that with ScriptyLightbox2, and even IE8 on WinXP works fine too. Chrome and Firefox on Windows also work perfectly to do that. But IE6 & IE7 & IE9 cause the ScriptyLightbox2 content to open on a new page, rather than hover the content above the existing page.

If it were only IE6 & IE7 that had this problem, it wouldn’t be a big deal. But since IE9 also has the problem, I believe it needs to be investigated. To do that, please test the following page in my site in IE6 or IE7 or IE9:

http://www.kiramek.com/japanese/products/540.html

• Click on the Siren/Speaker in that photo.

• Click on the block of icons beneath the 540HS.

Either of those clicks should cause the content to appear above the existing page. But as I said, in IE6 & IE7 and IE9, the content appears on a new blank page. That is the problem. It should hover above the EXISTING page, not open in a new page.

I look forward to hearing your thoughts.

–James Wages


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Walter,

Here is a video I just made showing the problem clearly:
http://www.kiramek.com/21test95/ScriptyLightBox2_Woes_in_IE9.mov

The first part of the video shows the problem in IE9 (running in Windows7). For a split second you can see the frame of where the content should appear hovering above that page, but then the browser opens the content in a new blank page.

The second part of the video shows Chrome running in Windows7. No problems at all – you can see the content properly appears above the existing page.

Again, I would appreciate hearing your thoughts on how we can address this problem.

Thank you,

James Wages


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I’m looking at this. Thanks for the link to the VirtualBox recipes. I’ve been having to cadge time on my wife’s office computers to look at things in 9, because I don’t want to upgrade my VMWare and lose IE8. This is a much neater solution.

Walter

On Feb 15, 2012, at 2:03 AM, JDW wrote:

I look forward to hearing your thoughts.


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Walter, I should add a couple more things…

In IE9 you can see a tiny “broken document” icon just to the right of the address bar. You can see that in my video. Clicking that gives you a special “IE9 Compatibility View.” But even in that view, what you see in my video remains true – the content won’t appear hovering over the existing page.

But the really nifty thing about IE9 is that you can view how the page would look in IE8 and in IE7, simply by clicking on the spiked-wheel icon (directly beneath the red “X” close box, and choose “Developer Tools” and then set which browser you like under the “Browser Mode” menu that appears at the bottom of the browser window. I verified it works perfectly, just like the actual copies of IE7 and IE8. That feature allows you to confirm my problem; namely, that ScriptyLightBox2 content will hover above the existing page perfectly in IE8, but it will only open in a new page in IE7 and IE9.

I look forward to hearing your thoughts when you have time.

Best,

James W.


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I tried following the instructions you linked to yesterday, and was not able to download the IE9 image. It tried to come down in 7 parts, and it would consistently get the first couple of parts, then break on the third. I may have to visit the BigUglyStore and buy a retail copy of Windows 7 in order to take this any further.

Walter

On Feb 16, 2012, at 2:18 AM, JDW wrote:

Walter, I should add a couple more things…

In IE9 you can see a tiny “broken document” icon just to the right of the address bar. You can see that in my video. Clicking that gives you a special “IE9 Compatibility View.” But even in that view, what you see in my video remains true – the content won’t appear hovering over the existing page.

But the really nifty thing about IE9 is that you can view how the page would look in IE8 and in IE7, simply by clicking on the spiked-wheel icon (directly beneath the red “X” close box, and choose “Developer Tools” and then set which browser you like under the “Browser Mode” menu that appears at the bottom of the browser window. I verified it works perfectly, just like the actual copies of IE7 and IE8. That feature allows you to confirm my problem; namely, that ScriptyLightBox2 content will hover above the existing page perfectly in IE8, but it will only open in a new page in IE7 and IE9.

I look forward to hearing your thoughts when you have time.

Best,

James W.


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I tried following the instructions you linked to yesterday, and was not able to download the IE9 image.

I tried to download them all but the only one I got was IE6 - the others all broke (didn’t want IE6!)

Now it wont let me download them again as it tells me they exist already.

Remind me how I get to see invisible files/folders with a leading period under Snow Leopard. I used Transmit but I am sure there is an easier way

David


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Open Terminal, use cd to navigate to the folder, then type

open .

and press return.

Or type Shift-Command-G in Finder, and type in the path to the folder there.

Walter

On Feb 16, 2012, at 5:08 PM, DeltaDave wrote:

I tried following the instructions you linked to yesterday, and was not able to download the IE9 image.

I tried to download them all but the only one I got was IE6 - the others all broke (didn’t want IE6!)

Now it wont let me download them again as it tells me they exist already.

Remind me how I get to see invisible files/folders with a leading period under Snow Leopard. I used Transmit but I am sure there is an easier way

David


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks

I am having another go at the IE7 download

D


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Walter and DeltaDave,

I did not download all 3 VM’s because you don’t need to. As I posted yesterday, IE9 allows you to go into it’s Developer section and change IE9 to emulate IE7 and IE8. I have true Windows PCs running IE7 and IE8, and I have compared them with the IE7 and IE8 modes of IE9, and I can tell you that IE9 simulates IE7 and IE8 perfectly on all the content I tried.

I had success at copying and then pasting the following line in the Terminal, to download the IE9 VM:

curl -s https://raw.github.com/xdissent/ievms/master/ievms.sh | IEVMS_VERSIONS="9" bash

It takes a while to finish all the downloading, but it worked for me on the first try. But be sure to download and install the latest version of Virtual Box first, then copy and paste the line above into the Terminal. Once downloaded, you need only open Virtual Box, and your VM will appear there ready to go.

–James W.


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

It was during the download of Windows 7 + IE9 that I was having this experience. My piddly T1 line is no match for your genuine Japanese broadband connection, I fear. I got the first of 7 images in about an hour, then the second one bombed out half-way through, the script skipped ahead and started downloading the third, and I decided I’d had enough of that.

Walter


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I’m on a relatively slow 12Mbps ADSL line here at the office, Walter. But at home, I have a 100Mbps fiber line. I pay $70/month for the fiber line.

:slight_smile:


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Kill me now, so that I may reincarnate in Japan! 1.5mbps symmetrical == $325/mo. DSL was wayyyy less, both in dollars and upstream speed, and didn’t work after a rain, or on alternating Tuesdays.

This neighborhood was wired with copper some time during the Hoover administration, and they haven’t ever changed it. I was all excited last summer when the phone company brought fiber all throughout the neighborhood. I can look out my back windows and see it gracefully looping from pole to pole, right behind my house. But they “don’t have enough capacity at the central office” according to the sales people, so they don’t know when they’ll get around to putting the last 50 feet (from the pole to my chimney) into place.

Walter

On Feb 17, 2012, at 1:03 AM, JDW wrote:

I’m on a relatively slow 12Mbps ADSL line here at the office, Walter. But at home, I have a 100Mbps fiber line. I pay $70/month for the fiber line.

:slight_smile:


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Walter,

I created a simple test page for you which exhibits the problem I spoke about in IE9:

http://www.kiramek.com/walter/

When I first created that page without any HTML Markup or Protaculous, it worked fine in IE9 (as well as any other browser). But I need to add code in Protaculous and in HTML Markup to make my search field work properly (code you gave to me in the past). I also have a splattering of HTML Markup code to add shadows to my CSSmenus. Furthermore, you recently gave me additional code to put in Protaculous that allows me to click anywhere in the ScriptyLightBox2 “Target” to have the Target close. But when I added all that code, the problem appeared again in IE9.

Again, the problem is that the content of the target does not hover over the existing page but instead it appears on a new, blank page.

I therefore believe this IE9 problem can be fixed with a modification to the code in HTML Markup and/or the code in Protaculous. However, that modification is beyond my capabilities. I would therefore appreciate hearing your thoughts.

Many thanks,

James Wages


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Somehow, you have a copy of Prototype 1.6.1 linked into the head of your page AFTER the link to Prototype 1.7.

Prototype 1.7 works fine with IE9, and Prototype 1.6.1 does not.

Check to ensure that you have the absolute latest version of Protaculous and ScriptyLightbox2. My guess is that the former is out of date, at least in your document. You should only ever have one link to Prototype and / or Scriptaculous in the head of your page, which is why I beat the jungle drums so loud every time I update anything. It’s not possible for a “scripty” Action to know which one of its peers will actually attach the libraries to any given page, so they all have to be running at a cooperative version level.

Walter

On Feb 20, 2012, at 4:03 AM, JDW wrote:

Walter,

I created a simple test page for you which exhibits the problem I spoke about in IE9:

Error 404: Not Found

When I first created that page without any HTML Markup or Protaculous, it worked fine in IE9 (as well as any other browser). But I need to add code in Protaculous and in HTML Markup to make my search field work properly (code you gave to me in the past). I also have a splattering of HTML Markup code to add shadows to my CSSmenus. Furthermore, you recently gave me additional code to put in Protaculous that allows me to click anywhere in the ScriptyLightBox2 “Target” to have the Target close. But when I added all that code, the problem appeared again in IE9.

Again, the problem is that the content of the target does not hover over the existing page but instead it appears on a new, blank page.

I therefore believe this IE9 problem can be fixed with a modification to the code in HTML Markup and/or the code in Protaculous. However, that modification is beyond my capabilities. I would therefore appreciate hearing your thoughts.

Many thanks,

James Wages


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Walter,

I have the latest version of ScriptyLightBox2, and I verified that in the bottom right corner of the Actions palette – version 0.6.

I thought I had the latest version of Protaculous. But when I checked the bottom right corner of the Actions palette just now, I see it says “0.6.5”. But even after installing the latest version a few moments ago, the version number in the Actions palette remains the same.

I downloaded version 0.7 from here:

http://actionsforge.com/actions/view/18-protaculous

I double-clicked it in the Finder. It told me it was replacing older actions in my FW document, and then I checked the version number in the Actions palette, but it was unchanged as “0.6.5”.

I deleted Protaculous from off my page (the only instance of it) and then reapplied it, but the version remains the same at 0.6.5.

Please advise.

Thank you,

James Wages


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Walter, problem solved!

The root problem was indeed the older version of Protaculous. And despite having double-clicked the Action in the Finder, and despite Freeway having led me to believe it was installed, Freeway in fact did not install it. I discovered that by digging into my “Library/Application Support/Freeway 5/Actions” folders. As you know there are two: one in my “home/library” and the other in my “hard disk/library”. There was no Protaculous action in my hard disk/library, but the was one in my home/library. I checked the version of that, and sure enough, Freeway lied to me about having “installed” version 0.7. The old 0.6.5 version was still sitting there in the Actions folder plain as day. So I manually deleted it and threw the new version in there, and then I saw the 0.7 version number propagate to all my open FW documents. I just checked in IE9 and all is well.

So thank you again.

I must say that this has hit me more than once in the past. I just forget about it as time goes on and then get hit with it over and over. The root problem is not my bad memory. The root problem is that Freeway leads me to believe that the Action I double-clicked in the Finder was installed. But in fact, it was not. I shouldn’t have to manually change the Action or restart Freeway or restart my computer to get this to work right. It should JustWork™! Grrr!

Anyway, thanks again. And if your snail-slow internet connection finally allowed you to download Virtual Box and IE9, let us know how it goes for you.

–James W.


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

After you deleted it from your page, but before you re-applied it, did you publish once? That seems to be the way to kick old bundle Actions off the island. The problem is that the Action gets cached in the document, so getting it off of one page isn’t even enough. You have to go through, page by page, and remove it from every page, publish the entire document once, and then re-apply it. Before you tell me, yes, I agree this is a pain in every dangly-bit there is. I have complained often and annoyingly about this. I am hoping it can get some love from the Weezards of Oxford one day soon, when they have finished killing all the Orcs.

Walter

On Feb 20, 2012, at 7:38 PM, JDW wrote:

Walter,

I have the latest version of ScriptyLightBox2, and I verified that in the bottom right corner of the Actions palette – version 0.6.

I thought I had the latest version of Protaculous. But when I checked the bottom right corner of the Actions palette just now, I see it says “0.6.5”. But even after installing the latest version a few moments ago, the version number in the Actions palette remains the same.

I downloaded version 0.7 from here:

http://actionsforge.com/actions/view/18-protaculous

I double-clicked it in the Finder. It told me it was replacing older actions in my FW document, and then I checked the version number in the Actions palette, but it was unchanged as “0.6.5”.

I deleted Protaculous from off my page (the only instance of it) and then reapplied it, but the version remains the same at 0.6.5.

Please advise.

Thank you,

James Wages


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Walter, I Previewed a few pages in my site, but that did not result in making the new Action appear. I did not Publish the entire site, nor did I do a Publish Everything. But I would still argue that we shouldn’t be forced to do that. :slight_smile:

Thank you!

James W.


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Walter, I discovered yet another problem with ScriptyLightBox2 today. Unfortunately, having the latest version of Protaculous does not fix this problem.

The problem appears on pages where I display videos above the existing page via ScriptyLightBox2. The videos open and play perfectly. The problem is that when you click the close box, only the “frame around the video” vanishes, and the video remains there and continues to play. Sometimes if I scroll around the page and click like mad long enough it will go away. But it most cases, the video won’t go away until I double-click it (which makes it fill the screen) and then I pause or stop it.

I verified this problem exists in IE6 & IE7 & IE8 running under WinXP and also in IE9 running under Windows7. No problem in Chrome, Safari or FireFox on the Mac. And no problem in Chrome, Safari or FireFox on Windows. It’s only IE on Windows.

Here is the test page:

http://kiramek.com/japanese/products/hv100.html

Click on either of the WindowsMedia buttons to see the problem in IE.

Your thoughts would be appreciated.

Thanks,

James Wages


actionsdev mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options