SSL and order form

Eeek!

I set up a web site with order form for my brother’s business and it was working well. However, he had to install an SSL certificate.

The web site appears with the https and padlock symbol, but the form can’t be submitted (keeps coming back with the error page).

Do I have to do something special to the form?

Thanks for anyone’s assistance (in advance).

https://www.fincal.com/orders.php


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

There are several things wrong with your form.

Most notably the way you have added the ‘guidance’ text ie Name, Company, Delivery Address - doing it this way means that these default values will be sent if the Submit button is clicked and the inbuilt error checking features wont work.

Your page is designated with the .php suffix - this is not necessary when using the PHPFF action and all it does is remove your ability to preview the file/page locally.

As a step towards finding out where your problem lies enable “A page for each error” in the 1st parameter in the action palette and name these error pages appropriately for the error ie server-erropr.html, not-in-domain.html etc.

Make sure you have the latest version of the action (2.4.4 I think) FreewayActions.com | PHP feedback form

Once you have done that, reupload and test and see what error page is displayed.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Also, please be aware that even though the page is secure, the email that gets sent will not. The best thing to do for this type of page is to use the built in Freeway Shop Actions.

The service used is free if you use a merchant provider such as Paypal, or $8 a month if you want to accept credit card payments. It’s completely secure and incredibly simple to use (see the guide in the Freeway Reference here: http://www.softpress.com/support/index.html#manuals

I hope this helps,
Joe


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Joe and many thanks for your assistance. Unfortunately, my level of expertise does not extend far.

The php suffix occurred automatically when my brother applied for the certificate (which is law). I don’t know how to change that. The hosting company must have done something and the prefix changed.

I got lost when you wrote: “As a step towards finding out where your problem lies enable “A page for each error” in the 1st parameter in the action palette and name these error pages appropriately for the error ie server-erropr.html, not-in-domain.html etc.”

Sorry, but I just do pictures and text.
Regards
Greg


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sorry, but I just do pictures and text. Regards Greg

But you must have set up the PHPFF action.

The settings are in there.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

:slight_smile: Yes, Dave, but I did it so long ago, I’ve forgotten. It’s not my normal “job”. However, I rearranged a few things and the form seems to be working now, so I can only thank Joe for his help. I will endeavour to learn how to set up the cart facility. Maybe my brother might even pay me.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options