Stray Graphic

I seem to have dropped a small graphic onto my page without creating a graphic box to drop it into. It shows as a grey item in page preview but in page mode I cannot select it to delete it. Any ideas?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Using the Site view in the left pane instead of the Page view you will see every object that has been placed in the layout. One of them is the culpret.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks but that doesn’t show it. Using the left pane and choosing the option to “show items” lists them all except the culprit. Clicking each one in turn, it selects an item on the page but none of them select the errant graphic.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

For the time being I’ve cheated and put a white graphic over it to hide it!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks but that doesn’t show it.

That seems unlikely. Try deleting each item one at a time. One of them has to be the offender.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Doesn’t make sense to me either, but deleted each item in turn (but undoing delete to save a lot of typing!) but the stray graphic stayed!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Oh - and I can’t see it in the source code either!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Try Edit>Resources for the page in question - if you have dragndropped something onto the page it will show up there.

Though it should, as chucka suggested, also show in page/site side panel.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The other possibility is the page is damaged somehow. Have you tried starting a new document to see if you can recreate the problem?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

David, for some reason that doesn’t show it either.

Chuchamuck - thanks for all the suggestions but none of the other pages based on the same master, created before or after this page, display that problem. It’s quite a big page so rather than rebuild, I’ll leave my small white graphic there to hide it.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sometime around 25/9/08 (at 02:18 -0400) Hector’s Dad said:

It’s quite a big page so rather than rebuild, I’ll leave my small
white graphic there to hide it.

This is a curious problem, and I’d rather it was understood properly
before you just ignore it. I have a couple of theories, but without
actually seeing something it seems silly to speculate further than
has already been done.

Could you perhaps make a copy of the Freeway document, strip out
all pages other than the troublesome one, remove any upload details
that might be set (important basic security step), and make that
document available somewhere for downloading so I could take a look?
(Or email it to me directly - my address is in my profile for web
users and in every message for email users.)

k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

…none of the other pages based on the same master, created before or after this page, display that problem.

Interesting clue. This is not surprising if you made changes to the pages then changed the master. The pages could become disconnected to certain things on the master page.

Just occured to me…is there anything outside the page or master on the pasteboard?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

OK - will deal with request for more info a bit later.

Maybe it’s my lack of understanding of Freeway’s working methods. For example, I didn’t realise that using “publish site” creates a copy of the graphics etc. in Resources ready for upload. I’d already prepared a folder called images and placed that in the site folder expecting that to be referenced but of course it was duplicated.

I’ve created a menu on the master page but did not add the links until all the pages were built. Would this cause an issue - it is after all altering the master once all the pages built on it are there.

Another point, the graphic in question is a 15px square jpg file to be used as a bullet for a list (can’t find out how to add that code in Freeway so am manually placing the bullet - clumsy I know!) and whilst my “original” graphic is called bullet.jpg, whether using either copy & paste to produce a duplicate or creating a new graphic area and dragging in bullet.jpg from Resources, I’ve ended up with bullet.jpg, bullet1.jpg and bullet1a.jpg in Resources. How is it FW needs three copies of the same graphic which is used about 20 times across the site?

I don’t like the idea of giving up either but I appreciate this is getting tricky.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Maybe it’s my lack of understanding of Freeway’s working methods. For example, I didn’t realise that using “publish site” creates a copy of the graphics etc. in Resources ready for upload. I’d already prepared a folder called images and placed that in the site folder expecting that to be referenced but of course it was duplicated.

Do NOT put anything in the resources folder. No go area. All the published html ends up in the site folder, and although it isn’t necessarily a problem to put things in the media folder that you use on your site, it might be a good idea to have a central location you can pull photos and grapic objects from that you use without relying on the site folder.

I’ve created a menu on the master page but did not add the links until all the pages were built. Would this cause an issue - it is after all altering the master once all the pages built on it are there.

Changing the master after pages have been edited can break links to objects on a master.

Another point, the graphic in question is a 15px square jpg file to be used as a bullet for a list (can’t find out how to add that code in Freeway so am manually placing the bullet - clumsy I know!)

Strictly speaking that is perfectly fine. For a more css oriented way to do that take a look at this examle: thebigerns.com

…and whilst my “original” graphic is called bullet.jpg, whether using either copy & paste to produce a duplicate or creating a new graphic area and dragging in bullet.jpg from Resources, I’ve ended up with bullet.jpg, bullet1.jpg and bullet1a.jpg in Resources. How is it FW needs three copies of the same graphic which is used about 20 times across the site?

The way I understand it, Freeway keeps track of each page separately instead of as a site as a whole.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

(Must learn how to quote bits!)

I didn’t put anything in the resources folder - I created an images folder at the same level expecting FW to upload that. I now know :wink:

Had a look at the link you gave - I’m looking to use an image as a bullet - the css had I written it manually would have been:

.list li {
list-style-image: url(images/bullet.jpg);
line-height: 150%;
padding-bottom: 30px;
}

It’s the first line that’s relevant. Can’t see how to achieve this in FW


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Had a look at the link you gave - I’m looking to use an image as a bullet - the css had I written it manually would have been:

.list li {
list-style-image: url(images/bullet.jpg);
line-height: 150%;
padding-bottom: 30px;
}

It’s the first line that’s relevant. Can’t see how to achieve this in FW

At the very top of the site page is a link to the actual Freeway sample page. Although it is a FWPro 4 document, it’s the custom CSS styles in the editor that you want. Actually, in the left column of the site page is all the relevant code.

The “a” would be set in the tag field as well as the “a:hover” and “a:visited”. The last “a” tag has a name “linkaway” that would go in the name field.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options