Struggling with links

This is my first foray using Xway but I have been a Freeway user for years so forgive this basic question.
I created a simple site and cannot get the links to work as expected.
I made a cut-down version which shows my problem which is the ‘Airbnb’ link on the Contact page works as expected but the ‘contact’ link on the About page does not. As far as I can see, I’ve used the same parameters for both and the really odd thing is the ‘View web preview’ link in Xray shows both links working as expected but the ‘contact’ link on the About page doesn’t when published and viewed locally or on the server.
I can’t see how to attach the .xway file here but it is available here at this link if anyone can help.


Hi Andrew,

The links seem to be working fine for me. One thing to be aware of is that Xway’s internal web preview doesn’t follow links. One reason for this is because (like Freeway) it only publishes the current page. So you should test links by previewing in a browser. I previewed your document in Safari and Firefox, and the links worked without any problems.

HI Jeremy,
Thanks so much for taking a look so promptly. I hope I haven’t misled you but the links work OK, it is the link styling which isn’t working for me!
On the Contact page, the “Airbnb” link is charcoal underlined normally and ‘blue-gray’ underlined when hovered over. The “contact” link on the About page should be the same and displays as such in Xray’s web preview but shows as blue-gray for both normal and hover states when previewing in the browser.
Thanks again,

Hello again, Jeremy.
I think I’ve spotted my problem!!
The ‘visited’ link style was the same as the hover link style so once visited it wasn’t changing.
What I don’t understand is why clearing the cache doesn’t reset the link style…
Anyway, thank you again and keep up the good work with Xway.

This is because you have different visited link styles for the main box on those pages: on the “Contact” page, the default visited link style for main is Charcoal, but on the “About” page the default visited link style for main is Blue-Gray. It’s always a good idea to check how the default style for visited link is set, because Xway’s page view always displays the ordinary link style.

If you want main to have the same link styles on all pages, it would be best to set the styles on the master page: select main on the master page, and set the Text Color for Visited Link (in the Default Styles section of the Box Inspector. Then go to main on each instance page and turn on Use Master Style for Visited Link in the Default Styles section. Do the same for Link and Hover Link.

Crossed in the post!!!

I see your point about using master page styles but I didn’t want to change the link styling for the navigation…

Hi Andrew,

Well done for seeing how to fix the problem, but see my comments (just above) about doing this on a master page.

You probably have to clear the browser’s history rather than its cache. But a less disruptive way to do this (if you don’t want to lose your history) would be to open a private browsing window.


You won’t, so long as you set the link styles on main on the master page (in the Box Inspector) rather than on the master page directly (in the Page Inspector).

The trick to understand is that you can set styles for things inside a specific box by selecting that object and setting its styles from the panels on the right. This overrides styles set for the whole page, and the custom styles you set for that box don’t apply to anything that isn’t within the box.

Thanks Jeremy and Keith - I think I’ve got my head round the link styling and so far the rest of my new site in Xway is coming together OK.

I’m playing a lot with em, rem, % and vw for font sizing and box spacing / positioning; I was hoping I would only need these but it looks like I might have to delve into @media queries!!