Text encoding issue

I have an rss feed embedded in a page (thanks to Walter’s ReadFeed action). The action picks up the feed from my wordpress blog. My problem is that the wordpress blog seems to be encoded in UTF-8 while my Freeway site is encoded in Western ISO-8859-1. (I have encoding set to automatic in the document preferences).

The blog entries are displayed with weird characters as the content encoding doesn’t match the meta data.

Tried changing the encoding in Freeway to UTF-8 but this made no difference - it doesn’t seem to change pages already made.

Anything else I can do?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

HI David
Open the inspector palette and click on the third button across the top which is the: general HTML pages settings.

then where it says encoding (second from the bottom) change that from automatic to UTF-8.

then publish and it should now be a different encoding

max


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Answered my own question with a bit of poking around. For the record, Document Settings… allows you to set the default for new pages, but the inspector allows you to change this for any one page (under ‘Pages HTML Generation Settings’ tab).

So I’ve left the default as ‘automatic’ as recommended elsewhere and changed my troublesome page to UTF-8 and voila - problem solved!

I’ll leave it in automatic until/unless someone can give me a good reason for going one way or the other.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Max,

Looks like you posted your reply just as I posted my own. Obviously great minds…!

David

On 8 Dec 2008, 5:38 am, max wrote:

HI David
Open the inspector palette and click on the third button across the top which is the: general HTML pages settings.

then where it says encoding (second from the bottom) change that from automatic to UTF-8.

then publish and it should now be a different encoding

max


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options